Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Celestia issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
davydm
n00b
n00b


Joined: 06 Jan 2017
Posts: 27

PostPosted: Thu Aug 16, 2018 3:54 pm    Post subject: Celestia issues Reply with quote

I hope this is the right place to post this; please shout if I should move this somewhere else, but it seemed like the closest fit:

OpenGL is working fine on my system -- Steam games, glxgears, glxinfo (reports NVIDIA vendor, so all good). I'm using x11-drivers/nvidia-drivers=396.51 from official gentoo sources.

Today I installed Celestia so my son could check it out. The app shows the splash screen, then exits. From a console, I get a little more info by running:
Code:

# LIBGL_DEBUG=verbose celestia
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib64/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so
libGL: Can't open configuration file /home/daf/.drirc: No such file or directory.
libGL: Can't open configuration file /home/daf/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
*** Cannot find the double-buffered visual.
*** Trying single-buffered visual.
*** No appropriate OpenGL-capable visual found.


Everything my google-fu has brought me suggests that I should get this error for anything attempting to use opengl if I'm getting it for one. The mentioned .so files under /usr/lib64 exist. I apparently have the correct opengl selected:
Code:

# eselect opengl list
  [1]   nvidia *
  [2]   xorg-x11


As far as I can tell, Celestia should just run; yet stubbornly, it refuses to. Any help appreciated.
Back to top
View user's profile Send private message
davydm
n00b
n00b


Joined: 06 Jan 2017
Posts: 27

PostPosted: Thu Aug 16, 2018 4:08 pm    Post subject: Reply with quote

(update) I can work around this by changing /usr/lib64/libGL.so and /usr/lib64/libGL.so.1 to point at nvidia's libGL.so (they were pointing at mesa's) -- the question is: shouldn't
Code:
eselect opengl set
be doing this? Or is there a another better (more official) way to do this? And what repercussions can I face by manualy fiddling with these two links?
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 513
Location: Cape Town, South Africa

PostPosted: Mon Mar 25, 2019 12:50 pm    Post subject: Reply with quote

davydm wrote:
(update) I can work around this by changing /usr/lib64/libGL.so and /usr/lib64/libGL.so.1 to point at nvidia's libGL.so (they were pointing at mesa's) -- the question is: shouldn't
Code:
eselect opengl set
be doing this? Or is there a another better (more official) way to do this? And what repercussions can I face by manualy fiddling with these two links?


You ever get it to work?

Have similar issues here, and I know it used to work in the past.

Am using Nvidia.

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
davydm
n00b
n00b


Joined: 06 Jan 2017
Posts: 27

PostPosted: Mon Mar 25, 2019 1:25 pm    Post subject: Reply with quote

iandoug wrote:
davydm wrote:
(update) I can work around this by changing /usr/lib64/libGL.so and /usr/lib64/libGL.so.1 to point at nvidia's libGL.so (they were pointing at mesa's) -- the question is: shouldn't
Code:
eselect opengl set
be doing this? Or is there a another better (more official) way to do this? And what repercussions can I face by manualy fiddling with these two links?


You ever get it to work?

Have similar issues here, and I know it used to work in the past.

Am using Nvidia.

Thanks, Ian


No, unfortunately not. I had good intentions of filing a bug against the package, and forgot about it. However, I have filed a bug now: https://bugs.gentoo.org/681732
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum