Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blocks B al migrar openssl a libressl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Fri Mar 22, 2019 12:22 am    Post subject: blocks B al migrar openssl a libressl Reply with quote

Hola, esto del block B no lo entendi todavia y por eso les pregunto que se hace en este caso.

Estoy migrando de openssl a libressl siguiendo la guia https://wiki.gentoo.org/wiki/Project:LibreSSL y cuando llego al final de la guia emerge -q @preserved-rebuild me sale todo este lio

http://dpaste.com/2GX4VPT

Que deberia hacer?

Saludos.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1359

PostPosted: Fri Mar 22, 2019 11:33 pm    Post subject: Reply with quote

¿Tienes puesto libressl en USE en tu make.conf?
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Sat Mar 23, 2019 7:11 pm    Post subject: Reply with quote

Si, tal como indica la guia.
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1359

PostPosted: Sat Mar 23, 2019 8:06 pm    Post subject: Reply with quote

La guía dice que después de poner la USE en make.conf hagas: emerge -uvNDq world
¿Qué dice
emerge -puvND world
?
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Sat Mar 23, 2019 11:50 pm    Post subject: Reply with quote

Code:
emerge -puvND world


http://dpaste.com/0A8D7C1
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1359

PostPosted: Sun Mar 24, 2019 12:55 am    Post subject: Reply with quote

Tienes 3 paquetes que necesitan openssl:
    net-misc/curl
    media-video/ffmpeg
    dev-qt/qtnetwork

Si puedes prescindir de ellos, desinstalalos. En caso contrario, para los 2 primeros tienes que forzar sus USEs a libressl (en package.use). Para qtnetwork quizá puedas encontrar algún overlay con USE libressl. En el de Gentoo no hay posibilidad. Finalmente tendrás que añadirlos expresamente a la actualización:
Code:
emerge -uvNDq world net-misc/curl media-video/ffmpeg dev-qt/qtnetwork
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Sun Mar 24, 2019 1:54 am    Post subject: Reply with quote

Drastico final, desisto de libressl y vuelvo a openssl.

Muchas gracias quilosaq por tu tiempo y asitencia.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Mon Mar 25, 2019 12:02 pm    Post subject: Reply with quote

Fitap wrote:
Drastico final, desisto de libressl y vuelvo a openssl.

Muchas gracias quilosaq por tu tiempo y asitencia.


la manera mas sencilla de pasar eso es hacer un unmerge de los paquetes que te estan bloqueando...

Quote:
(dev-libs/openssl-1.0.2r:0/0::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-misc/curl-7.64.0:0/0::gentoo, installed)
>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_64(-)]) required by (media-video/ffmpeg-3.4.5:0/55.57.57::gentoo, installed)
dev-libs/openssl:0/0=[-bindist] required by (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, installed)
dev-libs/openssl:0=[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_64(-)]) required by (net-misc/curl-7.64.0:0/0::gentoo, installed)
dev-libs/openssl:0 required by (net-nds/openldap-2.4.45:0/0::gentoo, ebuild scheduled for merge)
>=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (media-video/ffmpeg-3.4.5:0/55.57.57::gentoo, installed)
dev-libs/openssl:0=[bindist=] (dev-libs/openssl:0=[-bindist]) required by (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, installed)


basicamente hace:
Code:
emerge -Cav dev-libs/openssl net-misc/curl media-video/ffmpeg net-nds/openldap dev-qt/qtnetwork
luego hace un:

Code:
emerge -DuNav world


deberias pasar el bloqueo sin dramas, si aparecen paquetes nuevos, hace el emerge -C y volve a intentarlo
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Thu Mar 28, 2019 12:04 am    Post subject: Reply with quote

Muchas gracias por responder pelelademadera, nose porque sigue queriendo instalar openssl sin que haya paquetes que lo tiren.

http://dpaste.com/32XCFD9
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Thu Mar 28, 2019 10:35 am    Post subject: Reply with quote

Fitap wrote:
Muchas gracias por responder pelelademadera, nose porque sigue queriendo instalar openssl sin que haya paquetes que lo tiren.

http://dpaste.com/32XCFD9


que te devuelve un?
Code:
equery d dev-libs/openssl


si no me equivoco equery pertenece a gentoolkit
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Thu Mar 28, 2019 11:59 pm    Post subject: Reply with quote

Code:
equery d openssl
 * These packages depend on openssl:

app-admin/lastpass-cli-1.3.1-r1 (!libressl ? dev-libs/openssl:0)
app-admin/sudo-1.8.25_p1-r1 (openssl ? dev-libs/openssl:0)
app-arch/libarchive-3.3.1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
app-crypt/qca-2.1.3-r2 (!libressl ? dev-libs/openssl:0)
                       (!libressl ? >=dev-libs/openssl-1.0.1:0)
app-crypt/rhash-1.3.6-r1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
app-emulation/spice-0.14.0-r2 (!libressl ? dev-libs/openssl:0[static-libs(+)?])
app-text/mupdf-1.14.0-r3 (openssl ? >=dev-libs/openssl-1.1:0[static-libs?])
dev-db/mariadb-10.2.22-r1 (!libressl ? >=dev-libs/openssl-1.0.0:0)
dev-db/mysql-connector-c-6.1.11-r1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-lang/python-2.7.15 (!libressl ? dev-libs/openssl:0)
dev-lang/python-3.5.5 (!libressl ? dev-libs/openssl:0)
dev-lang/python-3.6.5 (!libressl ? dev-libs/openssl:0)
dev-lang/ruby-2.4.5 (!libressl ? dev-libs/openssl:0)
dev-lang/rust-1.29.1-r1 (!libressl ? dev-libs/openssl:0)
dev-libs/botan-1.10.17-r2 (!libressl ? <dev-libs/openssl-1.1:0[bindist=])
dev-libs/cyrus-sasl-2.1.26-r10 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libevent-2.1.8 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libzip-1.5.1 (!libressl ? dev-libs/openssl:0)
dev-libs/xmlsec-1.2.27 (!libressl ? dev-libs/openssl:0)
dev-perl/Net-SSLeay-1.820.0 (!libressl ? dev-libs/openssl:0)
dev-python/cryptography-2.2.2-r1 (!libressl ? dev-libs/openssl:0)
                                 (!libressl ? dev-libs/openssl:0[-bindist(-)])
                                 (!libressl ? >=dev-libs/openssl-1.0.2o-r6:0)
dev-python/m2crypto-0.24.0 (!libressl ? >=dev-libs/openssl-0.9.8:0)
dev-util/cargo-0.30.0-r1 (!libressl ? dev-libs/openssl:0)
dev-vcs/git-2.19.2 (!libressl ? dev-libs/openssl:0)
kde-apps/kopete-18.12.3 (jingle ? dev-libs/openssl:0)
media-libs/opusfile-0.11 (!libressl ? dev-libs/openssl:0)
media-video/ffmpeg-3.4.5 (openssl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-analyzer/nmap-7.70 (!libressl ? dev-libs/openssl:0)
net-dialup/ppp-2.4.7-r7 (!libressl ? dev-libs/openssl:0)
net-dns/bind-tools-9.12.2_p2-r1 (!libressl ? dev-libs/openssl:0)
                                (gost ? =dev-libs/openssl-1.0*[-bindist])
                                (gost ? >=dev-libs/openssl-1.1)
net-libs/libssh-0.8.6 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/libssh2-1.8.0-r1 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/libtorrent-rasterbar-1.1.12 (!libressl ? dev-libs/openssl:0)
net-libs/libvncserver-0.9.11-r1 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/neon-0.30.2 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-misc/curl-7.64.0 (curl_ssl_openssl ? dev-libs/openssl:0[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-misc/dhcp-4.4.1 (!libressl ? dev-libs/openssl:0)
net-misc/freerdp-2.0.0_rc4 (!libressl ? dev-libs/openssl:0)
net-misc/iputils-20180629 (!libressl ? dev-libs/openssl:0)
                          (!libressl ? dev-libs/openssl:0[static-libs(+)])
net-misc/openssh-7.9_p1-r4 (!libressl ? >=dev-libs/openssl-1.0.1:0[bindist=])
                           (!libressl ? <dev-libs/openssl-1.1.0:0[bindist=])
                           (>=dev-libs/openssl-1.1.0g:0[bindist=])
                           (dev-libs/openssl:0)
                           (dev-libs/openssl:0[static-libs(+)])
net-misc/socat-1.7.3.2 (!libressl ? dev-libs/openssl:0)
net-misc/spice-gtk-0.35 (!libressl ? dev-libs/openssl:0)
net-misc/tigervnc-1.9.0-r1 (!libressl ? dev-libs/openssl:0)
net-misc/wget-1.20.1 (!libressl ? dev-libs/openssl:0)
                     (!libressl ? dev-libs/openssl:0[static-libs(+)])
net-nds/openldap-2.4.45 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                        (!libressl ? dev-libs/openssl:0)
                        (ssl ? dev-libs/openssl:0)
net-voip/telepathy-gabble-0.18.4-r1 (!libressl ? >=dev-libs/openssl-0.9.8g:0[-bindist])
net-wireless/aircrack-ng-1.5.2 (!libressl ? dev-libs/openssl:0)
net-wireless/crda-3.18-r1 (!libressl ? dev-libs/openssl:0)
net-wireless/wpa_supplicant-2.6-r10 (!libressl ? >=dev-libs/openssl-1.0.2k:0[bindist=])
sys-fs/cryfs-0.9.9 (!libressl ? dev-libs/openssl:0)
sys-fs/cryptsetup-1.7.5-r1 (!libressl ? dev-libs/openssl:0[static-libs(+)])
                           (!libressl ? dev-libs/openssl:0)
www-client/falkon-3.0.1-r1 (!libressl ? dev-libs/openssl:0)
www-client/w3m-0.5.3_p20180125 (!libressl ? dev-libs/openssl:0)
x11-base/xorg-server-1.20.3 (!libressl ? dev-libs/openssl:0)
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Fri Mar 29, 2019 8:12 pm    Post subject: Reply with quote

por lo que veo:

kde-apps/kopete-18.12.3 (jingle ? dev-libs/openssl:0)

net-dns/bind-tools-9.12.2_p2-r1 (!libressl ? dev-libs/openssl:0)
(gost ? =dev-libs/openssl-1.0*[-bindist])
(gost ? >=dev-libs/openssl-1.1)

net-misc/curl-7.64.0 (curl_ssl_openssl ? dev-libs/openssl:0[static libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])

net-nds/openldap-2.4.45 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
(!libressl ? dev-libs/openssl:0)
(ssl ? dev-libs/openssl:0)



de esos paquetes chequea las flags, fijate que por ejemplo, por mas que tengas -ssl y +libressl si tenes activa la flag jingle en kopete, te va a poner de dependencia openssl.
en 2º caso fijate que bind-tools si tenes activa la flag gost, tiene de dependencia openssl.

En alguno de esos paquetes que te pase tenes el bloqueo, por ahi se me salteo alguno, pero esos son los que vi, chequea si tenes algun package.use que no te este dando dolores de cabeza por ahi...



saludos

Fitap wrote:
Code:
equery d openssl
 * These packages depend on openssl:

app-admin/lastpass-cli-1.3.1-r1 (!libressl ? dev-libs/openssl:0)
app-admin/sudo-1.8.25_p1-r1 (openssl ? dev-libs/openssl:0)
app-arch/libarchive-3.3.1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
app-crypt/qca-2.1.3-r2 (!libressl ? dev-libs/openssl:0)
                       (!libressl ? >=dev-libs/openssl-1.0.1:0)
app-crypt/rhash-1.3.6-r1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
app-emulation/spice-0.14.0-r2 (!libressl ? dev-libs/openssl:0[static-libs(+)?])
app-text/mupdf-1.14.0-r3 (openssl ? >=dev-libs/openssl-1.1:0[static-libs?])
dev-db/mariadb-10.2.22-r1 (!libressl ? >=dev-libs/openssl-1.0.0:0)
dev-db/mysql-connector-c-6.1.11-r1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-lang/python-2.7.15 (!libressl ? dev-libs/openssl:0)
dev-lang/python-3.5.5 (!libressl ? dev-libs/openssl:0)
dev-lang/python-3.6.5 (!libressl ? dev-libs/openssl:0)
dev-lang/ruby-2.4.5 (!libressl ? dev-libs/openssl:0)
dev-lang/rust-1.29.1-r1 (!libressl ? dev-libs/openssl:0)
dev-libs/botan-1.10.17-r2 (!libressl ? <dev-libs/openssl-1.1:0[bindist=])
dev-libs/cyrus-sasl-2.1.26-r10 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libevent-2.1.8 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libzip-1.5.1 (!libressl ? dev-libs/openssl:0)
dev-libs/xmlsec-1.2.27 (!libressl ? dev-libs/openssl:0)
dev-perl/Net-SSLeay-1.820.0 (!libressl ? dev-libs/openssl:0)
dev-python/cryptography-2.2.2-r1 (!libressl ? dev-libs/openssl:0)
                                 (!libressl ? dev-libs/openssl:0[-bindist(-)])
                                 (!libressl ? >=dev-libs/openssl-1.0.2o-r6:0)
dev-python/m2crypto-0.24.0 (!libressl ? >=dev-libs/openssl-0.9.8:0)
dev-util/cargo-0.30.0-r1 (!libressl ? dev-libs/openssl:0)
dev-vcs/git-2.19.2 (!libressl ? dev-libs/openssl:0)
kde-apps/kopete-18.12.3 (jingle ? dev-libs/openssl:0)
media-libs/opusfile-0.11 (!libressl ? dev-libs/openssl:0)
media-video/ffmpeg-3.4.5 (openssl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-analyzer/nmap-7.70 (!libressl ? dev-libs/openssl:0)
net-dialup/ppp-2.4.7-r7 (!libressl ? dev-libs/openssl:0)
net-dns/bind-tools-9.12.2_p2-r1 (!libressl ? dev-libs/openssl:0)
                                (gost ? =dev-libs/openssl-1.0*[-bindist])
                                (gost ? >=dev-libs/openssl-1.1)
net-libs/libssh-0.8.6 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/libssh2-1.8.0-r1 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/libtorrent-rasterbar-1.1.12 (!libressl ? dev-libs/openssl:0)
net-libs/libvncserver-0.9.11-r1 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/neon-0.30.2 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-misc/curl-7.64.0 (curl_ssl_openssl ? dev-libs/openssl:0[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-misc/dhcp-4.4.1 (!libressl ? dev-libs/openssl:0)
net-misc/freerdp-2.0.0_rc4 (!libressl ? dev-libs/openssl:0)
net-misc/iputils-20180629 (!libressl ? dev-libs/openssl:0)
                          (!libressl ? dev-libs/openssl:0[static-libs(+)])
net-misc/openssh-7.9_p1-r4 (!libressl ? >=dev-libs/openssl-1.0.1:0[bindist=])
                           (!libressl ? <dev-libs/openssl-1.1.0:0[bindist=])
                           (>=dev-libs/openssl-1.1.0g:0[bindist=])
                           (dev-libs/openssl:0)
                           (dev-libs/openssl:0[static-libs(+)])
net-misc/socat-1.7.3.2 (!libressl ? dev-libs/openssl:0)
net-misc/spice-gtk-0.35 (!libressl ? dev-libs/openssl:0)
net-misc/tigervnc-1.9.0-r1 (!libressl ? dev-libs/openssl:0)
net-misc/wget-1.20.1 (!libressl ? dev-libs/openssl:0)
                     (!libressl ? dev-libs/openssl:0[static-libs(+)])
net-nds/openldap-2.4.45 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                        (!libressl ? dev-libs/openssl:0)
                        (ssl ? dev-libs/openssl:0)
net-voip/telepathy-gabble-0.18.4-r1 (!libressl ? >=dev-libs/openssl-0.9.8g:0[-bindist])
net-wireless/aircrack-ng-1.5.2 (!libressl ? dev-libs/openssl:0)
net-wireless/crda-3.18-r1 (!libressl ? dev-libs/openssl:0)
net-wireless/wpa_supplicant-2.6-r10 (!libressl ? >=dev-libs/openssl-1.0.2k:0[bindist=])
sys-fs/cryfs-0.9.9 (!libressl ? dev-libs/openssl:0)
sys-fs/cryptsetup-1.7.5-r1 (!libressl ? dev-libs/openssl:0[static-libs(+)])
                           (!libressl ? dev-libs/openssl:0)
www-client/falkon-3.0.1-r1 (!libressl ? dev-libs/openssl:0)
www-client/w3m-0.5.3_p20180125 (!libressl ? dev-libs/openssl:0)
x11-base/xorg-server-1.20.3 (!libressl ? dev-libs/openssl:0)

_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Fri Mar 29, 2019 11:42 pm    Post subject: Reply with quote

Muchas gracias pelelademadera por responder, he verificado las uses locales y saque las que tiran de openssl.

Si no estoy confundido, ahora me queda unicamente el problematico dev-qt/qtnetwork.



Code:


sudo emerge -DuNav @world


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] dev-libs/openssl-1.1.0j-r1:0/1.1::gentoo  USE="asm zlib -bindist -rfc3779 -sctp -static-libs -test -tls-heartbeat -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 5.286 KiB
[ebuild  N     ] dev-qt/qtnetwork-5.11.3:5/5.11::gentoo  USE="ssl -bindist -connman -debug -libproxy -networkmanager -test" 0 KiB
[ebuild   R    ] dev-util/cargo-0.30.0-r1::gentoo  USE="libressl* -debug -doc" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] net-misc/spice-gtk-0.35::gentoo  USE="dbus gtk3 introspection libressl* (policykit) usbredir -gstaudio -gstvideo -lz4 -mjpeg -pulseaudio -sasl -smartcard -static-libs -vala -webdav" 0 KiB
[ebuild   R    ] www-client/falkon-3.0.1-r1::gentoo  USE="X dbus kwallet libressl* -debug -gnome-keyring -test" 0 KiB
[ebuild  N     ] kde-frameworks/khtml-5.54.0:5/5.54::gentoo  USE="X libressl -debug -test" 0 KiB
[ebuild  N     ] kde-frameworks/kdelibs4support-5.54.0:5/5.54::gentoo  USE="X libressl -debug -test" 0 KiB
[ebuild  N     ] kde-apps/kopete-18.12.3:5::gentoo  USE="addbookmarks autoreplace contactnotes handbook highlight privacy statistics texteffect urlpicpreview xmpp -debug -gadu -groupwise -history -jingle -latex -meanwhile -nowlistening -oscar -otr -pipes -ssl -test -testbed -translator -v4l -webpresence -winpopup -zeroconf" 0 KiB
[blocks B      ] dev-libs/openssl:0 ("dev-libs/openssl:0" is blocking dev-libs/libressl-2.8.3)

Total: 8 packages (5 new, 3 reinstalls), Size of downloads: 5.286 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/openssl-1.1.0j-r1:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0=[bindist=] (dev-libs/openssl:0=[-bindist]) required by (dev-qt/qtnetwork-5.11.3:5/5.11::gentoo, ebuild scheduled for merge)

  (dev-libs/libressl-2.8.3:0/46::gentoo, installed) pulled in by
    dev-libs/libressl:0= required by (dev-libs/xmlsec-1.2.27:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (dev-lang/python-3.5.5:3.5/3.5m::gentoo, installed)
    dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (dev-libs/cyrus-sasl-2.1.26-r10:2/2::gentoo, installed)
    dev-libs/libressl:0= required by (dev-libs/libzip-1.5.1:0/5::gentoo, installed)
    dev-libs/libressl required by (kde-frameworks/kdelibs4support-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
    dev-libs/libressl:0/46= required by (net-misc/wget-1.20.1:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (sys-fs/cryfs-0.9.9:0/0::gentoo, installed)
    dev-libs/libressl:= required by (sys-fs/cryfs-0.9.9:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-misc/iputils-20180629:0/0::gentoo, installed)
    dev-libs/libressl required by @selected
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-libs/libvncserver-0.9.11-r1:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (dev-libs/botan-1.10.17-r2:0/0::gentoo, installed)
    dev-libs/libressl required by (net-misc/dhcp-4.4.1:0/0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (dev-libs/cyrus-sasl-2.1.26-r10:2/2::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-wireless/aircrack-ng-1.5.2:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (net-misc/spice-gtk-0.35:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/libressl:0= required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)
    dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (www-client/w3m-0.5.3_p20180125:0/0::gentoo, installed)
    dev-libs/libressl:= required by (www-client/falkon-3.0.1-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/libressl:0/46= required by (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed)
    dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (net-libs/libvncserver-0.9.11-r1:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (app-emulation/spice-0.14.0-r2:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-analyzer/nmap-7.70:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-wireless/crda-3.18-r1:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-libs/libtorrent-rasterbar-1.1.12:0/9::gentoo, installed)
    dev-libs/libressl:= required by (net-analyzer/nmap-7.70:0/0::gentoo, installed)
    dev-libs/libressl:= required by (net-wireless/crda-3.18-r1:0/0::gentoo, installed)
    dev-libs/libressl:= required by (net-libs/libtorrent-rasterbar-1.1.12:0/9::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-vcs/git-2.19.2:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, installed)
    dev-libs/libressl required by (kde-frameworks/khtml-5.54.0:5/5.54::gentoo, ebuild scheduled for merge)
    dev-libs/libressl:0/46= required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
    >=dev-libs/libressl-2.8:0/46= required by (app-text/mupdf-1.14.0-r3:0/1.14.0::gentoo, installed)
    dev-libs/libressl:0= required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-misc/curl-7.64.0:0/0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
    dev-libs/libressl:= required by (net-dialup/ppp-2.4.7-r7:0/2.4.7::gentoo, installed)
    dev-libs/libressl:0/46= required by (app-admin/lastpass-cli-1.3.1-r1:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-dialup/ppp-2.4.7-r7:0/2.4.7::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-python/cryptography-2.2.2-r1:0/0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo, installed)
    dev-libs/libressl:0/46= required by (app-crypt/qca-2.1.3-r2:2/2::gentoo, installed)
    dev-libs/libressl:0= required by (net-wireless/aircrack-ng-1.5.2:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (www-client/w3m-0.5.3_p20180125:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (media-libs/opusfile-0.11:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed)
    dev-libs/libressl:0= required by (net-voip/telepathy-gabble-0.18.4-r1:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (net-misc/iputils-20180629:0/0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-libs/libssh2-1.8.0-r1:0/0::gentoo, installed)
    dev-libs/libressl:= required by (dev-vcs/git-2.19.2:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-libs/botan-1.10.17-r2:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-misc/freerdp-2.0.0_rc4:0/2::gentoo, installed)
    dev-libs/libressl:= required by (dev-python/m2crypto-0.24.0:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-python/m2crypto-0.24.0:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (net-misc/freerdp-2.0.0_rc4:0/2::gentoo, installed)
    dev-libs/libressl required by (dev-lang/ruby-2.4.5:2.4/2.4::gentoo, installed)
    dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (dev-db/mariadb-10.2.22-r1:0/18::gentoo, installed)
    dev-libs/libressl:0= required by (media-libs/opusfile-0.11:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-lang/python-3.5.5:3.5/3.5m::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-db/mariadb-10.2.22-r1:0/18::gentoo, installed)
    dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
    dev-libs/libressl:0= required by (app-admin/lastpass-cli-1.3.1-r1:0/0::gentoo, installed)
    dev-libs/libressl:= required by (app-crypt/qca-2.1.3-r2:2/2::gentoo, installed)
    dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo, installed)
    >=dev-libs/libressl-2.8:0=[static-libs?] (>=dev-libs/libressl-2.8:0=) required by (app-text/mupdf-1.14.0-r3:0/1.14.0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
    dev-libs/libressl:0= required by (net-misc/wget-1.20.1:0/0::gentoo, installed)
    dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (net-libs/libssh2-1.8.0-r1:0/0::gentoo, installed)
    dev-libs/libressl:0=[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (net-misc/curl-7.64.0:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
    dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (net-libs/libssh-0.8.6:0/4::gentoo, installed)
    dev-libs/libressl:0/46= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)
    dev-libs/libressl:= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-libs/libzip-1.5.1:0/5::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
    dev-libs/libressl:0= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
    dev-libs/libressl:0=[static-libs(+)?] (dev-libs/libressl:0=) required by (app-emulation/spice-0.14.0-r2:0/0::gentoo, installed)
    dev-libs/libressl:0= required by (dev-util/cargo-0.30.0-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/libressl:0/46= required by (net-voip/telepathy-gabble-0.18.4-r1:0/0::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
    dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-libs/libssh-0.8.6:0/4::gentoo, installed)
    dev-libs/libressl:0/46= required by (dev-libs/xmlsec-1.2.27:0/0::gentoo, installed)
    dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
    dev-libs/libressl:0= required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Sat Mar 30, 2019 12:15 am    Post subject: Reply with quote

volale la flag ssl a dev-qt/qtnetwork

podes hacerlo desde el package.use agregando la linea

dev-qt/qtnetwork -ssl

o bien en /etc/portage/package.use como fichero o bien a /etc/portage/package.use/***

Fitap wrote:
Code:
equery d openssl
 * These packages depend on openssl:

app-admin/lastpass-cli-1.3.1-r1 (!libressl ? dev-libs/openssl:0)
app-admin/sudo-1.8.25_p1-r1 (openssl ? dev-libs/openssl:0)
app-arch/libarchive-3.3.1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
app-crypt/qca-2.1.3-r2 (!libressl ? dev-libs/openssl:0)
                       (!libressl ? >=dev-libs/openssl-1.0.1:0)
app-crypt/rhash-1.3.6-r1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
app-emulation/spice-0.14.0-r2 (!libressl ? dev-libs/openssl:0[static-libs(+)?])
app-text/mupdf-1.14.0-r3 (openssl ? >=dev-libs/openssl-1.1:0[static-libs?])
dev-db/mariadb-10.2.22-r1 (!libressl ? >=dev-libs/openssl-1.0.0:0)
dev-db/mysql-connector-c-6.1.11-r1 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-lang/python-2.7.15 (!libressl ? dev-libs/openssl:0)
dev-lang/python-3.5.5 (!libressl ? dev-libs/openssl:0)
dev-lang/python-3.6.5 (!libressl ? dev-libs/openssl:0)
dev-lang/ruby-2.4.5 (!libressl ? dev-libs/openssl:0)
dev-lang/rust-1.29.1-r1 (!libressl ? dev-libs/openssl:0)
dev-libs/botan-1.10.17-r2 (!libressl ? <dev-libs/openssl-1.1:0[bindist=])
dev-libs/cyrus-sasl-2.1.26-r10 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libevent-2.1.8 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libzip-1.5.1 (!libressl ? dev-libs/openssl:0)
dev-libs/xmlsec-1.2.27 (!libressl ? dev-libs/openssl:0)
dev-perl/Net-SSLeay-1.820.0 (!libressl ? dev-libs/openssl:0)
dev-python/cryptography-2.2.2-r1 (!libressl ? dev-libs/openssl:0)
                                 (!libressl ? dev-libs/openssl:0[-bindist(-)])
                                 (!libressl ? >=dev-libs/openssl-1.0.2o-r6:0)
dev-python/m2crypto-0.24.0 (!libressl ? >=dev-libs/openssl-0.9.8:0)
dev-util/cargo-0.30.0-r1 (!libressl ? dev-libs/openssl:0)
dev-vcs/git-2.19.2 (!libressl ? dev-libs/openssl:0)
kde-apps/kopete-18.12.3 (jingle ? dev-libs/openssl:0)
media-libs/opusfile-0.11 (!libressl ? dev-libs/openssl:0)
media-video/ffmpeg-3.4.5 (openssl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-analyzer/nmap-7.70 (!libressl ? dev-libs/openssl:0)
net-dialup/ppp-2.4.7-r7 (!libressl ? dev-libs/openssl:0)
net-dns/bind-tools-9.12.2_p2-r1 (!libressl ? dev-libs/openssl:0)
                                (gost ? =dev-libs/openssl-1.0*[-bindist])
                                (gost ? >=dev-libs/openssl-1.1)
net-libs/libssh-0.8.6 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/libssh2-1.8.0-r1 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/libtorrent-rasterbar-1.1.12 (!libressl ? dev-libs/openssl:0)
net-libs/libvncserver-0.9.11-r1 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-libs/neon-0.30.2 (!libressl ? dev-libs/openssl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-misc/curl-7.64.0 (curl_ssl_openssl ? dev-libs/openssl:0[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
net-misc/dhcp-4.4.1 (!libressl ? dev-libs/openssl:0)
net-misc/freerdp-2.0.0_rc4 (!libressl ? dev-libs/openssl:0)
net-misc/iputils-20180629 (!libressl ? dev-libs/openssl:0)
                          (!libressl ? dev-libs/openssl:0[static-libs(+)])
net-misc/openssh-7.9_p1-r4 (!libressl ? >=dev-libs/openssl-1.0.1:0[bindist=])
                           (!libressl ? <dev-libs/openssl-1.1.0:0[bindist=])
                           (>=dev-libs/openssl-1.1.0g:0[bindist=])
                           (dev-libs/openssl:0)
                           (dev-libs/openssl:0[static-libs(+)])
net-misc/socat-1.7.3.2 (!libressl ? dev-libs/openssl:0)
net-misc/spice-gtk-0.35 (!libressl ? dev-libs/openssl:0)
net-misc/tigervnc-1.9.0-r1 (!libressl ? dev-libs/openssl:0)
net-misc/wget-1.20.1 (!libressl ? dev-libs/openssl:0)
                     (!libressl ? dev-libs/openssl:0[static-libs(+)])
net-nds/openldap-2.4.45 (!libressl ? >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                        (!libressl ? dev-libs/openssl:0)
                        (ssl ? dev-libs/openssl:0)
net-voip/telepathy-gabble-0.18.4-r1 (!libressl ? >=dev-libs/openssl-0.9.8g:0[-bindist])
net-wireless/aircrack-ng-1.5.2 (!libressl ? dev-libs/openssl:0)
net-wireless/crda-3.18-r1 (!libressl ? dev-libs/openssl:0)
net-wireless/wpa_supplicant-2.6-r10 (!libressl ? >=dev-libs/openssl-1.0.2k:0[bindist=])
sys-fs/cryfs-0.9.9 (!libressl ? dev-libs/openssl:0)
sys-fs/cryptsetup-1.7.5-r1 (!libressl ? dev-libs/openssl:0[static-libs(+)])
                           (!libressl ? dev-libs/openssl:0)
www-client/falkon-3.0.1-r1 (!libressl ? dev-libs/openssl:0)
www-client/w3m-0.5.3_p20180125 (!libressl ? dev-libs/openssl:0)
x11-base/xorg-server-1.20.3 (!libressl ? dev-libs/openssl:0)

_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Sat Mar 30, 2019 6:36 pm    Post subject: Reply with quote

Le he sacado las ssl a qtnetwork, hasta lo he desinstalado, pero cuando emerge lo instala, me avisa que necesita de ssl uses.

Code:
sudo emerge -DuNavq @world

[ebuild  N    ] dev-qt/qtnetwork-5.11.3  USE="ssl -bindist -connman -debug -libproxy -networkmanager -test"
[ebuild   R   ] dev-util/cargo-0.30.0-r1  USE="libressl* -debug -doc" ABI_X86="(64) -32 (-x32)"
[ebuild   R   ] net-misc/spice-gtk-0.35  USE="dbus gtk3 introspection libressl* (policykit) usbredir -gstaudio -gstvideo -lz4 -mjpeg -pulseaudio -sasl -smartcard -static-libs -vala -webdav"
[ebuild   R   ] www-client/falkon-3.0.1-r1  USE="X dbus kwallet libressl* -debug -gnome-keyring -test"
[ebuild  N    ] kde-frameworks/khtml-5.54.0  USE="X libressl -debug -test"
[ebuild  N    ] kde-apps/kopete-18.12.3  USE="addbookmarks autoreplace contactnotes handbook highlight privacy statistics texteffect urlpicpreview xmpp -debug -gadu -groupwise -history -jingle -latex -meanwhile -nowlistening -oscar -otr -pipes -ssl -test -testbed -translator -v4l -webpresence -winpopup -zeroconf"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-frameworks/kdelibs4support-5.54.0::gentoo
# required by kde-apps/kopete-18.12.3::gentoo
# required by kde-apps/kdenetwork-meta-18.12.3::gentoo
# required by kde-apps/kde-apps-meta-18.12.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtnetwork-5.11.3 ssl
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Wed Apr 03, 2019 4:54 pm    Post subject: Reply with quote

Fitap wrote:
Le he sacado las ssl a qtnetwork, hasta lo he desinstalado, pero cuando emerge lo instala, me avisa que necesita de ssl uses.

Code:
sudo emerge -DuNavq @world

[ebuild  N    ] dev-qt/qtnetwork-5.11.3  USE="ssl -bindist -connman -debug -libproxy -networkmanager -test"
[ebuild   R   ] dev-util/cargo-0.30.0-r1  USE="libressl* -debug -doc" ABI_X86="(64) -32 (-x32)"
[ebuild   R   ] net-misc/spice-gtk-0.35  USE="dbus gtk3 introspection libressl* (policykit) usbredir -gstaudio -gstvideo -lz4 -mjpeg -pulseaudio -sasl -smartcard -static-libs -vala -webdav"
[ebuild   R   ] www-client/falkon-3.0.1-r1  USE="X dbus kwallet libressl* -debug -gnome-keyring -test"
[ebuild  N    ] kde-frameworks/khtml-5.54.0  USE="X libressl -debug -test"
[ebuild  N    ] kde-apps/kopete-18.12.3  USE="addbookmarks autoreplace contactnotes handbook highlight privacy statistics texteffect urlpicpreview xmpp -debug -gadu -groupwise -history -jingle -latex -meanwhile -nowlistening -oscar -otr -pipes -ssl -test -testbed -translator -v4l -webpresence -winpopup -zeroconf"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-frameworks/kdelibs4support-5.54.0::gentoo
# required by kde-apps/kopete-18.12.3::gentoo
# required by kde-apps/kdenetwork-meta-18.12.3::gentoo
# required by kde-apps/kde-apps-meta-18.12.3::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtnetwork-5.11.3 ssl


equery d qt-webkit, con eso te fijas que paquetes dependen de qt-webkit.

alguno de esos requiere que uses qt-webkit con +ssl, probablemente deshabilitando alguna flag de ese paquete pasas el problema

postea el resultado y te doy una mano
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Fri Apr 05, 2019 12:08 am    Post subject: Reply with quote

Muchas gracias pelelademadera

He visto en la seccion ingles del foro que qtnetwork no tiene al momento soporte libressl en el tree de gentoo.

Aqui te dejo la salida extrania por cierto de lo que me has pedido.

Code:
equery d qt-webkit
 * These packages depend on qt-webkit:


Saludos.
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Fri Apr 05, 2019 1:01 pm    Post subject: Reply with quote

Fitap wrote:
Muchas gracias pelelademadera

He visto en la seccion ingles del foro que qtnetwork no tiene al momento soporte libressl en el tree de gentoo.

Aqui te dejo la salida extrania por cierto de lo que me has pedido.

Code:
equery d qt-webkit
 * These packages depend on qt-webkit:


Saludos.
si no tenes dependencias de qt-webkit, podes hacer un unmerge... para que esta instalado?
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Fitap
Apprentice
Apprentice


Joined: 13 Mar 2011
Posts: 242
Location: Rosario, Argentina

PostPosted: Fri Apr 05, 2019 6:34 pm    Post subject: Reply with quote

El paquete es sin el guion.

Code:
equery d dev-qt/qtwebkit
 * These packages depend on dev-qt/qtwebkit:
app-text/kchmviewer-7.7-r1 (dev-qt/qtwebkit:5)
dev-python/PyQt5-5.10.1-r1 (webkit ? >=dev-qt/qtwebkit-5.9:5[printsupport])
dev-qt/designer-5.11.3 (webkit ? >=dev-qt/qtwebkit-5.9.1:5)
dev-util/kdevelop-5.3.2 (webkit ? >=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-apps/k3b-18.12.3 (webkit ? >=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-apps/kdenlive-18.12.3 (freesound ? >=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-apps/rocs-18.12.3 (>=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-plasma/libksysguard-5.14.5 (webkit ? >=dev-qt/qtwebkit-5.9.1:5)
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1229
Location: La Plata, Argentina

PostPosted: Sat Apr 06, 2019 6:52 am    Post subject: Reply with quote

Fitap wrote:
El paquete es sin el guion.

Code:
equery d dev-qt/qtwebkit
 * These packages depend on dev-qt/qtwebkit:
app-text/kchmviewer-7.7-r1 (dev-qt/qtwebkit:5)
dev-python/PyQt5-5.10.1-r1 (webkit ? >=dev-qt/qtwebkit-5.9:5[printsupport])
dev-qt/designer-5.11.3 (webkit ? >=dev-qt/qtwebkit-5.9.1:5)
dev-util/kdevelop-5.3.2 (webkit ? >=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-apps/k3b-18.12.3 (webkit ? >=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-apps/kdenlive-18.12.3 (freesound ? >=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-apps/rocs-18.12.3 (>=dev-qt/qtwebkit-5.212.0_pre20180120:5)
kde-plasma/libksysguard-5.14.5 (webkit ? >=dev-qt/qtwebkit-5.9.1:5)


perdon, le erre de paquete de todas maneras, es qtnetwork el paquete en problemas...

por lo que veo en mi equipo, al menos yo tengo 4 paquetes que fuerzan el flag ssl en qtnetwork.

kde-frameworks/kdelibs4support-5.56.0 (>=dev-qt/qtnetwork-5.11.1:5[ssl])
kde-frameworks/khtml-5.56.0 (>=dev-qt/qtnetwork-5.11.1:5[ssl])
kde-frameworks/kio-5.56.0 (>=dev-qt/qtnetwork-5.11.1:5[ssl])
kde-frameworks/kxmlgui-5.56.0 (>=dev-qt/qtnetwork-5.11.1:5[ssl])

lamentablemente de kio y kxmlgui depende medio plasma.... asi que por lo que veo es imposible pasar a libressl con plasma, podrias probar con un gestor mas liviano como lxde o lxqt que tienen mucho menos dependencias y seguramente puedas usar libressl... o esperar a que updateen qtnetwork... lo veo bastante lejano
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum