Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Come procedere per aggiornare? [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 66
Location: Provincia pavese

PostPosted: Thu Mar 21, 2019 5:01 pm    Post subject: Come procedere per aggiornare? [Risolto] Reply with quote

Ciao ragazzi, ho cercato di aggiornare il sistema ma alla fine mi è uscito questo:
Code:
davide@gentoo ~ $ su
Password:
gentoo /home/davide # emerge --update --deep --with-bdeps=y @world
Calculating dependencies... done!
[ebuild  N     ] dev-libs/re2-0.2018.10.01  USE="-icu" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-libs/libevent-2.1.8  USE="ssl threads -debug -libressl -static-libs -test" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/libvpx-1.5.0  USE="svc threads -doc -postproc -static-libs -test" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmx sse sse2 -avx -avx2 -sse3 -sse4_1 -ssse3"
[ebuild     U  ] media-libs/libexif-0.6.21-r3 [0.6.21-r2]
[ebuild  N     ] app-arch/snappy-1.1.7  USE="(-static-libs) -test" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] sys-boot/grub-2.02-r3 [2.02-r1]
[ebuild     U  ] www-client/google-chrome-73.0.3683.86 [73.0.3683.75]
[ebuild  N     ] dev-qt/qtwebchannel-5.11.3  USE="qml -debug -test"
[ebuild  N     ] dev-qt/qtwebengine-5.11.3  USE="alsa bindist jumbo-build pulseaudio system-ffmpeg system-icu widgets -debug -designer -geolocation -pax_kernel -test"
[ebuild     U  ] kde-apps/marble-18.12.3 [18.08.3] USE="webengine%*"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-apps/marble-18.12.3::gentoo[webengine]
# required by @selected
# required by @world (argument)
>=dev-qt/qtwebengine-5.11.3 widgets
# required by dev-qt/qtwebengine-5.11.3::gentoo
# required by kde-apps/marble-18.12.3::gentoo[webengine]
# required by @selected
# required by @world (argument)
>=dev-qt/qtwebchannel-5.11.3 qml

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
gentoo /home/davide #

come devo procedere? Non ho idea di cosa fare.
_________________
Gentoo MATE+LightDM+OpenRC


Last edited by aenigma on Wed Apr 03, 2019 6:29 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22008
Location: here

PostPosted: Thu Mar 21, 2019 5:14 pm    Post subject: Reply with quote

Code:
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-apps/marble-18.12.3::gentoo[webengine]
# required by @selected
# required by @world (argument)
>=dev-qt/qtwebengine-5.11.3 widgets
# required by dev-qt/qtwebengine-5.11.3::gentoo
# required by kde-apps/marble-18.12.3::gentoo[webengine]
# required by @selected
# required by @world (argument)
>=dev-qt/qtwebchannel-5.11.3 qml

Portage ti dice che per installare marble hai bisogno di abilitare delle use flag in alcuni pacchetti.
Per fare questo devi utilizzare /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 66
Location: Provincia pavese

PostPosted: Fri Mar 22, 2019 7:16 am    Post subject: Reply with quote

Grazie fedeliallalinea, ho abilitato/disabilitato le use flags di ogni singolo pacchetto in /etc/portage/package/use/nome-pacchetto con "echo", ho ridato l'aggiornamento con --newuse, e tutto è andato a buon fine. Un altro piccolo passo per imparare ad usare la fantastica Gentoo l'ho fatto anche oggi grazie ai vostri consigli. Ciao.
_________________
Gentoo MATE+LightDM+OpenRC
Back to top
View user's profile Send private message
oscarandrea
Apprentice
Apprentice


Joined: 27 Nov 2015
Posts: 177
Location: Italy/Cosenza

PostPosted: Fri Mar 22, 2019 11:49 am    Post subject: Reply with quote

aenigma wrote:
Grazie fedeliallalinea, ho abilitato/disabilitato le use flags di ogni singolo pacchetto in /etc/portage/package/use/nome-pacchetto con "echo", ho ridato l'aggiornamento con --newuse, e tutto è andato a buon fine. Un altro piccolo passo per imparare ad usare la fantastica Gentoo l'ho fatto anche oggi grazie ai vostri consigli. Ciao.

oppure come consigliato si poteva fare autounmask-write e poi etc-update
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22008
Location: here

PostPosted: Fri Mar 22, 2019 12:52 pm    Post subject: Reply with quote

oscarandrea wrote:
oppure come consigliato si poteva fare autounmask-write e poi etc-update

Vero io sono un po' piu' tradizionalista e faccio a mano almeno mi obbliga a capire cosa sto facendo
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum