Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgraded to the 4.19.27 kernel but having stability issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
zamlz
n00b
n00b


Joined: 22 Jul 2017
Posts: 35

PostPosted: Mon Mar 18, 2019 3:31 pm    Post subject: Upgraded to the 4.19.27 kernel but having stability issues Reply with quote

Hi everyone,

I recently updated from kernel version 4.14.83 to 4.19.27 and have started to get stability issues.
Not really sure what is causing it but I know for a fact that X freezes up after a while (like a couple hours or less).

I have a hunch that it has to do with my AMD Ryzen 5 or the fact that I'm using Nvidia Drivers.
How would I go about figuring out where the issue is coming from?
I can also post both kernel configs if needed.

Thanks,
zamlz
_________________
AI/ML/Robotics/Linux - zamlz
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42873
Location: 56N 3W

PostPosted: Mon Mar 18, 2019 11:17 pm    Post subject: Reply with quote

zamlz,

Change something and see if the problem goes away.
If all you really did was a kernel upgrade, go back to the old kernel.

I suspect you changed more than you kernel. You must have rebuilt nvidia-drivers too as it provides an out of kernel module.
Did you update nvidia-drivers too.

If reverting to 4.14.83 fixes it. try a 4.16 or 4.17 kernel. Do a binary search.
Only change one thing at a time or you won't know what change had what effect.

On the basis that what you are seeing is a regression somewhere and it might be fixed in a newer kernel, you could try 5.0.x which is current testing.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
zamlz
n00b
n00b


Joined: 22 Jul 2017
Posts: 35

PostPosted: Thu Mar 21, 2019 12:18 am    Post subject: Reply with quote

NeddySeagoon wrote:
zamlz,
suspect you changed more than you kernel. You must have rebuilt nvidia-drivers too as it provides an out of kernel module.
Did you update nvidia-drivers too.


Indeed you are correct.

NeddySeagoon wrote:

If reverting to 4.14.83 fixes it. try a 4.16 or 4.17 kernel. Do a binary search.
Only change one thing at a time or you won't know what change had what effect.

On the basis that what you are seeing is a regression somewhere and it might be fixed in a newer kernel, you could try 5.0.x which is current testing.


I've reverted back ever since I made the post. I'll take your advice and try testing with other kernels inbetween.
_________________
AI/ML/Robotics/Linux - zamlz
Back to top
View user's profile Send private message
Makersmarx
n00b
n00b


Joined: 16 Feb 2019
Posts: 8
Location: Costa Rica

PostPosted: Thu Mar 21, 2019 11:40 pm    Post subject: Reply with quote

I also had many issues with freezes with my Ryzen 1600 back when I purchased it. I changed my Power Supply Idle from auto and havent seen them since. Have a look at this link, maybe it will help point you in the right direction.

https://community.amd.com/thread/225795
_________________
Pura Vida
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum