Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Un framebuffer para NVidia
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Sun Mar 17, 2019 9:02 pm    Post subject: Un framebuffer para NVidia Reply with quote

Hola a todos!!
Tuve que hacer un retroceso de Nouveau a nvidia-drivers.
Cuando quiero instalarle el framebuffer uvesafb me encuentro con que v86d ha muerto!!

Empecé a buscar alternativas y encontré “simple framebuffer” que lo menciona la gentoo-wiki de nvidia-drivers, pero no lo puedo hacer andar.

De comienzo a fin me muestra una pantalla negra y no muestra a Plymouth.

Esta es mi configuración de Grub:
Code:
GRUB_DISTRIBUTOR="Gentoo"
GRUB_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=0
GRUB_GFXMODE=1280x1024
GRUB_CMDLINE_LINUX_DEFAULT='quiet splash'
GRUB_CMDLINE_LINUX="root=/dev/sda6 rootfstype=ext4 init=/usr/lib/systemd/systemd quiet"
GRUB_THEME=/usr/share/grub/themes/gentoo/theme.txt
GRUB_HIDDEN_TIMEOUT=0
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_SUBMENU=y
GRUB_GFXPAYLOAD_LINUX=keep


Alguien más usa nvidia-drivers?
Como puedo solucionar este problema?

Gracias!!
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1221
Location: La Plata, Argentina

PostPosted: Mon Mar 18, 2019 10:27 am    Post subject: Reply with quote

efifb funciona

yo no uso spash ni initrd, pero el fb carga sin dramas.

creo que lo que necesitas es la flag kms activa para que funcione

Quote:
pelo@pelo-pc ~ $ dmesg | grep fb
[ 0.005025] NODE_DATA(0) allocated [mem 0x89fff8000-0x89fffbfff]
[ 0.222978] DMAR: DRHD base: 0x000000fbffc000 flags: 0x0
[ 0.222982] DMAR: dmar2: reg_base_addr fbffc000 ver 1:0 cap 8d2078c106f0466 ecap f020df
[ 0.222996] DMAR-IR: IOAPIC id 12 under DRHD base 0xfbffc000 IOMMU 2
[ 0.527989] pci 0000:65:00.0: BAR 3: assigned to efifb
[ 0.531979] pci_bus 0000:b2: root bus resource [mem 0xd9000000-0xfbffffff window]
[ 0.531989] pci 0000:b2:05.4: reg 0x10: [mem 0xfbf00000-0xfbf00fff]
[ 0.572748] pci_bus 0000:b2: resource 5 [mem 0xd9000000-0xfbffffff window]
[ 0.656409] efifb: probing for efifb
[ 0.656421] efifb: framebuffer at 0xd1000000, using 8128k, total 8128k
[ 0.656423] efifb: mode is 1920x1080x32, linelength=7680, pages=1
[ 0.656425] efifb: scrolling: redraw
[ 0.656426] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[ 0.662794] fb0: EFI VGA frame buffer device

pelo@pelo-pc ~ $ dmesg | grep NV
[ 0.000000] BIOS-e820: [mem 0x00000000425c0000-0x00000000433f0fff] ACPI NVS
[ 0.387539] PM: Registering ACPI NVS region [mem 0x425c0000-0x433f0fff] (14880768 bytes)
[ 0.390985] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[ 2.944167] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 418.43 Tue Feb 19 01:12:11 CST 2019
[ 2.997027] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input21
[ 2.997237] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input22
[ 2.997352] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input23
[ 2.997481] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:64/0000:64:00.0/0000:65:00.1/sound/card1/input24
[ 14.969730] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 418.43 Tue Feb 19 01:05:14 CST 2019

pelo-pc /home/pelo # emerge -pv nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-drivers/nvidia-drivers-418.43-r2:0/418::gentoo USE="X acpi compat driver gtk3 kms multilib tools uvm wayland -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
pelo-pc /home/pelo # uname -r
5.0.2-gentoo-pelo

_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Wed Mar 20, 2019 1:57 am    Post subject: Reply with quote

Hola pelelademadera:
Muchas gracias por tu respuesta! Lamentablemente no logré hacer andar efifb. Además, la wiki comenta que es frecuente que efifb falle con nvidia-drivers.

Pero finalmente pude hacer andar simplefb, pero el arranque muestra líneas del boot y Plymouth aparece solamente unos pocos segundos.

Como puedo hacer un arranque completamente silencioso? Ahora mi grub está así:

Code:
GRUB_DISTRIBUTOR="Gentoo"
GRUB_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=0
GRUB_GFXMODE=1280x1024
GRUB_CMDLINE_LINUX_DEFAULT='quiet splash'
GRUB_CMDLINE_LINUX="root=/dev/sda6 rootfstype=ext4 init=/usr/lib/systemd/systemd quiet  loglevel=0 show_status=0 udev.log-priority=3"
GRUB_THEME=/usr/share/grub/themes/gentoo/theme.txt
GRUB_HIDDEN_TIMEOUT=0
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_SUBMENU=y
GRUB_GFXPAYLOAD_LINUX=keep
Back to top
View user's profile Send private message
pelelademadera
Veteran
Veteran


Joined: 14 Jul 2008
Posts: 1221
Location: La Plata, Argentina

PostPosted: Fri Mar 22, 2019 5:46 pm    Post subject: Reply with quote

natrix wrote:
Hola pelelademadera:
Muchas gracias por tu respuesta! Lamentablemente no logré hacer andar efifb. Además, la wiki comenta que es frecuente que efifb falle con nvidia-drivers.

Pero finalmente pude hacer andar simplefb, pero el arranque muestra líneas del boot y Plymouth aparece solamente unos pocos segundos.

Como puedo hacer un arranque completamente silencioso? Ahora mi grub está así:

Code:
GRUB_DISTRIBUTOR="Gentoo"
GRUB_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=0
GRUB_GFXMODE=1280x1024
GRUB_CMDLINE_LINUX_DEFAULT='quiet splash'
GRUB_CMDLINE_LINUX="root=/dev/sda6 rootfstype=ext4 init=/usr/lib/systemd/systemd quiet  loglevel=0 show_status=0 udev.log-priority=3"
GRUB_THEME=/usr/share/grub/themes/gentoo/theme.txt
GRUB_HIDDEN_TIMEOUT=0
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_SUBMENU=y
GRUB_GFXPAYLOAD_LINUX=keep


Estimo que tendrias que crear un initrd, e integrar el modulo de nvidia en el mismo para que se cargue al momento de la carga del mismo, la verdad que no le doy mucha bola al inicio de la maquina, son unos 5 segundos y relamente esta encendida 24/7, con lo que rara vez lo veo... y desde consola, toda decoracion me ocupa espacio en la pantalla con lo que lo he probado y todo, pero no me resulta algo util, pero creo que la solucion viene por el lado del initrd
_________________
el pelado de la gente
------
Los habitantes de las islas Malvinas lo llaman gentoo, nombre en el que se basa la distribución GNU/Linux Gentoo, cuyo objetivo es la optimización para conseguir más rendimiento y velocidad en la ejecución.
------
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum