Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 2)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 14, 15, 16  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Tue Mar 05, 2019 6:43 pm    Post subject: Reply with quote

Leio wrote:
It's rather impolite for an overlay to have the same package (just renamed) under a different name than in the main tree, when it could just have the same name as main tree until a main tree pkgmove is done (hint: GNOME_ORG_MODULE).

Let's not go there. Thank you.

Shibotto wrote:
Mmh I noticed this doesn't seem to be tracked anywhere, should I open a bug report?

Leio wrote:
This thread is the bug reporting for dantrell overlay already. For main tree I'm not sure there's anything to track. It will be moved before stabilization of newer than 3.24 happens or when a 3.32 bump is made and it's noticed; there's no reason to track anything on the main tree side.

Indeed, there's nothing to be tracked.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 460

PostPosted: Thu Mar 07, 2019 10:06 am    Post subject: Reply with quote

When try to emerge at-spi2-core-2.30.1 and at-spi2-atk-2.30.1 the following fetch error appears:

Code:
>>> Downloading 'https://download.gnome.org/sources/at-spi2-core/2.30/at-spi2-core-2.30.1.tar.xz'
--2019-03-07 10:53:04--  https://download.gnome.org/sources/at-spi2-core/2.30/at-spi2-core-2.30.1.tar.xz
Auflösen des Hostnamens download.gnome.org… 209.132.180.162
Verbindungsaufbau zu download.gnome.org|209.132.180.162|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 302 Found
Platz: https://ftp-stud.hs-esslingen.de/pub/Mirrors/ftp.gnome.org/sources/at-spi2-core/2.30/at-spi2-core-2.30.1.tar.xz [folgend]
--2019-03-07 10:53:04--  https://ftp-stud.hs-esslingen.de/pub/Mirrors/ftp.gnome.org/sources/at-spi2-core/2.30/at-spi2-core-2.30.1.tar.xz
Auflösen des Hostnamens ftp-stud.hs-esslingen.de… 129.143.116.10, 2001:7c0:700::10
Verbindungsaufbau zu ftp-stud.hs-esslingen.de|129.143.116.10|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 188056 (184K) [application/x-xz]
Wird in »/usr/portage/distfiles/at-spi2-core-2.30.1.tar.xz« gespeichert.

     0K .......... .......... .......... .......... .......... 27% 1020K 0s
    50K .......... .......... .......... .......... .......... 54% 2,38M 0s
   100K .......... .......... .......... .......... .......... 81% 12,9M 0s
   150K .......... .......... .......... ...                  100%  347M=0,07s

2019-03-07 10:53:04 (2,44 MB/s) - »/usr/portage/distfiles/at-spi2-core-2.30.1.tar.xz« gespeichert [188056/188056]

!!! Fetched file: at-spi2-core-2.30.1.tar.xz VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      188056
!!! Expected: 188064
Refetching... File renamed to '/usr/portage/distfiles/at-spi2-core-2.30.1.tar.xz._checksum_failure_.ho9xkw9a'

!!! Couldn't download 'at-spi2-core-2.30.1.tar.xz'. Aborting.
 * Fetch failed for 'app-accessibility/at-spi2-core-2.30.1', Log file:
 *  '/var/log/portage/app-accessibility:at-spi2-core-2.30.1:20190307-095302.log'


Code:
>>> Downloading 'https://download.gnome.org/sources/at-spi2-atk/2.30/at-spi2-atk-2.30.1.tar.xz'
--2019-03-07 10:53:27--  https://download.gnome.org/sources/at-spi2-atk/2.30/at-spi2-atk-2.30.1.tar.xz
Auflösen des Hostnamens download.gnome.org… 209.132.180.162
Verbindungsaufbau zu download.gnome.org|209.132.180.162|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 302 Found
Platz: https://ftp-stud.hs-esslingen.de/pub/Mirrors/ftp.gnome.org/sources/at-spi2-atk/2.30/at-spi2-atk-2.30.1.tar.xz [folgend]
--2019-03-07 10:53:28--  https://ftp-stud.hs-esslingen.de/pub/Mirrors/ftp.gnome.org/sources/at-spi2-atk/2.30/at-spi2-atk-2.30.1.tar.xz
Auflösen des Hostnamens ftp-stud.hs-esslingen.de… 129.143.116.10, 2001:7c0:700::10
Verbindungsaufbau zu ftp-stud.hs-esslingen.de|129.143.116.10|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 200 OK
Länge: 94812 (93K) [application/x-xz]
Wird in »/usr/portage/distfiles/at-spi2-atk-2.30.1.tar.xz« gespeichert.

     0K .......... .......... .......... .......... .......... 54%  805K 0s
    50K .......... .......... .......... .......... ..        100% 9,91M=0,07s

2019-03-07 10:53:28 (1,36 MB/s) - »/usr/portage/distfiles/at-spi2-atk-2.30.1.tar.xz« gespeichert [94812/94812]

!!! Fetched file: at-spi2-atk-2.30.1.tar.xz VERIFY FAILED!
!!! Reason: Failed on BLAKE2B verification
!!! Got:      fe3ef77e749bef2300219fe32586ac0b871d06dce708ce8b7b57356a1fa17041c3f7b788e3e6d6b5f89dc97c3e8d43a9d1eb897ed8fbaac954f042421aef68b6
!!! Expected: 842e6909f6339ccea7aee20a8ec90ed795133592d4ef09f831d9440589519ad1b48db1c78c0558f42fff42ded78e618e7df6e2f4a4b51b117085c9434161e916
Refetching... File renamed to '/usr/portage/distfiles/at-spi2-atk-2.30.1.tar.xz._checksum_failure_.jcsrgihv'

!!! Couldn't download 'at-spi2-atk-2.30.1.tar.xz'. Aborting.
 * Fetch failed for 'app-accessibility/at-spi2-atk-2.30.1', Log file:
 *  '/var/log/portage/app-accessibility:at-spi2-atk-2.30.1:20190307-095326.log'
Back to top
View user's profile Send private message
veluw
n00b
n00b


Joined: 07 Mar 2019
Posts: 2

PostPosted: Thu Mar 07, 2019 7:23 pm    Post subject: Reply with quote

Hi all

When I configure DISPLAYMANAGER="gdm" and start it up, the screen switches to X11 mode, but stays completely black. There is no mouse and no gnome login screen visible, just black. It does not freeze and I can switch back to console via F keys.

I've enabled debug in /etc/gdm/custom.conf and there are following logs related to the black screen:

Code:
Mar  6 21:08:28 v gdm: GdmSession: Emitting 'session-started' signal with pid '7568'
Mar  6 21:08:28 v gdm: GdmDisplay: Greeter started
Mar  6 21:08:28 v gdm-launch-environment]: GdmSessionWorker: could not take control of tty: Operation not permitted
Mar  6 21:08:28 v gdm-x-session: Enabling debugging
Mar  6 21:08:28 v gdm-x-session: Preparing auth file for X server
Mar  6 21:08:28 v gdm-x-session: Running X server
Mar  6 21:08:29 v gdm-x-session: Running session message bus
Mar  6 21:08:29 v gdm-x-session: could not fetch environment: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.systemd1 was not provided by any .service fil
es
Mar  6 21:08:29 v gdm: GdmManager: trying to register new display
Mar  6 21:08:29 v gdm: GdmLocalDisplayFactory: display status changed: 2
Mar  6 21:08:29 v gdm-x-session: Running X session
Mar  6 21:10:01 v gdm: GDM finished, cleaning up...


"org.freedesktop.systemd1" is maybe some hint.

For the installation, I've followed GNOME_Without_systemd from the wiki and the installation process worked seamlessly. I've configured following profile:

dantrell-gnome-3-24:default/linux/amd64/17.0/desktop/gnome/3.24/extended (stable)

A month or so ago, I've tried also other versions of dantrell-gnome, both higher and lower, but the same effect and same error persisted.

Other DMs like mate or xfce are working on my machine, tough.

Had anyone a similar error already?

Thanks!
Veluw
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Fri Mar 08, 2019 12:24 am    Post subject: Reply with quote

Child_of_Sun_24 wrote:
When try to emerge at-spi2-core-2.30.1 and at-spi2-atk-2.30.1 the following fetch error appears [...]

This is an odd one since I did ensure that both of those packages built, however, a re-fetch shows that the source tarballs changed?

In any case, I regenerated the Manifest file so sync up and you should be good to go.

veluw wrote:
For the installation, I've followed GNOME_Without_systemd from the wiki and the installation process worked seamlessly. I've configured following profile [...]

For the record, I'm not the author or maintainer of the Wiki page and I don't provide support if you followed diverging instructions.

The official documentation is here and I'm going to assume it was followed (if it wasn't or you are not sure, please cross reference both sources).

veluw wrote:
When I configure DISPLAYMANAGER="gdm" and start it up, the screen switches to X11 mode, but stays completely black. There is no mouse and no gnome login screen visible, just black. It does not freeze and I can switch back to console via F keys.

The Wiki page doesn't mention CHECKVT at all but you'll notice the official documentation defines it as CHECKVT=7.

If you have a black screen but you suspect GDM is running, please cycle through all the VTs to make sure nothing is misplaced.

If that doesn't pan out, please tell me exactly how you are starting GNOME, whether or not you are using Wayland and if you have ruled out any privilege issues by checking with the root user account?
_________________
Dantrell B.
Back to top
View user's profile Send private message
veluw
n00b
n00b


Joined: 07 Mar 2019
Posts: 2

PostPosted: Tue Mar 12, 2019 7:42 pm    Post subject: Reply with quote

Hi Dantrell

Thank you for your reply.

Yes, I've also followed your official documentation, but the effects stay the same.

CHECKVT=7 is defined, yes.
Also tried to switch throug the VTs, but there are two VTs with black screen.
I'm not using Wayland. Same problem occurs with root.
When I've turn on auto login to skip the greeter, then a black desktop appears with context menu working, but the window borders are missing and my mouse cursor is an X.

However, it works now, by accident! :)
Both with auto login on or off.

Because of other reasons, I've replaced my graphics card from Nvidia GeForce GT 710B to ADM Radeon HD 6570.

With the AMD, gnome works now perfectly. The error from above (GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown) seems not related to that issue, since it is still written in the debug file.

Interestingly, I had switched from the Radeon to the GT710B 1.5 years ago during my Debian (also with Gnome 3) days when after a major upgrade my graphics started making trouble.

But it's fine for me when that Radeon works with Gentoo and Gnome 3.

In case you want to investigate this issue further and need any debugging information form my machine, just let me know.

Best regards
Veluw
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Wed Mar 13, 2019 3:16 am    Post subject: Reply with quote

I think some keywording is needed here:

Code:
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-libs/gegl-0.4.14::dantrell-gnome[pdf]
# required by media-gfx/gimp-2.10.8-r1::gentoo
# required by @media
# required by @selected
# required by @world (argument)
=app-text/poppler-0.74.0 **
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Wed Mar 13, 2019 7:10 am    Post subject: Reply with quote

veluw wrote:
However, it works now, by accident! :)

:o

saboya wrote:
I think some keywording is needed here [...]

Done.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 123
Location: Italy

PostPosted: Wed Mar 13, 2019 10:52 am    Post subject: Reply with quote

However cups-filters 1.20.4 seems to hate poppler 0.74.0 :lol:
cups-filters 1.21.6 from Gentoo stable compiles fine :thumb_up_emoticon_that_does_not_exist:
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Wed Mar 13, 2019 5:59 pm    Post subject: Reply with quote

Shibotto wrote:
However cups-filters 1.20.4 seems to hate poppler 0.74.0 :lol:

This issue was corrected.

Sync up and you should be good to go.

P.S. What actually needs to be done is a round of stabilization but I'm holding off on this until GNOME 3.32 settles in somewhat.

Shibotto wrote:
cups-filters 1.21.6 from Gentoo stable compiles fine :thumb_up_emoticon_that_does_not_exist:

1.21.6 was already available on my end though (just slotted in ~). :P
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Thu Mar 14, 2019 12:38 pm    Post subject: Reply with quote

After syncing today there's a bit of a blocker going on.

mesa-19.0.0 has been released, and it's unstable keyworded on Gentoo. So far so good.

However, it depends on >=sys-devel/llvm-8, and the possible candidates are currently masked.

I think it would be better to only require/allow >=media-libs/mesa-18.3* on the profiles, to avoid situations like this, and bump as needed.

Thoughts?
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 460

PostPosted: Thu Mar 14, 2019 3:29 pm    Post subject: Reply with quote

saboya wrote:
After syncing today there's a bit of a blocker going on.

mesa-19.0.0 has been released, and it's unstable keyworded on Gentoo. So far so good.

However, it depends on >=sys-devel/llvm-8, and the possible candidates are currently masked.

I think it would be better to only require/allow >=media-libs/mesa-18.3* on the profiles, to avoid situations like this, and bump as needed.

Thoughts?


I have installed mesa-19.0.0 today with llvm-7, there where no Problems.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7115
Location: Austria

PostPosted: Thu Mar 14, 2019 3:53 pm    Post subject: Reply with quote

In fact this condition is impossible as it would mean broken CI, and in that state it would not reach rsync mirrors.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Thu Mar 14, 2019 10:53 pm    Post subject: Reply with quote

asturm wrote:
In fact this condition is impossible as it would mean broken CI, and in that state it would not reach rsync mirrors.

This has nothing to do with the Gentoo tree, dantrell's profile allows unstable mesa but does not allow unstable llvm. This is due to the fact that, up until mesa-19 was released, stable llvm was enough to satisfy the dependency. However, mesa-19 requires llvm >= 7.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Fri Mar 15, 2019 1:32 am    Post subject: Reply with quote

saboya wrote:
After syncing today there's a bit of a blocker going on.

Child_of_Sun_24 wrote:
I have installed mesa-19.0.0 today with llvm-7, there where no Problems.

saboya wrote:
This has nothing to do with the Gentoo tree, dantrell's profile allows unstable mesa but does not allow unstable llvm. This is due to the fact that, up until mesa-19 was released, stable llvm was enough to satisfy the dependency. However, mesa-19 requires llvm >= 7.

This did happen because ~ versions of Mesa were allowed (even on stable setups) for a few GNOME release versions.

At one point in time, this was a necessary change but since all the versions of Mesa that prompted the change have been pruned from the main tree, this isn't so necessary anymore.

There is some cleaning up to do but I want to wait until I tackle GNOME 3.32 so I can do everything at once.

For now I have adjusted the allowance to only apply to ~ versions of Mesa which reference a stable version of LLVM.

saboya wrote:
I think it would be better to only require/allow >=media-libs/mesa-18.3* on the profiles, to avoid situations like this, and bump as needed.

P.S. There are some packages where something like this would be very useful but non-release candidate versions of Mesa probably isn't one of them.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 448
Location: Brazil

PostPosted: Sat Mar 16, 2019 12:56 pm    Post subject: Reply with quote

dantrell wrote:

This did happen because ~ versions of Mesa were allowed (even on stable setups) for a few GNOME release versions.

At one point in time, this was a necessary change but since all the versions of Mesa that prompted the change have been pruned from the main tree, this isn't so necessary anymore.

If I remember correctly this was due to EGL headers being outdated on the at the time stable Mesa versions.

Anyway, wasn't suggesting allowing non-release candidate Mesa versions, but to limit the version of Mesa that would be unkeyworded (as you did, with a more correct criteria).

Thanks :)
Back to top
View user's profile Send private message
gn-oosh
n00b
n00b


Joined: 13 Sep 2018
Posts: 2
Location: behind you

PostPosted: Sat Mar 23, 2019 10:39 pm    Post subject: gtk-update-icon-cache Reply with quote

Following sakaki's guide, I've got an error compiling and installing GNOME, and I'm really out of my depth. All help is greatly appreciated!

Snippet from /var/log/emerge.log, including my futile attempts, following the recommendations in sakaki's guide to resolve the failure (e.g., resuming and resuming with only 1 job).
Code:

1553300145:  === (169 of 220) Cleaning (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/gtk-upda
te-icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553300145:  === (169 of 220) Compiling/Packaging (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/gtk-update-icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553300150:  *** Finished. Cleaning up...
1553300150:  *** exiting unsuccessfully with status '1'.
1553300151:  *** terminating.
1553301046: Started emerge on: Mar 22, 2019 20:30:46
1553301046:  *** emerge --resume --jobs=5 --load-average=4.0
1553301051:  *** Resuming merge...
1553301054:  >>> emerge (1 of 52) dev-util/gtk-update-icon-cache-3.24.3 to /
1553301054:  === (1 of 52) Cleaning (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/gtk-update-
icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301054:  === (1 of 52) Compiling/Packaging (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/
gtk-update-icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301059:  *** Finished. Cleaning up...
1553301059:  *** exiting unsuccessfully with status '1'.
1553301059:  *** terminating.
1553301279: Started emerge on: Mar 22, 2019 20:34:39
1553301279:  *** emerge --resume --jobs=5 --load-average=4.0
1553301284:  *** Resuming merge...
1553301287:  >>> emerge (1 of 52) dev-util/gtk-update-icon-cache-3.24.3 to /
1553301287:  === (1 of 52) Cleaning (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/gtk-update-
icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301287:  === (1 of 52) Compiling/Packaging (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/
gtk-update-icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301292:  *** Finished. Cleaning up...
1553301292:  *** exiting unsuccessfully with status '1'.
1553301292:  *** terminating.
1553301316: Started emerge on: Mar 22, 2019 20:35:16
1553301316:  *** emerge --resume --jobs=1
1553301321:  *** Resuming merge...
1553301324:  >>> emerge (1 of 52) dev-util/gtk-update-icon-cache-3.24.3 to /
1553301324:  === (1 of 52) Cleaning (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/gtk-update-
icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301324:  === (1 of 52) Compiling/Packaging (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/
gtk-update-icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301329:  *** Finished. Cleaning up...
1553301329:  *** exiting unsuccessfully with status '1'.
1553301329:  *** terminating.
1553301489: Started emerge on: Mar 22, 2019 20:38:09
1553301489:  *** emerge --resume --jobs=5 --load-average=4.0
1553301495:  *** Resuming merge...
1553301497:  >>> emerge (1 of 52) dev-util/gtk-update-icon-cache-3.24.3 to /
1553301497:  === (1 of 52) Cleaning (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util/gtk-update$
icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301498:  === (1 of 52) Compiling/Packaging (dev-util/gtk-update-icon-cache-3.24.3::/usr/local/portage/dantrell-gnome/dev-util$
gtk-update-icon-cache/gtk-update-icon-cache-3.24.3.ebuild)
1553301502:  *** Finished. Cleaning up...
1553301502:  *** exiting unsuccessfully with status '1'.
1553301502:  *** terminating.



build.log
Code:

 * Package:    dev-util/gtk-update-icon-cache-3.24.3
 * Repository: dantrell-gnome
 * Maintainer: gnome@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   network-sandbox preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking gtk-update-icon-cache-3.24.3.tar.xz to /var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work
>>> Source unpacked in /var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work
>>> Preparing source in /var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work/gtk-update-icon-cache-3.24.3 ...
 * Disabling deprecation warnings ...
 [ ok ]
 * Running elibtoolize in: gtk-update-icon-cache-3.24.3/
 * Running elibtoolize in: gtk-update-icon-cache-3.24.3/build-aux/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.3 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work/gtk-update-icon-cache-3.24.3 ...
 * econf: updating gtk-update-icon-cache-3.24.3/build-aux/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating gtk-update-icon-cache-3.24.3/build-aux/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-silent-rules --docdir=/usr/share/doc/gtk-update-icon-cache-3.24.3 --htmldir=/usr/share/doc/gtk-update-icon-cache-3.24.3/html --libdir=/usr/lib64 --disable-maintainer-mode --disable-man
checking for a BSD-compatible install... /usr/lib/portage/python3.6/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether make supports nested variables... (cached) yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for native Win32... no
checking how to print strings... printf
checking whether make supports the include directive... yes (GNU style)
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking whether x86_64-pc-linux-gnu-gcc understands -c and -o together... yes
checking dependency style of x86_64-pc-linux-gnu-gcc... none
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/x86_64-pc-linux-gnu-nm -B
checking the name lister (/usr/bin/x86_64-pc-linux-gnu-nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for x86_64-pc-linux-gnu-objdump... x86_64-pc-linux-gnu-objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-pc-linux-gnu-dlltool... no
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking for archiver @FILE support... @
checking for x86_64-pc-linux-gnu-strip... x86_64-pc-linux-gnu-strip
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib
checking command to parse /usr/bin/x86_64-pc-linux-gnu-nm -B output from x86_64-pc-linux-gnu-gcc object... ok
checking for sysroot... no
checking for a working dd... /bin/dd
checking how to truncate binary pipes... /bin/dd bs=4096 count=1
checking for x86_64-pc-linux-gnu-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-gcc static flag -static works... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-gcc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating ./config.lt
config.lt: creating libtool
checking whether NLS is requested... yes
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) is GNU ld... yes
checking for shared library run path origin... done
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/x86_64-pc-linux-gnu-pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for
    glib-2.0 >= 2.53.4
    gdk-pixbuf-2.0 >= 2.30.0
... no
configure: error: Package requirements (
    glib-2.0 >= 2.53.4
    gdk-pixbuf-2.0 >= 2.30.0
) were not met:

Package dependency requirement 'glib-2.0 >= 2.53.4' could not be satisfied.
Package 'glib-2.0' has version '2.52.3', required version is '>= 2.53.4'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables UPDATE_ICON_CACHE_CFLAGS
and UPDATE_ICON_CACHE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work/gtk-update-icon-cache-3.24.3/config.log
 * ERROR: dev-util/gtk-update-icon-cache-3.24.3::dantrell-gnome failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *               ebuild.sh, line  124:  Called src_configure
 *             environment, line 2613:  Called gnome2_src_configure '--disable-man'
 *             environment, line 1800:  Called econf '--disable-maintainer-mode' '--disable-man'
 *        phase-helpers.sh, line  718:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  119:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=dev-util/gtk-update-icon-cache-3.24.3::dantrell-gnome'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/gtk-update-icon-cache-3.24.3::dantrell-gnome'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work/gtk-update-icon-cache-3.24.3'
 * S: '/var/tmp/portage/dev-util/gtk-update-icon-cache-3.24.3/work/gtk-update-icon-cache-3.24.3'


emerge --info
Code:

Portage 2.3.62 (python 3.6.5-final-0, targets/desktop/gnome/extended, gcc-8.2.0, glibc-2.27-r6, 4.19.27-gentoo-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.27-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-3470_CPU_@_3.20GHz-with-gentoo-2.6
KiB Mem:     8061092 total,   1926060 free
KiB Swap:    9671676 total,   9671676 free
Timestamp of repository gentoo: Sat, 23 Mar 2019 03:00:01 +0000
Head commit of repository gentoo: 811b7494b9b244f5dae0bb8cc822e09f6bdcc3c9
Head commit of repository sakaki-tools: df5b210704a49d66fca210509456b3809bab4716

Head commit of repository dantrell-gnome-3-14: c404012e769e5705d8fa7a5eb8710e98b372b6a8

Head commit of repository dantrell-gnome-3-16: 52aef0158cb25fb9c95cfed008a40a055cb36553

Head commit of repository dantrell-gnome-3-18: c37a539f7799cbcb64f386c7e6dff5d12ebc31db

Head commit of repository dantrell-gnome-3-20: 69f4b592bdce492c28614798f3debf40a7b628d1

Head commit of repository dantrell-gnome-3-22: 1e7f833f1daec993233b276d4e47240070357eff

Head commit of repository dantrell-gnome-3-24: a22e83f4f05adcc3259d94199d4c4070f1a323b0

Head commit of repository dantrell-gnome-3-26: 769b5d38315277a23adbf0deb467da80f664dcac

Head commit of repository dantrell-gnome-3-28: 5784edbffa692030c05301ff4172fcb30374937c

Head commit of repository dantrell-gnome-3-30: 65bc07eb14e311ba727d575c5d83ecdabd3ad9e2

Head commit of repository dantrell-gnome: b745aea7070f135799c9855ad1205f3d1c21b9b2

sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.30 p5) 2.30.0
app-shells/bash:          4.4_p23-r1::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.38.3-r1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r4::gentoo
sys-devel/gcc:            8.2.0-r6::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

sakaki-tools
    location: /usr/local/portage/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

dantrell-gnome-3-14
    location: /usr/local/portage/dantrell-gnome-3-14
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-14.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-16
    location: /usr/local/portage/dantrell-gnome-3-16
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-16.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-18
    location: /usr/local/portage/dantrell-gnome-3-18
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-18.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-20
    location: /usr/local/portage/dantrell-gnome-3-20
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-20.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-22
    location: /usr/local/portage/dantrell-gnome-3-22
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-22.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-24
    location: /usr/local/portage/dantrell-gnome-3-24
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-24.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-26
    location: /usr/local/portage/dantrell-gnome-3-26
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-26.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-28
    location: /usr/local/portage/dantrell-gnome-3-28
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-28.git
    masters: gentoo
    priority: 100

dantrell-gnome-3-30
    location: /usr/local/portage/dantrell-gnome-3-30
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome-3-30.git
    masters: gentoo
    priority: 100

dantrell-gnome
    location: /usr/local/portage/dantrell-gnome
    sync-type: git
    sync-uri: https://github.com/dantrell/gentoo-overlay-dantrell-gnome.git
    masters: gentoo
    priority: 150

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms split-elog strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo http://gentoo.ussg.indiana.edu/ http://mirrors.lug.mtu.edu/gentoo/ http://gentoo.osuosl.org/ http://gentoo.mirrors.pair.com/ http://mirrors.rit.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://mirror.lug.udel.edu/pub/gentoo/ http://gentoo.cs.utah.edu/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord crypt cups cxx dbus dri dts dvd dvdr eds elogind encode evo exif fam flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gtk3 gtkstyle iconv introspection ipv6 jpeg lcms ldap libnotify libsecret libtirpc mad mng mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl seccomp spell ssl startup-notification svg tcpd tiff tracker truetype udev udisks unicode upower usb vorbis x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx f16c mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


emerge -pqv
Code:

[ebuild     U ] dev-util/gtk-update-icon-cache-3.24.3 [3.24.0]

!!! The following installed packages are masked:
- sys-auth/pambase-20150213-r2::gentoo (masked by: package.mask)
- app-crypt/pinentry-1.1.0-r2::gentoo (masked by: package.mask)
- sys-apps/openrc-0.38.3-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


environment
https://pastebin.com/FmNRAgkz
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Sun Mar 24, 2019 1:09 am    Post subject: Re: gtk-update-icon-cache Reply with quote

gn-oosh wrote:
Following sakaki's guide, I've got an error compiling and installing GNOME, and I'm really out of my depth. All help is greatly appreciated!

Sync up and you should be good to go.

gn-oosh wrote:
emerge -pqv [...]

That said, it looks like you forgot to re-emerge @world before emerging gnome (or gnome-light) after initially setting your profile.

Both the Wiki page and the official documentation mention that this is a necessary step.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 869

PostPosted: Sun Mar 24, 2019 2:34 am    Post subject: Reply with quote

Is this standard behaviour that gnome does not let normal user to shutdown without root password? And how am I supposed to allow this without weaken security?
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Sun Mar 24, 2019 3:37 am    Post subject: Reply with quote

Elleni wrote:
Is this standard behaviour that gnome does not let normal user to shutdown without root password?

Last I checked, yes.

There's probably a Polkit policy or rule in /usr/share/polkit-1 that enforces this.

Elleni wrote:
And how am I supposed to allow this without weaken security?

You can put a custom Polkit rule in /etc/polkit-1/rules.d/.

For instance, I use /etc/polkit-1/rules.d/10-overrides.rules to allow local (i.e. not remote) members of certain groups to manage certain functionality without password authentication.

For your purposes, you could allow a specific user (or members of the wheel group) to manage certain functionality without password authentication.

To not weaken security, limit the allowed functionality to just ability the shutdown (and maybe suspend & hibernate).
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 869

PostPosted: Sun Mar 24, 2019 11:06 pm    Post subject: Reply with quote

I created the /etc/polkit-1/rules.d/10-overrides.rules file with following line
Code:

%wheel ALL=(ALL) NOPASSWD: /sbin/halt, /sbin/reboot


But this is not correct apparently as it did not allow me to shutdown nor reboot without password prompt. I guess that would have been to easy. :twisted:

Well as workaround I just push the poweroff button, that avoids to input password for a simple shutdown. Good enough for me. I am just wondering, why on earth they implement such a thing, I mean there are surely plenty of single user installations where there is no risk of shutting down while others are still logged in, but maybe it's just me :wink:

Nevertheless - once more dear dantrell - thanks for your exellent work and support!
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Sun Mar 24, 2019 11:26 pm    Post subject: Reply with quote

Elleni wrote:
But this is not correct apparently as it did not allow me to shutdown nor reboot without password prompt. That would have been to easy I suppose :twisted:

Oh you. :P

This should work for elogind (ConsoleKit1 uses slightly different rules):

Code:
polkit.addRule(function(action, subject)
{
    if ((action.id == "org.freedesktop.login1.reboot" ||
         action.id == "org.freedesktop.login1.reboot-multiple-sessions" ||
         action.id == "org.freedesktop.login1.power-off" ||
         action.id == "org.freedesktop.login1.power-off-multiple-sessions" ||
         action.id == "org.freedesktop.login1.suspend" ||
         action.id == "org.freedesktop.login1.suspend-multiple-sessions" ||
         action.id == "org.freedesktop.login1.hibernate" ||
         action.id == "org.freedesktop.login1.hibernate-multiple-sessions") &&
         subject.isInGroup("wheel"))
    {
        return polkit.Result.YES;
    }
});

_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 869

PostPosted: Mon Mar 25, 2019 12:54 am    Post subject: Reply with quote

Tried and this solves my issue. Perfect support as always. Thanks a lot :D
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 123
Location: Italy

PostPosted: Mon Mar 25, 2019 12:02 pm    Post subject: Reply with quote

Are we sure this is needed by default? According to my polkit rules (which I don't think I ever manually changed?) the only requirement should be an active session.

/usr/share/polkit-1/actions/org.freedesktop.login1.policy:
Code:
        <action id="org.freedesktop.login1.power-off">
                <description gettext-domain="systemd">Power off the system</description>
                <message gettext-domain="systemd">Authentication is required for powering off the system.</message>
                <defaults>
                        <allow_any>auth_admin_keep</allow_any>
                        <allow_inactive>auth_admin_keep</allow_inactive>
                        <allow_active>yes</allow_active>
                </defaults>
                <annotate key="org.freedesktop.policykit.imply">org.freedesktop.login1.set-wall-message</annotate>
        </action>

And indeed nothing in {/usr/share/polkit-1,/etc/polkit-1}/rules.d/ sets any additional rule for those actions.

To be extra sure I created a testing account with bare minimum permissions to launch GNOME and as long as the session is active I can perform those actions both from GNOME menu and loginctl <COMMAND>:
Code:
testing@VPCS11E7E ~ $ id
uid=1002(testing) gid=1002(testing) groups=1002(testing),27(video)

testing@VPCS11E7E ~ $ loginctl user-status testing
testing (1002)
           Since: Mon 2019-03-25 13:00:25 CET; 4min 27s ago
           State: active
        Sessions: *10
          Linger: no
            Unit: user-1002.slice


Maybe there are some lingering rules left behind by an old package?
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 581
Location: Earth

PostPosted: Mon Mar 25, 2019 8:20 pm    Post subject: Reply with quote

Shibotto wrote:
Are we sure this is needed by default? According to my polkit rules (which I don't think I ever manually changed?) the only requirement should be an active session.

Three possibilities though:

1. Sometimes Polkit goes haywire and the only thing that works are custom rules

2. Sometimes active sessions are marked inactive (by design if not intention) and the only way around it are custom rules

3. Elleni is using the combined profile (GNOME + Plasma) so there might be more policies and rules in place

Although the first two instances are rare, I have personally encountered both of them over the years but I have never been interested in diagnosing the cause. I just wrote custom rules and moved on.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
l33t
l33t


Joined: 23 May 2006
Posts: 869

PostPosted: Mon Mar 25, 2019 9:47 pm    Post subject: Reply with quote

Hey dantrell, I have another one for you - just in case you are bored and need something to investigate :twisted:

When trying to issue a teamviewer session (installed via portage - version 13) the password window is not showing up in gnome after typing the id and hitting enter. Teamviewer just shows connecting forever; this does not happen in plasma.

But really, this is low priority issue for me :)
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 14, 15, 16  Next
Page 15 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum