Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Intel mobile 945GM with modern drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
cord
Guru
Guru


Joined: 28 Apr 2007
Posts: 303

PostPosted: Sat Mar 09, 2019 5:52 pm    Post subject: [solved]Intel mobile 945GM with modern drivers Reply with quote

Hello. I have 945GM integrated video card. It was working well with intel (i915) driver when there was mesa-13 (it has OpenGL 2.1). But since the 17 has come, I get the crashes or big slowness in some KDE settings menu tabs.
The default configuration for my GPU (as wiki suggest) is:
Code:
[ebuild   R    ] media-libs/mesa-18.2.8::gentoo  USE="classic dri3 egl gallium gbm llvm wayland -d3d9 -debug -gles1 -gles2 -lm_sensors -opencl -osmesa -pax_kernel -pic (-selinux) -test -unwind -vaapi -valgrind -vdpau -vulkan -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel i915 (-freedreno) -i965 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware" 0 KiB

which sets OpenGL 1.4. Two things are very annoying. First, there is constant CPU load ~7-10% in the idle (mostly plasmashell process). The second, when I open KDE_menu -> SystemSetting -> Workspace Theme (or 'Icons') the window is drawed very slow (half a minute). The same thing is when I try to configure desktop wall paper.
If I recompile mesa with USE="-classic -video_cards_intel" it sets OpenGL 2.1. It doesn't load CPU in the idle, and no problems with "Workspace Theme" tab, but there is crashes like in #665024.

Well, what can I do with it? Is there way to use 945GM without problems nowadays?


ps I also read this, but it's different.


Last edited by cord on Wed Mar 13, 2019 1:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sat Mar 09, 2019 6:38 pm    Post subject: Reply with quote

KDE likes to blame the graphics driver for any and all crashes, but after years of seeing people having problems with every kind of GPU, and only in KDE 5, I'm not sure I believe them any more.

Try it with a different WM.
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 997

PostPosted: Sat Mar 09, 2019 6:48 pm    Post subject: Reply with quote

As I've just revisited my own settings with alternate intel integrated graphic,
https://www.reddit.com/r/Gentoo/comments/9ur5ml/intel_i965_which_mesa_use_flags_gallium_gles2
suggests -gallium -llvm... Guess it won't fix our KDE issue, though.

Thks 4 ur attention.
Back to top
View user's profile Send private message
cord
Guru
Guru


Joined: 28 Apr 2007
Posts: 303

PostPosted: Sat Mar 09, 2019 7:38 pm    Post subject: Reply with quote

Hah, your video card is 9th generation! You can use modesettings internal Xorg driver. My is 3rd, and modesettings support are for >=4.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sat Mar 09, 2019 7:44 pm    Post subject: Reply with quote

You _can_ force the modesetting/glamor driver to load on a 945, I've done it once before. Performance is abysmal though, don't bother.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2663
Location: Slovenia

PostPosted: Sun Mar 10, 2019 8:37 am    Post subject: Reply with quote

Yeah, glamor won't work well on these old things. If you're going with the modesetting driver, your best option is to *disable* glamor with a config like this (save as /etc/X11/xorg.conf.d/20-modesetting.conf)
Code:
Section "Device"
  Identifier "some old crap"
  Driver "modesetting"
  Option "AccelMethod" "none"
EndSection


There's also the possibility to fake the supported OpenGL version, could work:
Code:
export MESA_GL_VERSION_OVERRIDE=2.1 MESA_GLSL_VERSION_OVERRIDE=120
Back to top
View user's profile Send private message
cord
Guru
Guru


Joined: 28 Apr 2007
Posts: 303

PostPosted: Sun Mar 10, 2019 5:12 pm    Post subject: Reply with quote

Thank you! Looks like it's the best it can be.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum