Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cadence, jackdbus & loopback... [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 995

PostPosted: Sat Feb 16, 2019 2:28 pm    Post subject: Cadence, jackdbus & loopback... [solved] Reply with quote

Hi,
Using cadence atop of gentoo, not gentoostudio,
Jack2/dbus works fine enough here once started jack via cadence.

But if trying to experiment loopback via cadence, loopback UI tab in jack configuration is greyed.

Any idea what I miss?

Thks 4 ur attention.


Last edited by CaptainBlood on Tue Feb 19, 2019 1:42 am; edited 2 times in total
Back to top
View user's profile Send private message
CaptainBlood
l33t
l33t


Joined: 24 Jan 2010
Posts: 995

PostPosted: Tue Feb 19, 2019 12:28 am    Post subject: Reply with quote

Just had to set snd_aloop as module in kernel CONFIG_SND_ALOOP::

Device Drivers --->
<*> Sound card support --->
<*> Advanced Linux Sound Architecture --->
[*] Generic sound devices --->
<M> Generic loopback driver (PCM)

and update /etc/conf.d/modules accordingly with snd_aloop as module name.

Furthermore, media-sound/zita-ajbridge package from overlay may help (latency, cnot sure though), to be selected in Cadence [ System Tab ] [ JACK Bridges ] [ ALSA Audio ] Bridge Type : ALSA -> Loop -> JACK. [...] Buton-> Popup Window: [ Bridge tool drop down menu ] -> zita_a2j/j2a. Then stop & restat Alsa Audio deamon.

Thks 4 ur attention.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum