Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Gimp 2.10
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mptaiko
n00b
n00b


Joined: 05 Jan 2019
Posts: 33

PostPosted: Thu Jan 24, 2019 4:51 pm    Post subject: [gelöst] Gimp 2.10 Reply with quote

Hallo miteinander,

nach meiner Gentoo-Installation läuft vieles schon wie es laufen soll, aber an einigen Schrauben muss ich noch stellen.

Ich habe folgendes Profil installiert:

Code:
  [12]  default/linux/amd64/17.0 (stable)
  [13]  default/linux/amd64/17.0/selinux (stable)
  [14]  default/linux/amd64/17.0/hardened (stable)
  [15]  default/linux/amd64/17.0/hardened/selinux (stable)
  [16]  default/linux/amd64/17.0/desktop (stable) *
  [17]  default/linux/amd64/17.0/desktop/gnome (stable)
  [18]  default/linux/amd64/17.0/desktop/gnome/systemd (stable)


Im wesentlichen ist mein System genauso aufgebaut wie vorher bei Arch. Ich nutze den i3-Gaps-WM. Deshalb habe ich auch "17.0 desktop (stable)" eingestellt.
Was mich aber wundert, ist dass Gimp nur in der Version 2.8 auf die Platte gewandert ist und nicht die 2.10 wie bei Arch. Ist die nur in 17.1 .... verfügbar, oder wie kann man hier die neuere Version installieren?
Im Netz habe ich dazu nichts gefunden. Ich möchte Gimp 2.10 nutzen, weil hier Bilder mit 32 Bit Farbtiefe gelesen uns bearbeitet werden können, was in Gimp 2.8 unmöglich ist.
Bei Arch hatte ich seinerzeit auch nur die stable-Repos genutzt, nur ist da Version 2.10 schon fast seit einem halben Jahr enthalten und verfügbar. Andererseits finde ich es gut, dass nicht jeden Tag zig neuere Paketversionen eingestellt werden. Zumindetst hatte ich, verglichen mit Arch bisher relativ wenige Updates mit
Code:
emerge --update --deep @world
installieren müssen.

Habe ich beim Profil was falsch eingestellt oder mache ich beim updaten Fehler?

Meine anderen noch bestehenden Problemchen bringe ich in einem anderen Thread an.

LG Micha


Last edited by mptaiko on Sat Jan 26, 2019 11:11 am; edited 1 time in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2017
Location: My own world! I and Gentoo!

PostPosted: Thu Jan 24, 2019 5:05 pm    Post subject: Reply with quote

Hallo mptaiko,

Das liegt an den Keywords.
gimp ist in folgenden Versionen im Tree vorhanden:

eix gimp:

[I] media-gfx/gimp
     Verfügbare Versionen:   (2) 2.8.22-r1 (~)2.9.8-r1 (~)2.10.2 (~)2.10.4 (~)2.10.6-r1 (~)2.10.8-r1 **9999
       {aalib alsa altivec aqua bzip2 curl dbus debug doc exif gnome heif jpeg jpeg2k lcms mng openexr pdf png postscript python smp svg test tiff udev unwind vector-icons webp wmf xpm CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7"}
     Installierte Versionen: 2.10.8-r1(2)(00:34:24 13.01.2019)(aalib alsa mng python udev -altivec -aqua -debug -doc -gnome -heif -jpeg2k -openexr -postscript -smp -test -unwind -vector-icons -webp -wmf -xpm CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7")
     Startseite:             https://www.gimp.org/
     Beschreibung:           GNU Image Manipulation Program

(Die Klammern um die ~ zeigen in meiner Ausgabe an dass die Versionen mit den "unstable Keywords" gezeichnet sind, aber ich diese Versionen akzeptiere. wobei ich dies generell über die make.conf gelöst habe und damit ein "unstable Gentoo" nach der Logik fahre)

Das hat aber nichts mit dem Profil zu tun, dieses definiert sowas wie Default-USE-Flags, System-set und ähnliches.
Während die Keywords definieren welches Paket von der Gentoo-Gemeinschaft generell als "Stabil" gekennzeichnet sind und im jeweiligen Ebuild pro Paket definiert werden.

Für deinen Fall kannst du die neuere Gimp-Version in der Datei /etc/portage/package.keywords (auch als Ordner mit mehreren Dateien darin möglich) in einer der folgenden Varianten eintragen:
/usr/portage/package.accept_keywords:

media-gfx/gimp ~amd64             # Alle Versionen freischalten und das entsprechende Keyword genau eintragen
=media-gfx/gimp-2.10.8-r1 ~amd64  # Genau diese Version freischalten
>=media-gfx/gimp-2.10.8-r1        # Diese Version und größert freischalten, aber das default-unstable-keyword zu deiner Architektur berücksichtigen
>media-gfx/gimp-2.10 ~amd64       # Alle jüngeren Versionen ab hier freischalten
<media-gfx/gimp-2.10.9            # alle älteren Versionen ab hier freischalten
<=media-gfx/gimp-2.10.8-r1        # alle älteren Versionen und diese freischalten
media-gfx/gimp:0 ~amd64           # Den Slot 0 freischalten.


Daraufhin wäre es freigeschalten.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic

Version 0.6


Last edited by Max Steel on Thu Jan 24, 2019 5:15 pm; edited 3 times in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Thu Jan 24, 2019 5:10 pm    Post subject: Reply with quote

Code:
~amd64

^ Nicht nötig in package.accept_keywords, da impliziert.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
mptaiko
n00b
n00b


Joined: 05 Jan 2019
Posts: 33

PostPosted: Sat Jan 26, 2019 11:12 am    Post subject: Reply with quote

Hallo und vielen Dank,

Die Installation läuft gerade.

LG Micha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum