Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore in emerge x11-misc/virtualgl-2.5.2
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 2:52 pm    Post subject: Errore in emerge x11-misc/virtualgl-2.5.2 Reply with quote

Come da titolo ricevo il reguente errore in compilazione :
Code:

make: *** [Makefile:130: all] Error 2
 * ERROR: x11-misc/virtualgl-2.5.2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-misc/virtualgl-2.5.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-misc/virtualgl-2.5.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-misc/virtualgl-2.5.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/virtualgl-2.5.2/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-misc/virtualgl-2.5.2/work/VirtualGL-2.5.2-abi_x86_64.amd64'
 * S: '/var/tmp/portage/x11-misc/virtualgl-2.5.2/work/VirtualGL-2.5.2'

>>> Failed to emerge x11-misc/virtualgl-2.5.2, Log file:

>>>  '/var/tmp/portage/x11-misc/virtualgl-2.5.2/temp/build.log'



il log file e` riportato qui : https://paste.pound-python.org/show/wyl3v3Q32FM5OqYlPjVG/

grazie per l'aiuto
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 4:09 pm    Post subject: Reply with quote

Prova la patch proposta nel relativo bug https://bugs.gentoo.org/673988
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 4:27 pm    Post subject: Reply with quote

come la applico ?? :oops:
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 5:16 pm    Post subject: Reply with quote

drudox wrote:
come la applico ?? :oops:

Con /etc/portage/patches
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 5:43 pm    Post subject: Reply with quote

ottengo un errore durante ebuild prepare :

Code:
sysresccd /usr/portage/x11-misc/virtualgl # ebuild virtualgl-2.5.2.ebuild clean prepare
 * VirtualGL-2.5.2.tar.gz BLAKE2B SHA512 size ;-) ...                    [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> Unpacking source...
>>> Unpacking VirtualGL-2.5.2.tar.gz to /var/tmp/portage/x11-misc/virtualgl-2.5.2/work
>>> Source unpacked in /var/tmp/portage/x11-misc/virtualgl-2.5.2/work
>>> Preparing source in /var/tmp/portage/x11-misc/virtualgl-2.5.2/work/VirtualGL-2.5.2 ...
 * Applying virtualgl-2.5.2-openssl-1.1-compat-a974c22141d0ded9ff60a0b903f81e6b484d6ba4.patch ...                                                        [ ok ]
 * Applying virtualgl-openssl-1.1.patch ...
1 out of 1 hunk FAILED -- saving rejects to file include/Socket.h.rej
2 out of 2 hunks FAILED -- saving rejects to file util/Socket.cpp.rej    [ !! ]
 * ERROR: x11-misc/virtualgl-2.5.2::gentoo failed (prepare phase):
 *   patch -p1  failed with /etc/portage/patches/x11-misc/virtualgl-2.5.2/virtualgl-openssl-1.1.patch
 *
 * Call stack:
 *               ebuild.sh, line  124:  Called src_prepare
 *             environment, line 3328:  Called cmake-utils_src_prepare
 *             environment, line  955:  Called default_src_prepare
 *      phase-functions.sh, line  933:  Called __eapi6_src_prepare
 *             environment, line  272:  Called eapply_user
 *             environment, line 1191:  Called eapply '/etc/portage/patches/x11-misc/virtualgl-2.5.2/virtualgl-openssl-1.1.patch'
 *             environment, line 1161:  Called _eapply_patch '/etc/portage/patches/x11-misc/virtualgl-2.5.2/virtualgl-openssl-1.1.patch'
 *             environment, line 1099:  Called __helpers_die 'patch -p1  failed with /etc/portage/patches/x11-misc/virtualgl-2.5.2/virtualgl-openssl-1.1.patch'
 *   isolated-functions.sh, line  119:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=x11-misc/virtualgl-2.5.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-misc/virtualgl-2.5.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-misc/virtualgl-2.5.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-misc/virtualgl-2.5.2/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-misc/virtualgl-2.5.2/work/VirtualGL-2.5.2'
 * S: '/var/tmp/portage/x11-misc/virtualgl-2.5.2/work/VirtualGL-2.5.2'
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 6:03 pm    Post subject: Reply with quote

Da l'errore perche' hai due patch che vanno in conflitto
Code:
 * Applying virtualgl-2.5.2-openssl-1.1-compat-a974c22141d0ded9ff60a0b903f81e6b484d6ba4.patch ...                                                        [ ok ]
 * Applying virtualgl-openssl-1.1.patch ...

prova a rimuovere la virtualgl-openssl-1.1.patch
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 6:13 pm    Post subject: Reply with quote

ok perfertto ! grazie tante ... ora non capisco una cosa :
quando tento di lanciare
Code:
  emerge @preserved-rebuild


mi da questo errore (prima falliva solo la compilazione di virtualgl )
Code:

 sysresccd /usr/portage/x11-misc/virtualgl # emerge @preserved-rebuild
Calculating dependencies... done!
[ebuild   R    ] x11-libs/libdrm-2.4.96  VIDEO_CARDS="amdgpu* nouveau* radeon*"
[ebuild   R    ] x11-drivers/xf86-video-amdgpu-18.1.0
[ebuild   R    ] x11-drivers/xf86-video-nouveau-1.0.15-r1
[ebuild   R    ] x11-drivers/xf86-video-ati-18.1.0

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-drivers/xf86-video-amdgpu-18.1.0::gentoo
# required by @preserved-rebuild (argument)
>=x11-libs/libdrm-2.4.96 video_cards_radeon video_cards_nouveau video_cards_amdgpu

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


io non voglio installare quei tre pacchetti dal momento in cui ho seguito le indicazioni per installare bumblebee .....
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 6:18 pm    Post subject: Reply with quote

Che cosa hai impostato come VIDEO_CARDS in make.conf?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 6:24 pm    Post subject: Reply with quote

Code:
VIDEO_CARDS="intel i965 nvidia"
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 6:26 pm    Post subject: Reply with quote

E come mai hai installato il pacchatto x11-drivers/xf86-video-amdgpu?
Puoi postare l'output del comando
Code:
equery d x11-drivers/xf86-video-amdgpu

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 6:29 pm    Post subject: Reply with quote

Code:
sysresccd ~ # equery d x11-drivers/xf86-video-amdgpu
bash: equery: command not found
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 6:33 pm    Post subject: Reply with quote

il fatto che sia installato e` che ho aggiornato world prima di definire VIDEO_CARDS
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 6:38 pm    Post subject: Reply with quote

Allora lancia un
Code:
# emerge -UD @world

questo comando ricompila tutti i pacchetti dove c'e' un cambio di use flags, e poi un
Code:
# emerge -ca

prima di dare ok al secondo comando controlla bene che non ci siano pacchetti critici che vuole disinstallarti
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 6:40 pm    Post subject: Reply with quote

Code:
sysresccd ~ # emerge -ca

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence of this, it often becomes necessary to run
 * `emerge --update --newuse --deep @world` prior to depclean.

Calculating dependencies... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 x11-drivers/xf86-video-fbdev
    selected: 0.5.0
   protected: none
     omitted: none

 x11-drivers/xf86-video-vesa
    selected: 2.4.0
   protected: none
     omitted: none

 sys-libs/db
    selected: 5.3.28-r2
   protected: none
     omitted: 6.0.35-r1

 x11-drivers/xf86-video-dummy
    selected: 0.3.8
   protected: none
     omitted: none

 sys-devel/llvm
    selected: 6.0.1-r2
   protected: none
     omitted: 7.0.1

 sys-devel/automake
    selected: 1.15.1-r2
   protected: none
     omitted: 1.16.1-r1

 app-text/openjade
    selected: 1.3.2-r7
   protected: none
     omitted: none

 sys-kernel/gentoo-sources
    selected: 4.14.83
   protected: none
     omitted: 4.20.0


!!! 'app-editors/nano' (virtual/editor) is part of your system profile.
!!! Unmerging it may be damaging to your system.


 app-editors/nano
    selected: 2.9.8
   protected: none
     omitted: none

 sys-devel/gcc
    selected: 7.3.0-r6
   protected: none
     omitted: 8.2.0-r6

 sys-devel/binutils
    selected: 2.30-r4
   protected: none
     omitted: 2.31.1-r3

All selected packages: =x11-drivers/xf86-video-vesa-2.4.0 =app-editors/nano-2.9.8 =x11-drivers/xf86-video-dummy-0.3.8 =sys-libs/db-5.3.28-r2 =sys-devel/gcc-7.3.0-r6 =sys-devel/binutils-2.30-r4 =app-text/openjade-1.3.2-r7 =x11-drivers/xf86-video-fbdev-0.5.0 =sys-devel/automake-1.15.1-r2 =sys-devel/llvm-6.0.1-r2 =sys-kernel/gentoo-sources-4.14.83

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No]


confermo ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 6:49 pm    Post subject: Reply with quote

Prima di dare l'ok non vedo comunque che ti vuole rimuovere x11-drivers/xf86-video-amdgpu e in piu' vuole eliminarti nano e i gentoo-sources-4.20.
Che kernel hai in uso (uname -a)? Che editor di sistema usi (eselect editor list)?

Quindi forse come ti dice depclean lancia prima un emerge --update --newuse --deep @world
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 07, 2019 6:54 pm    Post subject: Reply with quote

ho eliminato a mano admcpu , noveau , e ati ...

Code:
sysresccd ~ # uname -a
Linux sysresccd 4.14.80-std532-amd64 #2 SMP Sun Nov 11 18:59:44 UTC 2018 x86_64 Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz GenuineIntel GNU/Linux


Code:
Available targets for the EDITOR variable:
  [1]   /bin/nano
  [2]   /usr/bin/ex
  [3]   /usr/bin/vi *
  [ ]   (free form)


Code:
sysresccd ~ # emerge --update --newuse --deep @world
Calculating dependencies... done!
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.


grazie per l'aiuto !! ho installato i driver nvidia e intel e seguito la guida di nvidia/bumblebee , abilitato xdm con lightdm ma se avvio gentoo si bloacca a
Code:
waiting for xautority
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 07, 2019 7:34 pm    Post subject: Reply with quote

MI pare che per il kernel e nano non ci siano problemi a questo punto (a parte che aggiornerei il sistema al kernel 4.14.83).

Per l'altro problema vedi se questo post puo' aiutarti
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Fri Jan 11, 2019 1:15 pm    Post subject: Reply with quote

Scusa ma non mi ha aiutato ... potresti aiutarmi a capire da dove nace il problema?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Fri Jan 11, 2019 6:05 pm    Post subject: Reply with quote

drudox wrote:
Scusa ma non mi ha aiutato ... potresti aiutarmi a capire da dove nace il problema?

Non ho idea di cosa causi il tuo problema. Io ho installato bumblebee e primus come descritto qui (cerca il titolo Configurazione Intel/NVIDIA con Bumblebee e primus)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sat Jan 12, 2019 7:33 pm    Post subject: Reply with quote

Ho seguito le tue impostazioni a mena dito ma ricevo comunque questo messaggio che blocca l'avvio :

Code:
*Setting up lightdm
*Starting VirtualGL
truncate : cannot open /var/libVirtualGL/vgl_xauth_key for writing: Read only file system
* waiting for Xauthority
 


questo e` il mio fstab:

/dev/sda3 / ext4 noatime 0 1
/dev/sdb3 /home ext4 defaults 0 2
/dev/sdb4 none swap sw 0 0
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Sun Jan 13, 2019 9:18 am    Post subject: Reply with quote

le opzioni di mount della / sono troppo striminzite e non hai i permessi di scrittura (nemmeno root) ... hai il filesystem in sola lettura

mettici minimo un
Code:
defaults


dal man di mount
Code:
defaults
              Use the default options: rw, suid, dev, exec, auto, nouser, and async.


ti dà i permessi di scrittura

al momento hai solo
Code:
noatime
              Do  not  update  inode  access  times on this filesystem (e.g. for faster access on the news spool to speed up news servers).  This works for all inode
              types (directories too), so it implies nodiratime.


prova con :
Code:
# mount -o remount,defaults /


se non ti fa scrivere l'fstab per qualche motivo , esegui un chroot e cambia le opzioni di mount per la /

puoi vedere come vengono montati i vari filesystem semplicemente digitando :
Code:
# mount


PS : ma come cavolo ti faceva funzionare lo stesso ^^
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 13, 2019 1:07 pm    Post subject: Reply with quote

sabayonino wrote:


PS : ma come cavolo ti faceva funzionare lo stesso ^^


cioe` ?

cmq ho cambiato l'opzione in defaults :

Code:
/dev/sda3               /               ext4            defaults         0 1
/dev/sdb3               /home           ext4            defaults        0 2
/dev/sdb4               none            swap            sw              0 0


ma ottengo lo stesso risultato !!
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 13, 2019 5:20 pm    Post subject: Reply with quote

Come posso fare a mettere in scrittura quel file ? o tutti quelli che servono ?
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Mon Jan 14, 2019 8:03 pm    Post subject: Reply with quote

era il filesystem che era in sola lettura (quindi tutto)

Qual'è il problema ora ?

Dovresti essere più preciso e fornire più informazioni possibili perchè da qua non si capisce molto...

Il post iniziale partiva con un errore di compilazione ... Quindi presumo che prima il sistema funzionasse.
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 14, 2019 9:14 pm    Post subject: Reply with quote

funzionava da chroot fatto dalla live di systemrescue ,, quando avvio gentoo si blocca e non ho accesso alle ttY
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum