Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X doesn't works in a new installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Mon Jan 14, 2019 10:25 am    Post subject: X doesn't works in a new installation Reply with quote

Hi all , I'm tring to install X in a new gentoo's installation (done from systemrescue live USB, in my Laptop Dell inspiron 7757 )

After have follow the wiki to configure kernel parameters and package about dual video Card (Nvidia GTX and Intel ) bumblebee ( from https://forums.gentoo.org/viewtopic-p-7920848.html#7920848)
I got after the reboot :
Code:

 *Setting up lightdm
*Starting VirtualGL
truncate : cannot open /var/libVirtualGL/vgl_xauth_key for writing: Read only file system
* waiting for Xauthority


this is my fstab :

Code:
/dev/sda3               /               ext4            defaults         0 1
/dev/sdb3               /home           ext4            defaults        0 2
/dev/sdb4               none            swap            sw              0 0


I've tried to check for Xorg.0.log but doesn't exist !
May somebody help me about ?
thanks
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7249
Location: Saint Amant, Acadiana

PostPosted: Mon Jan 14, 2019 1:01 pm    Post subject: Reply with quote

Quote:
Read only file system

This is your problem. Since we do not know anything about your setup there is no way to tell why this is happening. Maybe init is failing, maybe corrupted filesystem, maybe something else.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Mon Jan 14, 2019 1:35 pm    Post subject: Reply with quote

and how can I check ?? please if you can gvive me some advice ... thanks in advance ! what do you need to know ?
Back to top
View user's profile Send private message
system.shock
n00b
n00b


Joined: 06 Jan 2019
Posts: 29

PostPosted: Mon Jan 14, 2019 8:18 pm    Post subject: Reply with quote

You can check it using:
Code:
mount | grep " / "
/dev/mapper/gentwo-root on / type ext4 (rw,relatime)

So in my case rw, means read and write if you have ro that's mean read only file system.
You can manualy remount file system as read\write (first link in google):
Code:
mount -o remount,rw /partition/identifier /mount/point

And after that start X.
If it helps you should check why your file systems mount ro in dmesg.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Mon Jan 14, 2019 8:25 pm    Post subject: Reply with quote

where I have to give this command ? because when I run gentoo and it stop with "waiting for xauthiority" I cannot go to the tty .. the system is completely locked !

thank you very much for your precious help !!
Back to top
View user's profile Send private message
system.shock
n00b
n00b


Joined: 06 Jan 2019
Posts: 29

PostPosted: Mon Jan 14, 2019 8:31 pm    Post subject: Reply with quote

You can press ctrl+alt+f[1234] login and get access to terminal.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Mon Jan 14, 2019 9:06 pm    Post subject: Reply with quote

no I can't ... the system go to lock ! I don't have access to the tty, may I change the run level ?
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2599

PostPosted: Mon Jan 14, 2019 9:15 pm    Post subject: Reply with quote

Pass the kernel "pfix=nox" on boot. How you do this varies with bootloader but some google-fu should give you the answer.

X is not your problem. Something else is dorked up and unless you can see what you are doing you won't know what. This is why adding xdm to the default run level is not recommended until you have a working X configuration.

As a general practice I like to comment out the entry for the first tty so I can add a no clear option thus making my boot messages persistent. Much easier to see errors. You do this in /etc/inittab like so
Code:
#x1:12345:respawn:/sbin/agetty 38400 console linux
c1:12345:respawn:/sbin/agetty 38400 --noclear tty1 linux

The first like is the commented out original persevered for posterity. The second line is the desired behavior. Depending on the situation you may or may not desire this behavior in the long run.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Jan 15, 2019 10:17 am    Post subject: Reply with quote

unfortunately doesn't works !

I' modified my inittab as follow , and remove xdm to default level .. but still the system lock with "waiting for X authority" with the previous message that said that the file system is read only

inittab:

Code:

#
# /etc/inittab:  This file describes how the INIT process should set up
#                the system in a certain run-level.
#
# Author:  Miquel van Smoorenburg, <miquels@cistron.nl>
# Modified by:  Patrick J. Volkerding, <volkerdi@ftp.cdrom.com>
# Modified by:  Daniel Robbins, <drobbins@gentoo.org>
# Modified by:  Martin Schlemmer, <azarah@gentoo.org>
# Modified by:  Mike Frysinger, <vapier@gentoo.org>
# Modified by:  Robin H. Johnson, <robbat2@gentoo.org>
# Modified by:  William Hubbs, <williamh@gentoo.org>
#

# Default runlevel.
id:3:initdefault:

# System initialization, mount local filesystems, etc.
si::sysinit:/sbin/openrc sysinit

# Further system initialization, brings up the boot runlevel.
rc::bootwait:/sbin/openrc boot

l0u:0:wait:/sbin/telinit u
l0:0:wait:/sbin/openrc shutdown
l0s:0:wait:/sbin/halt -dhnp
l1:1:wait:/sbin/openrc single
l2:2:wait:/sbin/openrc nonetwork
l3:3:wait:/sbin/openrc default
l4:4:wait:/sbin/openrc default
l5:5:wait:/sbin/openrc default
l6u:6:wait:/sbin/telinit u
l6:6:wait:/sbin/openrc reboot
l6r:6:wait:/sbin/reboot -dkn
#z6:6:respawn:/sbin/sulogin

# new-style single-user
su0:S:wait:/sbin/openrc single
su1:S:wait:/sbin/sulogin

# TERMINALS
#x1:12345:respawn:/sbin/agetty 38400 console linux
#c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c1:12345:respawn:/sbin/agetty 38400 --noclear tty1 linux
#c2:2345:respawn:/sbin/agetty 38400 tty2 linux
#c3:2345:respawn:/sbin/agetty 38400 tty3 linux
#c4:2345:respawn:/sbin/agetty 38400 tty4 linux
#c5:2345:respawn:/sbin/agetty 38400 tty5 linux
#c6:2345:respawn:/sbin/agetty 38400 tty6 linux

# SERIAL CONSOLES
#s0:12345:respawn:/sbin/agetty -L 115200 ttyS0 vt100
#s1:12345:respawn:/sbin/agetty -L 115200 ttyS1 vt100

# What to do at the "Three Finger Salute".
ca:12345:ctrlaltdel:/sbin/shutdown -r now

# Used by /etc/init.d/xdm to control DM startup.
# Read the comments in /etc/init.d/xdm for more
# info. Do NOT remove, as this will start nothing
# extra at boot if /etc/init.d/xdm is not added
# to the "default" runlevel.
x:a:once:/etc/X11/startDM.sh
------------------------------------------------------------
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Jan 15, 2019 10:35 am    Post subject: Reply with quote

now I switch to run level 2 and I can log from the console (TTY)
and now i get :

Code:
mount | grep " / "
/dev/sda3 on / type ext4 (rw,realtime)


so looks everything ok or not ?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 631

PostPosted: Tue Jan 15, 2019 11:34 am    Post subject: Reply with quote

if I try from user to run "startx" I got this error :

Code:
Warning :   Unsupported high keycode 372 for name <I372> ignored
>                  X11 cannot support keycode above 255
>                  this warning only shows for the first high keycode
Errors from xkbcomp are not fatal for X server
libEGL warning : DRI2: failed to authenticate
twm: warning fonts for charset ISO...... is laking
twm: warning fonts for charset ISO...... is laking
twm: warning fonts for charset ISO...... is laking
twm: warning fonts for charset ISO...... is laking
......
......
twm ...


PS: I can write on partition " / "
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum