Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
FIXED: keine Maus und Keyboard nach Kernelupdate
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1575
Location: Frankfurt, Germany

PostPosted: Wed Jan 02, 2019 4:22 pm    Post subject: Reply with quote

Ich frage mich die ganze Zeit, ob Du vielleicht doch unter dem udev-Problem leidest. Zuerst wurde berichtet, dass das Problem nur unter udev-240 auftritt. Mittlerweile gibt es aber auch Berichte, dass (zumindest in bestimmtem Konstellationen) auch udev-239 betroffen ist. Teste doch mal ob die Probleme verschwinden, wenn Du auf eudev wechselst.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Wed Jan 02, 2019 4:30 pm    Post subject: Reply with quote

HOTPLUG gibt es an vielen Stellen, da weiß ich nicht was ich entfernen soll aber die Fehlermeldungen treten, wie gesagt, auch beim alten Kern auf. Ich habe jetzt die beiden UEVENT_HELPER Parameter deactiviert und baue den Kernel.
Section Module ist entfernt und macht keinen Unterschied, wie vorhergesagt.
Wenn der Kern fertig ist werde ich ihn booten und erneut testen. (ich erwarte keinen Unterschied aber wer weiß?)

Für den alten Kern gilt:

Code:

dmesg | grep "Kernel command line"
[    0.000000] Kernel command line: root=/dev/sda2


Für den neuen kann ich es nicht direkt sagen aber bestimmt das gleiche. Ich kann das dann via ssh testen aber wenn die Zeile anders wäre, würde er IMHO nicht mehr starten.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Wed Jan 02, 2019 4:35 pm    Post subject: Reply with quote

mike155 wrote:
Ich frage mich die ganze Zeit, ob Du vielleicht doch unter dem udev-Problem leidest. Zuerst wurde berichtet, dass das Problem nur unter udev-240 auftritt. Mittlerweile gibt es aber auch Berichte, dass (zumindest in bestimmtem Konstellationen) auch udev-239 betroffen ist. Teste doch mal ob die Probleme verschwinden, wenn Du auf eudev wechselst.


Ja, mach ich anschließend. Bin allerdings ne Weile weg heute abend ;) So in einer Stunde etwa.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Wed Jan 02, 2019 5:03 pm    Post subject: Reply with quote

Der neu gebaute Kernel hat keinen Unterschied gemacht. Inwieweit ist die eudev Migration riskant? Ich wollte jetzt nicht so gern mein Backup testen müssen.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1575
Location: Frankfurt, Germany

PostPosted: Wed Jan 02, 2019 5:12 pm    Post subject: Reply with quote

Quote:
Inwieweit ist die eudev Migration riskant?

Soweit ich mich erinnern kann, war die Migration zu eudev einfach und problemlos. Hier gibt es eine kurze Anleitung, im Abschnitt 'Migrating from udev to eudev'. Es ist nur eine Anweisung.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4473

PostPosted: Wed Jan 02, 2019 9:45 pm    Post subject: Reply with quote

Ich glaube das die eudev migration eher nichts bringen wird.
Eher sollten wir an der Xorg konfiguration arbeiten. Die enthält einiges an nicht mehr benötigte Elemente.
Und die xorg.conf ist mehr oder weniger auch obsolete, da zum einen der X-Sever vieles schon automatisch richtig erkennt.
Nur für "spezial/sonder" Konfigurationen (z.b. default keyboard layout oder properitäre Treiber) ist eine konfig datei notwendig.
Wobei solche Elemente nicht mehr unbedingt in einer xorg.conf stehen müssen.
Seit einigen Versionen kann der X-Server konfigurationen aus dem Verzeichnis /etc/X11/xorg.conf.d laden.

Bei meinem system habe ich keine xorg.conf mehr sondern nur noch eine konfigurationsdatei im xorg.conf.d Verzeichnis für das default keyboard layout.
/etc/X11/xorg.conf.d/01-keyboard.conf wrote:
Section "InputClass"
Identifier "keyboard-all"
Driver "evdev"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"

MatchIsKeyboard "on"
EndSection


Mehr benötige ich nicht, da ich den opensource gpu treiber für AMD karten verwende, welche vom X-Server automatisch verwendet wird.

Für den properitären NVIDIA treiber wird eine zusätzliche datei in /etc/X11/xorg.conf.d benötigt (laut https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers#The_X_server)
/etc/X11/xorg.conf.d/nvidia.conf wrote:
Section "Device"
Identifier "nvidia"
Driver "nvidia"
EndSection

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Thu Jan 03, 2019 8:25 am    Post subject: Reply with quote

Ich werde meine xorg.conf so umbauen, wie es firefly beschreibt, testen und mich dannach wieder melden.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2058
Location: My own world! I and Gentoo!

PostPosted: Thu Jan 03, 2019 8:52 am    Post subject: Reply with quote

Meine Konfiguration ist ähnlich zu fireflys, mit dem Unterschied dass ich die explizite Angabe eines Drivers weg lasse und dass Xorg selbst regeln lass. Er lädt libinput für die Eingabedevices. (Tastatur, Mouse). Bin bislang gut gefahren.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4473

PostPosted: Thu Jan 03, 2019 12:03 pm    Post subject: Reply with quote

Die angabe des treibers ist bei mir noch existent da durch die Umstellung auf evdev wo der alte keyboard x11 treiber noch installiert war.
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3695
Location: Germany

PostPosted: Sat Jan 05, 2019 1:10 pm    Post subject: Reply with quote

Erdie wrote:
Code:
# CONFIG_USB_PCI is not set
ist vermutlich das was dir in der neuen Linux-4.14 Konfiguration fehlt.
Die Option gibt es erst ab >=linux-4.12
und wird beim make oldconfig gern mal übersehen.
Back to top
View user's profile Send private message
lovelytux
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2013
Posts: 107
Location: Westwoods of Germany

PostPosted: Sun Jan 06, 2019 11:13 pm    Post subject: Reply with quote

Hey,
vielleicht noch ein Hinweis: x11-drivers/xf86-input-evdev x11-drivers/xf86-input-libinput sollten nicht zur gleichen Zeit installiert sein! Und /usr/share/X11/xorg.conf.d/ muss ggf. angepasst werden.
Grüße
Back to top
View user's profile Send private message
Erdie
Advocate
Advocate


Joined: 20 May 2004
Posts: 2036
Location: Heidelberg - Germany

PostPosted: Sat Jan 12, 2019 1:11 pm    Post subject: Reply with quote

Josef.95 wrote:
Erdie wrote:
Code:
# CONFIG_USB_PCI is not set
ist vermutlich das was dir in der neuen Linux-4.14 Konfiguration fehlt.
Die Option gibt es erst ab >=linux-4.12
und wird beim make oldconfig gern mal übersehen.


Das war die Lösung! DANKE !!!

Und allen anderen danke ich auch, die mit dabei waren.

Grüße
Erdie

P.S. ich werde die xorg.conf on aufräumen, bin grad etwas faul und busy .. ;)
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum