Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X-Server doesn't start with OpenRC
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Phoen7x
n00b
n00b


Joined: 29 Dec 2018
Posts: 16

PostPosted: Tue Jan 01, 2019 1:37 pm    Post subject: Reply with quote

Thank you very much for your help! :)
Anon-E-moose wrote:
Do you have an /etc/rc.conf file? and if so is rc_parallel set to yes?

Yes, this config file is there, but the variable is commented out:
Code:
#rc_parallel="NO"

On my system only OpenRC runs, but no systemd. Only the empty packages systemd-dummy and libsystemd-dummy are installed.
I had the same system with systemd set up and found no problems there.

NeddySeagoon wrote:

This is my dmesg output:
https://bin.disroot.org/?41ea8a9acfcdeb8e#2tfDJcXN7LWd1rSqvOdFBanCEVn63Yeo7nV3mCKgHVg=
Back to top
View user's profile Send private message
Phoen7x
n00b
n00b


Joined: 29 Dec 2018
Posts: 16

PostPosted: Tue Jan 01, 2019 9:46 pm    Post subject: Reply with quote

With lxdm as loginmanager it is possible to start with
Code:
sudo rc-service xdm start
in the XFCE-desktop.
Problem with the NetworkManager solved by
Code:
rc-update add haveged boot


Does anyone have an idea why it always ends with lightdm in black screen with flashing cursor? Is lightdm incompatible with openrc?[/code]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum