Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No Sound - Sound card is not detected(?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
kiigass
n00b
n00b


Joined: 21 Nov 2018
Posts: 6

PostPosted: Thu Dec 06, 2018 2:04 pm    Post subject: No Sound - Sound card is not detected(?) Reply with quote

Hi,

I am pretty new to gentoo, but I am sure, you had many and more of these questions. I am sorry, though, I have to ask anyway and hope you are so kind as to help me =)

I just installed dbus, consolekit, pulseaudio and mpv following these wiki articles:
https://wiki.gentoo.org/wiki/D-Bus
https://wiki.gentoo.org/wiki/ConsoleKit
https://wiki.gentoo.org/wiki/PulseAudio
https://wiki.gentoo.org/wiki/Mpv

I did the startx integration for consolekit (https://wiki.gentoo.org/wiki/ConsoleKit#startx_integration) and I also did
Code:
root #rc-update add consolekit default
as described in the pulseaudio article.

I did a reboot afterwards. Then I tried (pulseaudio article):
Code:
getfacl /dev/snd/controlC0

But I don't have "controlC0", which got me suspicious. I ran "cat /proc/asound/cards", which returns "--- no soundcards ---". I think that is bad. "alsamixer" pretty much returns the same (F2/F6), though it says "Card: PulseAudio", "Chip: PulseAudio". Then I just tried to play a file and mpv gave me this:
Code:
Playing: Benny_Hill_Theme.mp3
 (+) Audio --aid=1 (mp3 2ch 44100Hz)
AO: [pulse] 44100Hz stereo 2ch s16
A: 00:00:07 / 00:04:32 (2%)


Exiting... (Quit)

But no sound.

Here is some more information:
Code:

lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)

Code:

ll /dev/snd/
total 0
1062 0 drwxr-xr-x.  2 root root       80 Dec  6 14:23 .
1025 0 drwxr-xr-x. 17 root root     3.7K Dec  6 14:45 ..
1064 0 crw-rw----+  1 root audio 116,  1 Dec  6 14:23 seq
1063 0 crw-rw----+  1 root audio 116, 33 Dec  6 14:23 timer

Code:

getfacl /dev/snd/seq
# file: dev/snd/seq
# owner: root
# group: audio
user::rw-
user:moritz:rw-
group::rw-
mask::rw-
other::---

Code:

getfacl /dev/snd/timer
# file: dev/snd/timer
# owner: root
# group: audio
user::rw-
user:moritz:rw-
group::rw-
mask::rw-
other::---


This is my kernel configuration:
https://pastebin.com/gpFRimVJ

I would appreciate a hint where to look next. Thank you.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6603
Location: Saint Amant, Acadiana

PostPosted: Thu Dec 06, 2018 2:23 pm    Post subject: Reply with quote

You need to enable ALSA support for your sound chip. PulseAudio needs ALSA (or OSS4) working, it can't use the sound hardware in its own. Below is the relevant part of your config.
Code:
# HD-Audio
#
CONFIG_SND_HDA=y
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_HWDEP=y
# CONFIG_SND_HDA_RECONFIG is not set
# CONFIG_SND_HDA_INPUT_BEEP is not set
# CONFIG_SND_HDA_PATCH_LOADER is not set
# CONFIG_SND_HDA_CODEC_REALTEK is not set
# CONFIG_SND_HDA_CODEC_ANALOG is not set
# CONFIG_SND_HDA_CODEC_SIGMATEL is not set
# CONFIG_SND_HDA_CODEC_VIA is not set
# CONFIG_SND_HDA_CODEC_HDMI is not set
# CONFIG_SND_HDA_CODEC_CIRRUS is not set
# CONFIG_SND_HDA_CODEC_CONEXANT is not set
# CONFIG_SND_HDA_CODEC_CA0110 is not set
# CONFIG_SND_HDA_CODEC_CA0132 is not set
# CONFIG_SND_HDA_CODEC_CMEDIA is not set
# CONFIG_SND_HDA_CODEC_SI3054 is not set
# CONFIG_SND_HDA_GENERIC is not set

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
kiigass
n00b
n00b


Joined: 21 Nov 2018
Posts: 6

PostPosted: Thu Dec 06, 2018 4:32 pm    Post subject: Reply with quote

Thank you very much! You nailed it!

To all future readers:

https://wiki.gentoo.org/wiki/ALSA
has some information on how to choose the correct codec for your sound card.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6603
Location: Saint Amant, Acadiana

PostPosted: Thu Dec 06, 2018 4:38 pm    Post subject: Reply with quote

kiigass,

well done! Congrats. :)
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum