Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with fontawesome
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 469

PostPosted: Mon Nov 19, 2018 2:36 pm    Post subject: Problem with fontawesome Reply with quote

Hello, i have emerged fontawesome, but i have problem, i would like to enable it, but awesome fonts don't appear in fonconfig ...

Look:
Code:
 fulgurance@msi-gs73vr-6rf  ~  sudo eselect fontconfig list                                   ✔  126  15:33:02
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-hinting-full.conf
  [3]   10-hinting-medium.conf
  [4]   10-hinting-none.conf
  [5]   10-hinting-slight.conf *
  [6]   10-no-sub-pixel.conf
  [7]   10-powerline-symbols.conf *
  [8]   10-scale-bitmap-fonts.conf *
  [9]   10-sub-pixel-bgr.conf
  [10]  10-sub-pixel-rgb.conf
  [11]  10-sub-pixel-vbgr.conf
  [12]  10-sub-pixel-vrgb.conf
  [13]  10-unhinted.conf
  [14]  11-lcdfilter-default.conf
  [15]  11-lcdfilter-legacy.conf
  [16]  11-lcdfilter-light.conf
  [17]  20-unhint-small-dejavu-sans.conf
  [18]  20-unhint-small-dejavu-sans-mono.conf
  [19]  20-unhint-small-dejavu-serif.conf
  [20]  20-unhint-small-vera.conf *
  [21]  25-unhint-nonlatin.conf
  [22]  30-metric-aliases.conf *
  [23]  40-nonlatin.conf *
  [24]  45-generic.conf *
  [25]  45-latin.conf *
  [26]  49-sansserif.conf *
  [27]  50-user.conf *
  [28]  51-local.conf *
  [29]  57-dejavu-sans.conf
  [30]  57-dejavu-sans-mono.conf
  [31]  57-dejavu-serif.conf
  [32]  60-generic.conf *
  [33]  60-latin.conf *
  [34]  60-liberation.conf
  [35]  61-stix.conf
  [36]  65-fonts-persian.conf *
  [37]  65-khmer.conf
  [38]  65-nonlatin.conf *
  [39]  66-noto-mono.conf
  [40]  66-noto-sans.conf
  [41]  66-noto-serif.conf
  [42]  69-unifont.conf *
  [43]  70-no-bitmaps.conf
  [44]  70-yes-bitmaps.conf
  [45]  75-yes-terminus.conf
  [46]  80-delicious.conf *
  [47]  90-synthetic.conf *
 fulgurance@msi-gs73vr-6rf  ~  eix fontawesome                                                ✔  127  15:33:28
[I] media-fonts/fontawesome
     Available versions:  (~)4.7.0(0/4) (~)5.0.6(0/5) (~)5.1.0(0/5) {X +otf +ttf}
     Installed versions:  5.1.0(0/5)(12:40:02 10/11/2018)(X otf ttf)
     Homepage:            https://fontawesome.com
     Description:         The iconic font
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 667
Location: Frankfurt, Germany

PostPosted: Mon Nov 19, 2018 10:21 pm    Post subject: Reply with quote

Package 'fontawesome' does not install any files in /etc/fonts/conf.avail - for that reason, you don't see an option in 'eselect fontconfig'.

Please note that most fonts don't install anything in /etc/fonts/conf.avail. And you usually don't 'select' fonts via eselect fontconfig.

What exactly do you want to do?
  • Do you want to use font 'fontawesome' in LibreOffice? Then start LibereOffice and select one of the fontawesome fonts.
  • Do you want to use font 'fontawsome' as the default font in your terminal? Then you have to configure your terminal to use font 'fontawesome'. Which terminal do you use?
  • ... or what else?
Please tell us what you want to do.
Back to top
View user's profile Send private message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 469

PostPosted: Tue Nov 20, 2018 4:22 pm    Post subject: Reply with quote

It's for use this fonts with zsh powerlevel9k theme. I have maked an ebuild that work fine with powerline fonts, but awesome fonts isn't show correctly. I think my terminal don't found or use it.

I use Konsole (kde)

My .zshrc file
Code:
POWERLEVEL9K_MODE='awesome-fontconfig'
source '/usr/share/zsh-theme-powerlevel9k/powerlevel9k.zsh-theme'
export HISTSIZE=5000
export HISTFILE="$HOME/.zsh_history"
export SAVEHIST=$HISTSIZE
autoload -U compinit
autoload -U promptinit
autoload -U bashcompinit
compinit
promptinit
bashcompinit
setopt hist_ignore_all_dups
setopt hist_ignore_space
setopt autocd
setopt extendedglob
neofetch
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 667
Location: Frankfurt, Germany

PostPosted: Tue Nov 20, 2018 4:51 pm    Post subject: Reply with quote

Do I understand correctly that you want to use one of the fontawesome fonts in konsole?

That's easy: In konsole, select Settings, Tab 'Appearance' and press 'Select font'. Then select one of the fontawesome fonts.
Back to top
View user's profile Send private message
Fulgurance
Guru
Guru


Joined: 15 Feb 2017
Posts: 469

PostPosted: Tue Nov 20, 2018 5:06 pm    Post subject: Reply with quote

No, i just would like this fonts are used by zsh powerlevel9k theme, not for all caracteres on my terminal. (and it's impossible because this font isn't listed into konsole...)
Back to top
View user's profile Send private message
kajzer
Apprentice
Apprentice


Joined: 27 Nov 2014
Posts: 297

PostPosted: Tue Nov 20, 2018 7:15 pm    Post subject: Reply with quote

I use powerlevel9k theme but with nerd fonts, it includes font awesome and much more, you can choose one font from here (or all , your choice)
https://github.com/ryanoasis/nerd-fonts/releases
I'm using ShareTechMono

In .zshrc file replace this line
Code:
POWERLEVEL9K_MODE='awesome-fontconfig'

with
Code:
POWERLEVEL9K_MODE='nerdfont-complete'
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum