Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
games-emulation/mupen64plus
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
dendro
n00b
n00b


Joined: 21 Jul 2018
Posts: 39

PostPosted: Mon Nov 12, 2018 10:23 pm    Post subject: games-emulation/mupen64plus Reply with quote

I'm having trouble emerging games-emulation/mupen64plus

Code:
 sudo emerge --ask games-emulation/mupen64plus


returns
Code:

!!! All ebuilds that could satisfy ">=games-emulation/mupen64plus-core-2.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- games-emulation/mupen64plus-core-2.5-r1::gentoo (masked by: ~amd64 keyword)

(dependency required by "games-emulation/mupen64plus-2.5::gentoo" [ebuild])
(dependency required by "games-emulation/mupen64plus" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


So I tried
Code:
 sudo ACCEPT_KEYWORDS="~amd64" emerge --ask games-emulation/mupen64plus


Which returns
Code:


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^                                                                                                                   
    (and 4 more with the same problem)

  (dev-qt/qtcore-5.11.2-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.11.2 required by (dev-qt/qtdbus-5.11.2:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                     
    (and 7 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.11.1[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, installed)
    ^             ^^^^^^                                                                                                                                         
    (and 2 more with the same problem)

  (dev-qt/qtgui-5.11.2-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.2[dbus] required by (dev-qt/qtwidgets-5.11.2:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^                                                                                                                                             
    (and 3 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.11.1 required by (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, installed)
    ^                 ^^^^^^                                                                                                                   

  (dev-qt/qtwidgets-5.11.2:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.11.2[gles2=] required by (dev-qt/qtopengl-5.11.2:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                                                               
    (and 1 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.11.1 required by (dev-qt/qtgui-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^                                                                                                                   

  (dev-qt/qtdbus-5.11.2:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.2 required by (dev-qt/qtbluetooth-5.11.2:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                         
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21335
Location: here

PostPosted: Tue Nov 13, 2018 6:49 am    Post subject: Re: games-emulation/mupen64plus Reply with quote

dendro wrote:
So I tried
Code:
 sudo ACCEPT_KEYWORDS="~amd64" emerge --ask games-emulation/mupen64plus

Adding ACCEPT_KEYWORDS="~amd64" isn't a good idea because this not unmask only package but all the dependencies.
If you want unmask packages use /etc/portage/package.accept_keywords
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dendro
n00b
n00b


Joined: 21 Jul 2018
Posts: 39

PostPosted: Thu Nov 15, 2018 4:37 am    Post subject: Re: games-emulation/mupen64plus Reply with quote

fedeliallalinea wrote:
dendro wrote:
So I tried
Code:
 sudo ACCEPT_KEYWORDS="~amd64" emerge --ask games-emulation/mupen64plus

Adding ACCEPT_KEYWORDS="~amd64" isn't a good idea because this not unmask only package but all the dependencies.
If you want unmask packages use /etc/portage/package.accept_keywords


Thanks this worked. :) I unmasked packages like you said with
Code:
/etc/portage/package.accept_keywords
one by one until mupen compiled.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum