Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PostgreSQL USe-FLAGS
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2762

PostPosted: Sun Nov 11, 2018 1:34 am    Post subject: PostgreSQL USe-FLAGS Reply with quote

Hi, ALL,
Code:

IgorReinCloud /home/igor/Sybase_16 # emerge -pv postgresql
] * Last emerge --sync was 36d 22h 50m 22s ago.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-postgresql-2.3::gentoo  5 KiB
[ebuild  N     ] dev-db/postgresql-10.5:10::gentoo  USE="nls pam readline server ssl zlib -doc -kerberos -ldap -libressl -perl -python (-selinux) -static-libs (-systemd) -tcl -threads -uuid -xml" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" 19,810 KiB

Total: 2 packages (2 new), Size of downloads: 19,814 KiB

 * IMPORTANT: 19 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.



The problem is that "server" USE-flag is not covered at [url]this wiki[/url], which should be an official documentation to install the DBMS.

Now do I understand correctly that if I turn that off I will compile and install only PostgreSQL client library and not the server?

Also, it would be nice if someone from the official Gentoo team who handle the PostgreSQL updates that page as it should be an official PostgreSQL documentation for Gentoo. I understand that it is WiKi and anybody can update it, but this page is meant as an official documentation on how to install the DBMS.

Thank you.
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 667
Location: Frankfurt, Germany

PostPosted: Sun Nov 11, 2018 2:02 am    Post subject: Reply with quote

BTW: ufed shows a strange message for USE flag 'server':
Quote:
(dev-db/postgresql): Disable to build and install the clients and libraries only

It would be much better to have something like: 'Install the PostgreSQL server'
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2762

PostPosted: Sun Nov 11, 2018 2:15 am    Post subject: Reply with quote

Hi,
Even weirder - from the PostgreSQL-10.5 ebuild:

Code:

pkg_config() {
   use server || die "USE flag 'server' not enabled. Nothing to configure."



So it looks like the "server" USE-flag is required to build the package?

Thank you.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13033

PostPosted: Sun Nov 11, 2018 5:27 am    Post subject: Reply with quote

No, USE=server is required to configure the package. If you don't have USE=server, none of the things you install can be configured, so there is no point to using emerge --configure in that case.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2762

PostPosted: Sun Nov 11, 2018 5:38 am    Post subject: Reply with quote

Hu,
Building libpg ( A native client library for PostgreSQL) still requires configuring. You just do:

Code:

configure
cd src/interfaces/libpq
make
make install


At least that what people at PostgreSQL told me.

But I'm just curious - if I turn off the "server" flag, what will happen? Will I get just libpg built and installed? Or it is for something else?

Thank you.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13033

PostPosted: Sun Nov 11, 2018 6:43 pm    Post subject: Reply with quote

You are conflating package configuration with build configuration. Yes, you may need to run an autoconf script to prepare the client source for compilation. However, that does not mean there is anything for the system administrator to configure after the package is installed. pkg_config is for system administrators, not for package builders.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2762

PostPosted: Sun Nov 11, 2018 7:11 pm    Post subject: Reply with quote

Hu,
So turning this USE-flag off means to build just the client libraries?

Thank you.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13033

PostPosted: Sun Nov 11, 2018 11:52 pm    Post subject: Reply with quote

That is how I interpret the description shown by equery use, yes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum