Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201811-09 ] Icecast
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2135

PostPosted: Sat Nov 10, 2018 4:26 am    Post subject: [ GLSA 201811-09 ] Icecast Reply with quote

Gentoo Linux Security Advisory

Title: Icecast: Arbitrary code execution (GLSA 201811-09)
Severity: high
Exploitable: remote
Date: 2018-11-10
Bug(s): #670148
ID: 201811-09

Synopsis

A vulnerability in Icecast might allow remote attackers to execute
arbitrary code.


Background

Icecast is an open source alternative to SHOUTcast that supports MP3,
OGG (Vorbis/Theora) and AAC streaming.


Affected Packages

Package: net-misc/icecast
Vulnerable: < 2.4.4
Unaffected: >= 2.4.4
Architectures: All supported architectures


Description

Multiple buffer overflows have been discovered in Icecast. Please review
the CVE identifier referenced below for details.


Impact

A remote attacker, by sending a specially crafted request using
authentication type “url”, could possibly execute arbitrary code with
the privileges of the process, or cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All Icecast users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/icecast-2.4.4"
   


References

CVE-2018-18820
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum