Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gentoo prefix] update qtgui failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
zhuyan
n00b
n00b


Joined: 30 Mar 2006
Posts: 54

PostPosted: Thu Aug 16, 2018 2:19 am    Post subject: [gentoo prefix] update qtgui failed Reply with quote

It is very strange. The last error during update is

/tools/bootstrap/gentoo/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/bin/qvkgen: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

ldd gives

Quote:
ldd /tools/bootstrap/gentoo/var/tmp/portage/dev-qt/qtgui-5.11.1/work/qtbase-everywhere-src-5.11.1/bin/qvkgen
linux-vdso.so.1 (0x00007fff8d5f8000)
libQt5Core.so.5 => not found
libc.so.6 => /tools/bootstrap/gentoo/lib64/libc.so.6 (0x00007fe11a3e5000)
/tools/bootstrap/gentoo/lib64/ld-linux-x86-64.so.2 (0x00007fe11a794000)


But I do have that libQt5Core.so.5 inside /tools/bootstrap/gentoo/usr/lib64:

Quote:

ls /tools/bootstrap/gentoo/usr/lib64/libQt5*so.5 -l
lrwxrwxrwx 1 zhuyan zhuyan 20 Aug 9 13:43 /tools/bootstrap/gentoo/usr/lib64/libQt5Core.so.5 -> libQt5Core.so.5.11.1
lrwxrwxrwx 1 zhuyan zhuyan 20 Aug 9 13:45 /tools/bootstrap/gentoo/usr/lib64/libQt5DBus.so.5 -> libQt5DBus.so.5.11.1
lrwxrwxrwx 1 zhuyan zhuyan 18 May 22 08:00 /tools/bootstrap/gentoo/usr/lib64/libQt5Gui.so.5 -> libQt5Gui.so.5.9.5
lrwxrwxrwx 1 zhuyan zhuyan 18 May 22 08:10 /tools/bootstrap/gentoo/usr/lib64/libQt5Svg.so.5 -> libQt5Svg.so.5.9.5
lrwxrwxrwx 1 zhuyan zhuyan 22 May 22 08:09 /tools/bootstrap/gentoo/usr/lib64/libQt5Widgets.so.5 -> libQt5Widgets.so.5.9.5
lrwxrwxrwx 1 zhuyan zhuyan 21 May 22 08:00 /tools/bootstrap/gentoo/usr/lib64/libQt5XcbQpa.so.5 -> libQt5XcbQpa.so.5.9.5
lrwxrwxrwx 1 zhuyan zhuyan 19 Aug 9 13:45 /tools/bootstrap/gentoo/usr/lib64/libQt5Xml.so.5 -> libQt5Xml.so.5.11.1


Even if I set LD_LIBRARY_PATH to /tools/bootstrap/gentoo/usr/lib64. It still can't find the so.5 file


Following the emerge --info output

Code:

zhuyan@localhost ~ $ emerge --info '=dev-qt/qtgui-5.11.1::gentoo'                                                       
fatal: not a git repository (or any of the parent directories): .git                                                     
Portage 2.3.46 (python 3.6.6-final-0, default/linux/amd64/17.0/no-multilib/prefix/kernel-2.6.32+, gcc-7.3.0, glibc-2.25-r11, 2.6.32-642.el6.x86_64 x86_64)                                                                                                                     
=================================================================                                                                       
                         System Settings                                                                                               
=================================================================                                                                       
System uname: Linux-2.6.32-642.el6.x86_64-x86_64-Intel-R-_Core-TM-_i7-3720QM_CPU_@_2.60GHz-with-centos-6.8-Final                       
KiB Mem:     1906276 total,    327484 free                                                                                             
KiB Swap:    2047996 total,   2030152 free                                                                                             
Timestamp of repository gentoo: Wed, 15 Aug 2018 09:30:01 +0000                                                                         
Head commit of repository gentoo: c28e489ab53d41813fe75a8a00e939ccffabd80f                                                             
sh bash 4.4_p23                                                                                                                         
ld GNU ld (Gentoo 2.30 p3) 2.30.0                                                                                                       
app-shells/bash:          4.4_p23::gentoo                                                                                               
dev-lang/perl:            5.26.2::gentoo                                                                                               
dev-lang/python:          2.7.15::gentoo, 3.5.5-r1::gentoo, 3.6.6::gentoo                                                               
dev-util/cmake:           3.12.0::gentoo                                                                                               
dev-util/pkgconfig:       0.29.2::gentoo                                                                                               
sys-apps/baselayout:      2.6-r1::gentoo                                                                                               
sys-apps/sandbox:         2.13::gentoo                                                                                                 
sys-devel/autoconf:       2.69-r4::gentoo                                                                                               
sys-devel/automake:       1.16.1-r1::gentoo                                                                                             
sys-devel/binutils:       2.30-r3::gentoo                                                                                               
sys-devel/gcc:            7.3.0-r3::gentoo                                                                                             
sys-devel/gcc-config:     1.9.1::gentoo                                                                                                 
sys-devel/libtool:        2.4.6-r5::gentoo                                                                                             
sys-devel/make:           4.2.1-r3::gentoo                                                                                             
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)                                                                             
sys-libs/glibc:           2.25-r11::gentoo                                                                                             
Repositories:                                                                                                                           

gentoo
    location: /tools/bootstrap/gentoo/usr/portage
    sync-type: rsync                             
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000                                 
    eclass-overrides: rap                           
    sync-rsync-verify-metamanifest: yes             
    sync-rsync-verify-max-age: 24                   
    sync-rsync-verify-jobs: 1                       
    sync-rsync-extra-opts:                           

rap
    location: /tools/bootstrap/gentoo/usr/portage-stage
    sync-type: git                                     
    sync-uri: https://anongit.gentoo.org/git/proj/android.git
    masters: gentoo                                         
    eclass-overrides: rap                                   

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"     
CBUILD="x86_64-pc-linux-gnu" 
CFLAGS="-O2 -pipe -O2 -pipe" 
CHOST="x86_64-pc-linux-gnu"   
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /tools/bootstrap/gentoo/etc/gentoo-release"
CXXFLAGS="-O2 -pipe -O2 -pipe"
DISTDIR="/tools/bootstrap/gentoo/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans unprivileged"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/tools/bootstrap/gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/tools/bootstrap/gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/tools/bootstrap/gentoo/var/tmp"
USE="acl amd64 berkdb bzip2 cli crypt cxx dri fortran gdbm iconv ipv6 libtirpc modules ncurses nls nptl openmp pcre prefix readline seccomp ssl tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5 python3_6" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
zhuyan
n00b
n00b


Joined: 30 Mar 2006
Posts: 54

PostPosted: Tue Aug 28, 2018 5:22 am    Post subject: Reply with quote

After some searching, it looks like Qt5-5.11 doesn't work on old linux kernel

https://bbs.archlinux.org/viewtopic.php?id=232682
Back to top
View user's profile Send private message
Vladimir Kunschikov
n00b
n00b


Joined: 09 Feb 2014
Posts: 2
Location: Russia

PostPosted: Thu Nov 08, 2018 7:27 pm    Post subject: Reply with quote

it can be solved by applying patch to the "QtCore" library.
You should create /etc/portage/patches/dev-qt/qtcore directory, then put there file with contents
Code:
diff -Nur a/src/corelib/global/minimum-linux_p.h b/src/corelib/global/minimum-linux_p.h
--- a/src/corelib/global/minimum-linux_p.h   2018-06-15 10:29:31.000000000 +0300
+++ b/src/corelib/global/minimum-linux_p.h   2018-11-08 22:22:52.463589580 +0300
@@ -77,19 +77,9 @@
  * - getrandom                  3.17                    QT_CONFIG(getentropy)
  */
 
-#if QT_CONFIG(getentropy)
-#  define MINLINUX_MAJOR        3
-#  define MINLINUX_MINOR        17
-#  define MINLINUX_PATCH        0
-#elif QT_CONFIG(renameat2)
-#  define MINLINUX_MAJOR        3
-#  define MINLINUX_MINOR        16
-#  define MINLINUX_PATCH        0
-#else
 #  define MINLINUX_MAJOR        2
 #  define MINLINUX_MINOR        6
 #  define MINLINUX_PATCH        28
-#endif
 
 #define MINIMUM_LINUX_VERSION  QT_VERSION_CHECK(MINLINUX_MAJOR, MINLINUX_MINOR, MINLINUX_PATCH)
 


and reemerge qtcore.

While loading some shared library glibc is checking not only SONAME but some elf file format notes. They can be read by executing
Code:

 readelf -n /usr/lib64/libQt5Core.so|grep Linux
    ОС: Linux, ABI: 3.17.0

in case of Gentoo and libqt5core.so it can be found in more human readable form:
Code:

 ldconfig -p|grep 5Core.so$
   libQt5Core.so (libc6,x86-64, ABI ОС: Linux 3.17.0) => /usr/lib64/libQt5Core.so
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum