Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Changed video card from Nvidia to Amd Vulkan help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
adcdam
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2015
Posts: 77

PostPosted: Thu Oct 25, 2018 9:31 pm    Post subject: [solved]Changed video card from Nvidia to Amd Vulkan help Reply with quote

Hi
I dont know how to set vulkan with the new card,
in the nvidia card i had a nvidia_icd.json file inside /etc/vulkan/icd.d
but i changed my video card to a rx580 and i dont have any file inside /etc/vulkan/icd.
i installed Amdgpu drivers
what files do i need?
do i need to install something else to have vulkan working?
i have media-libs/vulkan-loader installed.


Last edited by adcdam on Tue Oct 30, 2018 10:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5330

PostPosted: Fri Oct 26, 2018 2:21 am    Post subject: Reply with quote

Did you build mesa with vulkan support? Post the output of emerge --info mesa.

Having no files in /etc/vulkan/icd.d is correct, they should be in /usr/share/vulkan/icd.d/.
Back to top
View user's profile Send private message
adcdam
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2015
Posts: 77

PostPosted: Fri Oct 26, 2018 7:52 pm    Post subject: Reply with quote

I have a very old version of mesa. it seems it was build without vulkan support


Code:
media-libs/mesa-17.2.8::xorg-kit was built with the following:
USE="classic dri3 egl gallium gbm llvm nptl xa -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="radeonsi (-freedreno) -i915 -i965 (-imx) -intel -nouveau -r100 -r200 -r300 -r600 -radeon (-vc4) -virgl (-vivante) -vmware"
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1390

PostPosted: Fri Oct 26, 2018 9:40 pm    Post subject: Reply with quote

adcdam wrote:

Code:

...mesa-17.2.8::xorg-kit...


I don`t know how to set the USE flags in funtoo. If it's done as in gentoo, then in make.conf oder package.use.
But the best point for you is to ask here: https://forums.funtoo.org/

And it would not be a bad idea to update the system.
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
adcdam
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jan 2015
Posts: 77

PostPosted: Tue Oct 30, 2018 10:50 pm    Post subject: Resolved by Marlo via PM Reply with quote

Resolved by Marlo via PM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum