Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO; ]virtualbox - error in supliboslnit
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
zar Marco
Guru
Guru


Joined: 09 Sep 2016
Posts: 381
Location: Colle Umberto ( TV )

PostPosted: Sun Oct 14, 2018 9:39 am    Post subject: Reply with quote

Per il downgrade, scarica le gentoo sources più vecchie in un altro slot, se non ne hai già, seleziona con eselect e compila il Kernel appena scaricato, poi dal boot scegli con cosa bootare
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Sun Oct 14, 2018 11:28 am    Post subject: Reply with quote

zar Marco wrote:
Per il downgrade, scarica le gentoo sources più vecchie in un altro slot, se non ne hai già, seleziona con eselect e compila il Kernel appena scaricato, poi dal boot scegli con cosa bootare

Deve anche smascherare il pacchetto perche' la versione che vuole mettere, 4.14.52, e' mascherata.

@trigg: cosa non funziona con l'update del kernel?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Sun Oct 14, 2018 12:43 pm    Post subject: Reply with quote

sto per l'ennesima volta installando
gentoo-sources versione 4.14.65

e compilare il kernel 4.14.65 con genkernel all

la mia impressione è che nonostante l'aggiornamento resto fermo al 4.14.52

l'anomalia la si vede dal kernel in uso (terminale)
e la versione in funzione data dal conky

https://i.imgur.com/QtQTeI7.png

mi posso sbagliare
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Sun Oct 14, 2018 12:54 pm    Post subject: Reply with quote

la versione effettiva che usi la vedi con uname -a.
<che passi hai fatto dopo avere compilato il kernel con genkernel?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Sun Oct 14, 2018 12:56 pm    Post subject: Reply with quote

Code:
gentoo /home/trigg # eselect kernel list
Available kernel symlink targets:
  [1]   linux-4.14.65-gentoo *


gentoo /home/trigg #  uname -a
Linux gentoo 4.14.52-gentoo #1 SMP Sun Jul 1 18:45:59 CEST 2018 x86_64 AMD Athlon(tm) 5150 APU with Radeon(tm) R3 AuthenticAMD GNU/Linux



ho seguito questi comandi dopo il genkern all

Code:
# grub-mkconfig -o /boot/grub/grub.cfg
# emerge @module-rebuild



durante il genkernl all compare questa riga che fa riferimento al firmware

Code:
Not installing firmware as requested by configuration FIRMWARE_INSTALL=no...
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Sun Oct 14, 2018 2:11 pm    Post subject: Reply with quote

questo e quello che mi dice con il gernkernel all

Code:
gentoo /home/trigg # genkernel all
* Gentoo Linux Genkernel; Version 3.5.3.3
* Running with options: all

* Using genkernel.conf from /etc/genkernel.conf
* Sourcing arch-specific config.sh from /usr/share/genkernel/arch/x86_64/config.sh ..
* Sourcing arch-specific modules_load from /usr/share/genkernel/arch/x86_64/modules_load ..
* Linux Kernel 4.14.65-gentoo for x86_64...
* .. with config file /etc/kernels/kernel-config-x86_64-4.14.65-gentoo
* kernel: Using config from /etc/kernels/kernel-config-x86_64-4.14.65-gentoo
* kernel: >> Running mrproper...
*         >> Running oldconfig...
* kernel: >> Cleaning...
*         >> Compiling 4.14.65-gentoo bzImage...
*         >> Not installing firmware as requested by configuration FIRMWARE_INSTALL=no...
*         >> Compiling 4.14.65-gentoo modules...
*         >> Installing 4.14.65-gentoo modules (and stripping)
*         >> Generating module dependency data...
* Copying config for successful build to /etc/kernels/kernel-config-x86_64-4.14.65-gentoo
* busybox: >> Using cache
* initramfs: >> Initializing...
*         >> Appending devices cpio data...
*         >> Appending base_layout cpio data...
*         >> Appending auxilary cpio data...
*         >> Copying keymaps
*         >> Appending busybox cpio data...
*         >> Appending modules cpio data...
*         >> Appending blkid cpio data...
*         >> Appending modprobed cpio data...
*         >> Appending linker cpio data...
*         >> Deduping cpio...
*         >> Compressing cpio data (.xz)...
*
* Kernel compiled successfully!
*
* Required Kernel Parameters:
*     root=/dev/$ROOT
*
*     Where $ROOT is the device node for your root partition as the
*     one specified in /etc/fstab
*
* If you require Genkernel's hardware detection features; you MUST
* tell your bootloader to use the provided INITRAMFS file.

* WARNING... WARNING... WARNING...
* Additional kernel cmdline arguments that *may* be required to boot properly...
* With support for several ext* filesystems available, it may be needed to
* add "rootfstype=ext3" or "rootfstype=ext4" to the list of boot parameters.

* Do NOT report kernel bugs as genkernel bugs unless your bug
* is about the default genkernel configuration...
*
* Make sure you have the latest ~arch genkernel before reporting bugs.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Sun Oct 14, 2018 3:00 pm    Post subject: Reply with quote

Puoi postare anche il contenuto della boot?
Code:
$ ls /boot/

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 620

PostPosted: Sun Oct 14, 2018 6:34 pm    Post subject: Reply with quote

Non so come è impostata la conf di genkernel , ma prova a mettere l'opzione --install quando compili con genkernel
Senza quella , l'immagine non viene inserita nella /boot

Code:
--[no-]install
           Installs, or does not install the kernel to /boot after building. The default is --install. If MOUNTBOOT is set in /etc/genkernel.conf then /boot will be automatically mounted if it is not already mounted before the ramdisk
           and kernel images are copied over.


io la utilizo sempre nel comando di compilazione
e nella conf non è impostata
Code:
# =========Common Command Line Option Defaults=========

# Should we install to $BOOTDIR?  Default is "no" because genkernel is used in
# catalyst and stage building.
#INSTALL="yes"

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Mon Oct 15, 2018 5:54 am    Post subject: Reply with quote

buongiorno

questo è il conteuto della boot

Code:
gentoo /home/trigg # ls /boot/
grub                                       kernel-genkernel-x86_64-4.14.65-gentoo
initramfs-genkernel-x86_64-4.14.52-gentoo  lost+found
initramfs-genkernel-x86_64-4.14.65-gentoo  System.map-genkernel-x86_64-4.14.52-gentoo
kernel-genkernel-x86_64-4.14.52-gentoo     System.map-genkernel-x86_64-4.14.65-gentoo


adesso ho lanciato

genkernel all --install

e vi terrò aggiornati a fine compilazione


per quanto riguarda questo passaggio citatato da sabayonino non ho la più pallida idea su come fare

Quote:
io la utilizo sempre nel comando di compilazione
e nella conf non è impostata
Codice:
# =========Common Command Line Option Defaults=========

# Should we install to $BOOTDIR? Default is "no" because genkernel is used in
# catalyst and stage building.
#INSTALL="yes"
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Mon Oct 15, 2018 6:12 am    Post subject: Reply with quote

trigg wrote:
questo è il conteuto della boot

Code:
gentoo /home/trigg # ls /boot/
grub                                       kernel-genkernel-x86_64-4.14.65-gentoo
initramfs-genkernel-x86_64-4.14.52-gentoo  lost+found
initramfs-genkernel-x86_64-4.14.65-gentoo  System.map-genkernel-x86_64-4.14.52-gentoo
kernel-genkernel-x86_64-4.14.52-gentoo     System.map-genkernel-x86_64-4.14.65-gentoo

Quindi il kernel e' installato in boot, e cosa ritorna il comando
Code:
# grub-mkconfig -o /boot/grub/grub.cfg

e magari posta anche il contenuto del file /boot/grub/grub.cfg
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Mon Oct 15, 2018 7:33 am    Post subject: Reply with quote

a seguito di genkernel all --install
ho avuto lo stersso output di genkernel all

Code:
gentoo /home/trigg # genkernel all --install
* Gentoo Linux Genkernel; Version 3.5.3.3
* Running with options: all --install

* Using genkernel.conf from /etc/genkernel.conf
* Sourcing arch-specific config.sh from /usr/share/genkernel/arch/x86_64/config.sh ..
* Sourcing arch-specific modules_load from /usr/share/genkernel/arch/x86_64/modules_load ..
* Linux Kernel 4.14.65-gentoo for x86_64...
* .. with config file /etc/kernels/kernel-config-x86_64-4.14.65-gentoo
* kernel: Using config from /etc/kernels/kernel-config-x86_64-4.14.65-gentoo
* kernel: >> Running mrproper...
*         >> Running oldconfig...
* kernel: >> Cleaning...
*         >> Compiling 4.14.65-gentoo bzImage...
*         >> Not installing firmware as requested by configuration FIRMWARE_INSTALL=no...
*         >> Compiling 4.14.65-gentoo modules...
*         >> Installing 4.14.65-gentoo modules (and stripping)
*         >> Generating module dependency data...
* Copying config for successful build to /etc/kernels/kernel-config-x86_64-4.14.65-gentoo
* busybox: >> Using cache
* initramfs: >> Initializing...
*         >> Appending devices cpio data...
*         >> Appending base_layout cpio data...
*         >> Appending auxilary cpio data...
*         >> Copying keymaps
*         >> Appending busybox cpio data...
*         >> Appending modules cpio data...
*         >> Appending blkid cpio data...
*         >> Appending modprobed cpio data...
*         >> Appending linker cpio data...
*         >> Deduping cpio...
*         >> Compressing cpio data (.xz)...
*
* Kernel compiled successfully!
*
* Required Kernel Parameters:
*     root=/dev/$ROOT
*
*     Where $ROOT is the device node for your root partition as the
*     one specified in /etc/fstab
*
* If you require Genkernel's hardware detection features; you MUST
* tell your bootloader to use the provided INITRAMFS file.

* WARNING... WARNING... WARNING...
* Additional kernel cmdline arguments that *may* be required to boot properly...
* With support for several ext* filesystems available, it may be needed to
* add "rootfstype=ext3" or "rootfstype=ext4" to the list of boot parameters.

* Do NOT report kernel bugs as genkernel bugs unless your bug
* is about the default genkernel configuration...
*
* Make sure you have the latest ~arch genkernel before reporting bugs.


l'output di grub-mkconfig -o /boot/grub/grub.cfg mi da

Code:
gentoo /home/trigg #  grub-mkconfig -o /boot/grub/grub.cfg
Generazione file di configurazione GRUB...
Trovata immagine linux: /boot/kernel-genkernel-x86_64-4.14.65-gentoo
Trovata immagine initrd: /boot/initramfs-genkernel-x86_64-4.14.65-gentoo
Trovata immagine linux: /boot/kernel-genkernel-x86_64-4.14.52-gentoo
Trovata immagine initrd: /boot/initramfs-genkernel-x86_64-4.14.52-gentoo
  /run/lvm/lvmetad.socket: connect failed: File o directory non esistente
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.
Trovato Arch Linux su /dev/sda11
fatto


nel link sotto il contenuto di /boot/grub/grub.cfg

https://paste.pound-python.org/show/Bxmihlu7zSXZ9GQVlrid/
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Mon Oct 15, 2018 7:51 am    Post subject: Reply with quote

A parte il messaggio
Code:
  /run/lvm/lvmetad.socket: connect failed: File o directory non esistente
  WARNING: Failed to connect to lvmetad. Falling back to internal scanning.

che e' un warning e quindi non dovrebbe causare problemi (usi lvm?), non vedo nulla di errato.
Il kernel nuovo viene rilevato e inserito nel menu di grub. Quando fai reboot prova a vedere nel menu di grub se c'e' il kernel 4.14.65 come opzione
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Mon Oct 15, 2018 9:10 am    Post subject: Reply with quote

forse ho capito tra un faccio la prova a cambiare grub customizer in arch linux
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Mon Oct 15, 2018 9:44 am    Post subject: Reply with quote

allora il discorso del kernel dipendeva dall'impostazioni di grub customizer in arch-linux

Code:
gentoo /home/trigg #  uname -a
Linux gentoo 4.14.65-gentoo #1 SMP Mon Oct 15 08:09:10 CEST 2018 x86_64 AMD Athlon(tm) 5150 APU with Radeon(tm) R3 AuthenticAMD GNU/Linux
gentoo /home/trigg #



resta la finestra di errore nel lancio di virtualbox

Code:
Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Mon Oct 15, 2018 11:11 am    Post subject: Reply with quote

Visto che hai rilanciato genkernel un paio di volte prova a ricompilare i moduli
Code:
# emerge @module-rebuild

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Mon Oct 15, 2018 12:44 pm    Post subject: Reply with quote

nulla di fatto

se eseguo modprobe vboxdrv
virtualbox parte

non so se può essere causa del problema
durante l'avvio di gentoo viene tra le tante scritte in verde seguite da [ok]
una scritta in rosso che dice piu o meno
error modules failed to start

cmq per oggi sono al limite
sembra che non carica i moduli all'avvio e quindi come ho già detto devo aggiungerli ogni volta a mano.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Mon Oct 15, 2018 2:04 pm    Post subject: Reply with quote

Per il caricamento dei moduli hai seguito i relativi passi della guida?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Fri Oct 19, 2018 7:10 am    Post subject: Reply with quote

si li avevo già visti
senza risultato

credo che l'unico modo rimasto è quello di lanciare in automatico allìavvio del sitema
con uno script i comandi
modprobe vboxdrv ; modprobe vboxnetad ; modprobe vboxnetflt ; modprobe vboxpci


come posso lanciare uno script senza digitare la password in automatico?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Fri Oct 19, 2018 7:19 am    Post subject: Reply with quote

Sul mio sistema ho messo questi moduli in /etc/conf.d/modules
/etc/conf.d/modules:
...
modules="vboxdrv vboxnetadp vboxnetflt"
...

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Fri Oct 19, 2018 2:03 pm    Post subject: Reply with quote

ho controllato diverse volte i moduli a parte l'errore che mi da durante l'avvio del sistema

faiiled to load module /etc/init.d (piu o meno)
tutto sembra in ordine.

cmq per ovviare al mancanto caricamento dei moduli ho fatto 3 passaggi

1) modificato il file /etc/sudoers
aggiungnedo la riga
Code:
## Same thing without a password
# %wheel ALL=(ALL) NOPASSWD: ALL
trigg ALL=(ALL) NOPASSWD: /mnt/DATI/gentoo/virtualbox/mod.sh


2) creato lo script mos.sh in /mnt/DATI/gentoo/virtualbox/mod.s
Code:
#!/bin/bash

modprobe vboxdrv
#modprobe vboxnetad
modprobe vboxnetflt
modprobe vboxpci
ntpdate -b time.ien.it
exit


3) aggiuunto il comando
Code:
sudo  /mnt/DATI/gentoo/virtualbox/mod.sh

in impèostazioni->sessione avvio->avvio automatico

in questo modo quando si avvia gentoo viene eseguito lo script che carica i moduli , senza dover digitare la pwd
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Fri Oct 19, 2018 2:09 pm    Post subject: Reply with quote

Hai provato la mia soluzione tramite file /etc/conf.d/modules?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Fri Oct 19, 2018 2:59 pm    Post subject: Reply with quote

questo è il file /etc/conf.d/modules

Code:
# Linux users can define a list of modules for a specific kernel version,
# a released kernel version, a main kernel version or all kernel versions.
# The most specific versioned variable will take precedence.
# FreeBSD users can only use the modules="foo bar" setting.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules_2="ipv6"
#modules="ohci1394"

# Linux users can give modules a different name when they load - the new name
# will also be used to pick arguments below.
# This is not supported on FreeBSD.
#modules="dummy:dummy1"

# Linux users can give the modules some arguments if needed, per version
# if necessary.
# Again, the most specific versioned variable will take precedence.
# This is not supported on FreeBSD.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="debug2"
#module_ieee1394_args_2_6_23="debug3"
#module_ieee1394_args_2_6="debug4"
#module_ieee1394_args_2="debug5"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.
modules = "vboxdrv vboxnetadp vboxnetflt vboxpci"


la riga modules = "vboxdrv vboxnetadp vboxnetflt vboxpci"[
è già esisitente

cmq con lo script avviato e la modifica di sudoers virtualbox si avvia normalmente
anche se è una soluzione poco ortodossa funziona

il bello di linux è anche questo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19883
Location: here

PostPosted: Fri Oct 19, 2018 3:18 pm    Post subject: Reply with quote

Sei sicuro che puoi mettere gli spazi
Code:
modules = "vboxdrv vboxnetadp vboxnetflt vboxpci"
       | |
       qua?

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
trigg
Apprentice
Apprentice


Joined: 14 Jun 2018
Posts: 179

PostPosted: Fri Oct 19, 2018 3:33 pm    Post subject: Reply with quote

[RISOLTO]
a caratteri cubitali
cavolo 3 settimane a cercare il problema alla fine si è trovato l'ago nel pagliaio

in effetti era sbagliato /etc/conf.d/modules

da
modules = "vboxdrv vboxnetadp vboxnetflt"

con gli spazi , mi dava errore

a

modules="vboxdrv vboxnetadp vboxnetflt"

senza errore e tutto ha ripreso a funzionare come prima

grazie Fedeliallalinea
ho sistemato finalmente questo problema imparando anche qualche altra cosa in più :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum