Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenGL is not working with DRI on nvidia + i915
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
g4s8
n00b
n00b


Joined: 15 Dec 2017
Posts: 12

PostPosted: Thu Oct 11, 2018 7:45 am    Post subject: OpenGL is not working with DRI on nvidia + i915 Reply with quote

I have a laptop with nvidia and intel video cards. I've just set up Xorg server and able to start it using startx. But when I try to check opengl it fails:
Code:

# glxinfo
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig


My xorg.conf is empty, nvidia drivers are loaded, i915 driver is built into kernel (as DRI option).
Code:

# lsmod | grep -i nvidia
nvidia_drm             40960  0
nvidia_modeset       1060864  1 nvidia_drm
nvidia              13553664  25 nvidia_modeset
ipmi_msghandler        40960  1 nvidia


OpenGL configuration is references to nvidia:
Code:

# eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
# eselect opencl list
Available OpenCL implementations:
  [1]   nvidia *


Video cards option:
Code:

# cat /etc/portage/make.conf | grep VIDEO_CARDS
VIDEO_CARDS="nvidia i915 intel"


lshw output:
Code:

# lshw -c display
  *-display                 
       description: VGA compatible controller
       product: GP106M [GeForce GTX 1060 Mobile 3GB]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:140 memory:ec000000-ecffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:4000(size=128) memory:ed000000-ed07ffff
  *-display
       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:122 memory:eb000000-ebffffff memory:80000000-8fffffff ioport:5000(size=64) memory:c0000-dffff


Can someone help me please to make nvidia working with intel via DRI and configure opengl?
Back to top
View user's profile Send private message
LIsLinuxIsSogood
l33t
l33t


Joined: 13 Feb 2016
Posts: 892

PostPosted: Fri Oct 19, 2018 8:47 am    Post subject: Reply with quote

Is DRM configure din the kernel? Check kernel configuration for CONFIG_DRM and post output.

I've not read too much about this card (is it a combo of nvidia+intel card) that does support hopefully support what you are trying to do.

But I don't know if Nvidia portion of the card is truly independent of the intel portion so I don't know about this, but eliminating the intel support in the kernel...would that possibly break the graphical system altogether? I don't know if that is the answer, but DRM and Nvidia drivers do conflict and could require rebuild of the drivers.
Back to top
View user's profile Send private message
g4s8
n00b
n00b


Joined: 15 Dec 2017
Posts: 12

PostPosted: Thu Oct 25, 2018 2:29 pm    Post subject: Reply with quote

LIsLinuxIsSogood wrote:
Is DRM configure din the kernel? Check kernel configuration for CONFIG_DRM and post output.

I've not read too much about this card (is it a combo of nvidia+intel card) that does support hopefully support what you are trying to do.

But I don't know if Nvidia portion of the card is truly independent of the intel portion so I don't know about this, but eliminating the intel support in the kernel...would that possibly break the graphical system altogether? I don't know if that is the answer, but DRM and Nvidia drivers do conflict and could require rebuild of the drivers.


Thanks. I've fixed it by installing https://wiki.gentoo.org/wiki/NVIDIA/Bumblebee and configuring i915 as a primary graphic card using Xorg-X11 libs as default OpenGL, now I can use Nvidia OpenGL implementation by running process with primusrun:
Code:

# glxinfo | grep -i "opengl version"
OpenGL version string: 3.0 Mesa 18.1.9

# primusrun glxinfo | grep -i "opengl version"
OpenGL version string: 4.6.0 NVIDIA 396.54
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum