Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Raid array needing resync at boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 610

PostPosted: Tue Oct 16, 2018 7:19 pm    Post subject: Raid array needing resync at boot Reply with quote

I've had some odd issues with my RAID array recently. For example, today, after a hasty reboot (i.e. I didn't check if any other ttys were logged in) the system dragged while it did an mdadm resync.
Digging about, I wonder if there should be an
Code:
mdadm --wait-clean /dev/md127
included in the shutdown process.

(I should add that I use an initramfs to mount the array.)

This didn't used to be an issue - perhaps I was lucky - but I notice there's been a similar problem (O.K. it seems to be caused by systemd ...) in Ubunto last year.

I tried looking at old versions of OpenRc, which I use, to see if mdadm gets called anywhere, but not obviously (but my limited Git skills mean I might have missed something).

I'm wondering about adding such a command to say stop() in /etc/init.d/root or /etc/init.d/localmount.

Oh, more digging. There seems to be a confirmed but unfixed bug from 2011 covering this. I suspect it's supposed to have been fixed by ensuring /etc/init.d/mdadm shuts down cleanly, but my logs show that did happen and I still got an mdadm resync.

I guess I could convert to systemd and use their hack to find some dangling processes from my initramfs :-)
_________________
Greybeard
Back to top
View user's profile Send private message
log_null
n00b
n00b


Joined: 28 Nov 2011
Posts: 15

PostPosted: Thu Oct 18, 2018 10:23 pm    Post subject: Reply with quote

Not directly related to RAID, but services and volumes at all ( openrc ) ... I had an issue related to service (mariadb) which used to depends of a iscsi LUN no matter what configured at service dependency, the volume wasn't ready and mounted before the service. My dirty workaround was to create a service script ( running after multipath and before mariadb) just to wait a few seconds .
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum