Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
atom-9999::mva fails to emerge at install phase
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1077
Location: Stuttgart, Germany

PostPosted: Fri Oct 12, 2018 2:51 pm    Post subject: atom-9999::mva fails to emerge at install phase Reply with quote

So, I got here by several steps:

using app-editor/atom-1.32.0_beta3 from the cynede overlay, I was unable to update dependent packages: the file /usr/share/atom/resources/app/apm/node_modules/npm/node_modules/npm-lifecycle/node-gyp-bin/node-gyp refused to execute with a "Permission denied" error. So I thought this was just something wrong with that version (the file, incidentally, also points to the wrong directory to find the linked node-gyp.js executable, but even when this is fixed it fails out). So I tried the mva overlay, which appears to have a "live" ebuild for atom-9999.

Trying to install that, however, it fails at the install phase with the following error:

Code:
Running electron-packager on /var/tmp/portage/app-editors/atom-9999/work/atom-9999/out/app with app name "atom"

... and 1 more
Packaging app for platform linux x64 using electron v2.0.11
Changing permissions for node files in /var/tmp/portage/app-editors/atom-9999/work/atom-9999/out/atom-dev-1.33.0-dev-d29bb96c8-amd64
Copying non-ASAR resources to /var/tmp/portage/app-editors/atom-9999/work/atom-9999/out/atom-dev-1.33.0-dev-d29bb96c8-amd64/resources
Writing LICENSE.md to /var/tmp/portage/app-editors/atom-9999/work/atom-9999/out/atom-dev-1.33.0-dev-d29bb96c8-amd64/resources
Application bundle created at /var/tmp/portage/app-editors/atom-9999/work/atom-9999/out/atom-dev-1.33.0-dev-d29bb96c8-amd64
Generating snapshot script at "/var/tmp/portage/app-editors/atom-9999/work/atom-9999/out/startup.js" (189)Error: ENOENT: no such file or directory, open 'exception-reporting'
  at Object.fs.openSync (fs.js:660:18)
  at Object.fs.readFileSync (fs.js:565:33)
  at /var/tmp/portage/app-editors/atom-9999/work/atom-9999/script/node_modules/electron-link/lib/generate-snapshot-script.js:28:27
  at Generator.next (<anonymous>:null:null)
  at step (/var/tmp/portage/app-editors/atom-9999/work/atom-9999/script/node_modules/electron-link/lib/generate-snapshot-script.js:3:191)
  at /var/tmp/portage/app-editors/atom-9999/work/atom-9999/script/node_modules/electron-link/lib/generate-snapshot-script.js:3:361
  at <anonymous>:null:null


Can somebody help me please sort out all the various packages that are breaking on my atom install?

cheers,

EE
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10147
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Oct 12, 2018 3:49 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software. The cynede overlay is not officially supported so the thread fits better here.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1077
Location: Stuttgart, Germany

PostPosted: Fri Oct 12, 2018 5:56 pm    Post subject: Reply with quote

well, technically we're talking about the mva overlay now, since that's the one I can't emerge. But since that one isn't officially supported either, iirc, I guess it doesn't much matter.

Any guess what this error is?

Cheers,

EE
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1077
Location: Stuttgart, Germany

PostPosted: Tue Oct 16, 2018 1:37 pm    Post subject: Reply with quote

I've been digging into this a bit, and now I have a peripheral question: it may be the case that atom-1.32.0 requires a more recent version of nodejs, but that would require using openssl-1.1*, which is currently masked. So here's my next question: how likely will unmasking openssl-1.1.0i (which is what's in the portage tree right now for the -1.1* series) børk my system? The bugreports strongly suggest the likelihood is high, but maybe it's not so terrible?

Cheers,

EE
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19934
Location: here

PostPosted: Tue Oct 16, 2018 1:47 pm    Post subject: Reply with quote

You can check if there are packages installed in your system with a open bug for openssl-1.1

EDIT: openssl-1.1 is hard masked, then the chance of having problems is high
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12964

PostPosted: Wed Oct 17, 2018 2:20 am    Post subject: Reply with quote

We have somewhat routinely see forum threads from people who had a problem that was traced to them unmasking OpenSSL 1.1. In those cases, they did it unknowingly because they blindly trusted autounmask. You would be in a slightly better position since you would know to be suspicious of OpenSSL-related failures. If you retain a tbz2 of openssl-1.0.x, you should be able to back out if the situation goes badly. There might still be a fair amount of rebuilding to get all packages back to the 1.0.x subslot though.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1077
Location: Stuttgart, Germany

PostPosted: Sat Oct 20, 2018 7:45 pm    Post subject: Reply with quote

addendum: it turns out that the problem I have with atom only occurs on the 1.32.* branch. The 1.31.* version (which appears to be the last that appears to require USE="python_targets_python2_7") works fine.

So, I suspect that whatever changed for the 1.32.* branch, be it python 3, or something else, is preventing the gyp-rebuild process from working properly.

But since the workaround is just to use atom-1.31.1, I can just do that.

Cheers,

EE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum