Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Upgrading Portage (python dependency)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Fri Oct 12, 2018 11:36 pm    Post subject: [SOLVED] Upgrading Portage (python dependency) Reply with quote

Hi,

I'm trying to do an upgrade for my system, i think it's a total mess lol

Any help is appreciated

Code:


sudo emerge -av --oneshot sys-apps/portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-crypt/openpgp-keys-gentoo-release-20180706::gentoo  USE="{-test}" 44 KiB
[ebuild  N     ] dev-python/bz2file-0.98::gentoo  PYTHON_TARGETS="python2_7 (-pypy)" 12 KiB
[ebuild   R   ~] dev-python/setuptools-38.5.1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4* python3_5 python3_6* -pypy -pypy3" 0 KiB
[ebuild     U  ] dev-python/certifi-2018.4.16::gentoo [2017.4.17::gentoo] PYTHON_TARGETS="python2_7 python3_4* python3_5 python3_6* (-pypy) (-pypy3) (-python3_7)" 147 KiB
[ebuild  N     ] app-portage/gemato-14.0::gentoo  USE="blake2 bzip2 gpg -lzma -sha3 {-test} -tools" PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_4 -python3_5 (-python3_7)" 70 KiB
[ebuild     U *] sys-apps/portage-9999::gentoo [2.3.24-r1::gentoo] USE="(ipc) native-extensions rsync-verify* xattr -build -doc -epydoc -gentoo-dev (-selinux)" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4 -python3_5* -python3_7%" 0 KiB

Total: 6 packages (2 upgrades, 3 new, 1 reinstall), Size of downloads: 271 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

  (sys-apps/portage-9999:0/0::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/portage (Argument)

  (sys-apps/portage-2.3.24-r1:0/0::gentoo, installed) pulled in by
    sys-apps/portage[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (app-portage/layman-2.4.2-r1:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                             
    sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-java/java-config-2.2.0-r4:2/2::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                         
    sys-apps/portage[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (app-portage/gentoolkit-0.4.0:0/0::gentoo, installed)
                                                                                                                                                                                                                                                                                                                                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-libs/glibc-2.25-r10::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- net-libs/libnsl-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (11 Sep 2018)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.

- dev-perl/DBD-mysql-4.41.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Kent Fredric <kentnl@gentoo.org> (27 May 2018)
# Subject to Man-in-the-middle security bypass vulnerability.
# Retained in tree only for users who need older versions
# for compatibility reasons.
# Bug: #623942

- sys-libs/binutils-libs-2.29.1-r1::gentoo (masked by: package.mask)
- app-eselect/eselect-mesa-0.0.10-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Matt Turner <mattst88@gentoo.org> (29 Sep 2018)
# Removal in 30 days, bug #576334

- sys-devel/binutils-2.29.1-r1::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Last edited by Troopo on Wed Oct 24, 2018 6:01 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6229
Location: Room 101

PostPosted: Sat Oct 13, 2018 5:01 am    Post subject: Reply with quote

Troopo ...

both layman and java-config need to be re-merged to provide the required/matching PYTHON_TARGETS. This may happen automatically if '--changed-use --with-bdeps=y --deep' were provided, but if not then the following should pick up those, and any other package in which PYTHON_TARGET="python3_6" is available.

Code:
# emerge --oneshot --ask $(eix --only-names --exact --installed-without-use python_single_target_python3_6)

HTH & best ... khay
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3505
Location: Germany

PostPosted: Sat Oct 13, 2018 10:53 am    Post subject: Reply with quote

Yes, or try it first without change the PYTHON_TARGETS and new dependencies
Code:
# USE="-rsync-verify" PYTHON_TARGETS="python2_7 python3_5" emerge -av1 --autounmask=n =sys-apps/portage-2.3.49

and run then a normal `emerge -avuDN @world` update.
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Sat Oct 13, 2018 11:40 pm    Post subject: Reply with quote

Thanks Guys, i think that helped
Unfortunately now i got much more problems but that's progress right? :)

Code:

[blocks B      ] <x11-proto/videoproto-2.3.3-r1 ("<x11-proto/videoproto-2.3.3-r1" is blocking x11-base/xorg-proto-2018.4)
[blocks B      ] <x11-proto/xextproto-7.3.0-r1 ("<x11-proto/xextproto-7.3.0-r1" is blocking x11-base/xorg-proto-2018.4)
[blocks B      ] <x11-proto/inputproto-2.3.2-r1 ("<x11-proto/inputproto-2.3.2-r1" is blocking x11-base/xorg-proto-2018.4)
[blocks B      ] <sys-libs/glibc-2.26 ("<sys-libs/glibc-2.26" is blocking net-libs/rpcsvc-proto-1.3.1-r1)

Total: 611 packages (483 upgrades, 1 downgrade, 62 new, 9 in new slots, 56 reinstalls, 26 uninstalls), Size of downloads: 4,151,744 KiB
Fetch Restriction: 1 package (1 unsatisfied)
Conflict: 33 blocks (4 unsatisfied)

Fetch instructions for dev-java/oracle-jdk-bin-1.8.0.181:
 * Please download these files and move them to your distfiles directory:
 *
 *   jdk-8u181-linux-x64.tar.gz
 *
 *   http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
 *
 * If the above mentioned URL does not point to the correct version anymore,
 * please download the file from Oracle's Java download archive:
 *
 *   http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
 *

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtsql-5.11.1-r1:5/5.11.1::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                         
    >=dev-qt/qtcore-5.9.4:5 required by (kde-frameworks/bluez-qt-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                                 
    (and 180 more with the same problems)

  (dev-qt/qtcore-5.9.6-r1:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtserialport-5.9.6:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    >=dev-qt/qtcore-5.9.4:5 required by (kde-apps/sweeper-18.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                         
    (and 126 more with the same problems)

  (dev-qt/qtcore-5.7.1-r4:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    dev-qt/qtcore:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                 ^^^^^^^                                                                                                       
    (and 6 more with the same problems)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.1 required by (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^                                                                                                                                   
    >=dev-qt/qtdbus-5.9.4:5 required by (kde-frameworks/kactivities-stats-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                                           
    (and 68 more with the same problems)

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                   

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtgui-5.9.4:5 required by (kde-frameworks/kidletime-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                                   
    ~dev-qt/qtgui-5.11.1[gles2=] required by (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^                                                                                                                                                   
    (and 111 more with the same problems)

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    dev-qt/qtgui:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                ^^^^^^^                                                                                                       
    ~dev-qt/qtgui-5.7.1[-gles2,png,xcb] required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                                     

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.11.1 required by (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^                                                                                                                                   
    >=dev-qt/qtwidgets-5.9.4:5 required by (kde-apps/keditbookmarks-18.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                               
    (and 91 more with the same problems)

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    dev-qt/qtwidgets:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                    ^^^^^^^                                                                                                       

sys-process/procps:0

  (sys-process/procps-3.3.15-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-process/procps-3.3.12-r1:0/5::gentoo, installed) pulled in by
    sys-process/procps:0/5= required by (dev-db/mariadb-10.1.31-r1:0/18::gentoo, installed)
                      ^^^^^                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (dev-db/mariadb-10.1.31-r1:0/18::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/glibc-2.25-r10:2.2/2.2::gentoo, installed) pulled in by
    sys-libs/glibc required by (www-plugins/google-talkplugin-5.41.3.0:0/0::gentoo, installed)
    sys-libs/glibc:2.2 required by (virtual/libc-1:0/0::gentoo, installed)
    >=sys-libs/glibc-2.7 required by (sys-apps/iproute2-4.17.0:0/0::gentoo, ebuild scheduled for merge)
    sys-libs/glibc required by @selected
    sys-libs/glibc:* required by (dev-java/oracle-jdk-bin-1.8.0.181:1.8/1.8::gentoo, ebuild scheduled for merge)
    <sys-libs/glibc-2.26 required by (net-libs/libnsl-0:0/1::gentoo, installed)
    >=sys-libs/glibc-2.6.1 required by (x11-drivers/nvidia-drivers-396.54:0/396::gentoo, ebuild scheduled for merge)
    >=sys-libs/glibc-2.13 required by (sys-devel/gcc-7.3.0-r3:7.3.0/7.3.0::gentoo, ebuild scheduled for merge)

  (net-libs/rpcsvc-proto-1.3.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    net-libs/rpcsvc-proto required by (net-fs/nfs-utils-2.3.1-r3:0/0::gentoo, installed)

  (x11-proto/videoproto-2.3.3:0/0::gentoo, installed) pulled in by
    >=x11-proto/videoproto-2.3.1-r1[abi_x86_64(-)] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, installed)

  (x11-proto/inputproto-2.3.2:0/0::gentoo, installed) pulled in by
    >=x11-proto/inputproto-2.2-r1[abi_x86_64(-)] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, installed)

  (x11-proto/xextproto-7.3.0:0/0::gentoo, installed) pulled in by
    x11-proto/xextproto required by (media-sound/alsamixer-app-0.1:0/0::gentoo, installed)
    >=x11-proto/xextproto-7.2.1-r1[abi_x86_64(-)] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, installed)

  (x11-base/xorg-proto-2018.4:0/0::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-proto required by (x11-libs/libXt-1.1.5-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXpm-3.5.12-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-apps/bdftopcf-1.1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-plasma/plasma-desktop-5.12.5-r1:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXdmcp-1.1.2-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/cairo-1.14.12:0/0::gentoo, installed)
    x11-base/xorg-proto required by (kde-frameworks/kguiaddons-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXfixes-5.0.3-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-misc/slim-1.3.6-r5:0/0::gentoo, installed)
    x11-base/xorg-proto required by (net-im/pidgin-2.13.0:0/2::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-frameworks/kwindowsystem-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXres-1.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/pango-1.42.4:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXrender-0.9.10-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-apps/sessreg-1.1.1:0/0::gentoo, installed)
    x11-base/xorg-proto required by (x11-libs/gtk+-3.22.30:3/3::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libfontenc-1.1.3-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-plasma/libksysguard-5.12.5:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/xcb-util-cursor-0.1.3-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-apps/xinput-1.6.2:0/0::gentoo, installed)
    x11-base/xorg-proto required by (x11-apps/xprop-1.2.3:0/0::gentoo, installed)
    x11-base/xorg-proto required by (kde-frameworks/kjobwidgets-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (media-libs/freeglut-3.0.0:0/0::gentoo, installed)
    x11-base/xorg-proto required by (kde-frameworks/kdelibs4support-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/xcb-util-keysyms-0.4.0-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-drivers/xf86-input-mouse-1.9.3:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (media-libs/libsdl2-2.0.8-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (app-office/libreoffice-6.0.6.2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-frameworks/khtml-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXext-1.3.3-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (media-sound/pulseaudio-11.1-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXrandr-1.5.1-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXmu-1.1.2-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-frameworks/plasma-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXxf86vm-1.1.4-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXft-2.3.2-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-frameworks/kdesu-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libICE-1.0.9-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXcomposite-0.4.4-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (media-libs/libmpeg2-0.5.1-r2:0/0::gentoo, installed)
    x11-base/xorg-proto required by (media-video/vlc-3.0.4:0/5-9::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libvdpau-1.1.1:0/0::gentoo, installed)
    x11-base/xorg-proto required by (kde-plasma/kwin-5.12.5:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXdamage-1.1.4-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-plasma/khotkeys-5.12.5:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-drivers/xf86-input-libinput-0.27.1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-plasma/plasma-workspace-5.12.5:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXinerama-1.1.4:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/gtk+-2.24.32:2/2::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-apps/mkfontscale-1.1.3:0/0::gentoo, installed)
    x11-base/xorg-proto required by (x11-libs/startup-notification-0.12-r1:0/0::gentoo, installed)
    x11-base/xorg-proto required by (kde-frameworks/kinit-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libSM-1.2.2-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libxshmfence-1.3-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-apps/rgb-1.0.6:0/0::gentoo, installed)
    x11-base/xorg-proto required by (x11-libs/libX11-1.6.6:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXScrnSaver-1.2.3:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libxkbfile-1.0.9-r2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-plasma/kgamma-5.12.5:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, installed)
    x11-base/xorg-proto required by (x11-libs/xcb-util-image-0.4.0-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-apps/iceauth-1.0.8:0/0::gentoo, installed)
    x11-base/xorg-proto required by (kde-frameworks/knotifications-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (dev-java/swt-3.7.2-r2:3.7/3.7::gentoo, installed)
    x11-base/xorg-proto required by (kde-plasma/kscreenlocker-5.12.5:5/5::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (dev-lang/tk-8.6.8:0/8.6::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXau-1.0.8-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXi-1.7.9-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (media-libs/mesa-18.1.9:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXv-1.0.11-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-frameworks/kio-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (media-libs/libsdl-1.2.15-r9:0/0::gentoo, installed)
    x11-base/xorg-proto required by (x11-libs/libXtst-1.2.3-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXfont2-2.0.3-r1:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/wxGTK-3.0.4:3.0/3.0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (kde-frameworks/kcrash-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/fltk-1.3.3-r3:1/1::gentoo, installed)
    x11-base/xorg-proto required by (media-libs/gst-plugins-base-1.14.1:1.0/1.0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libxkbcommon-0.8.2:0/0::gentoo, ebuild scheduled for merge)
    x11-base/xorg-proto required by (x11-libs/libXaw-1.0.13-r1:0/0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- sys-libs/binutils-libs-2.29.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.25-r10::gentoo (masked by: package.mask)
- net-libs/libnsl-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (11 Sep 2018)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19943
Location: here

PostPosted: Sun Oct 14, 2018 6:11 am    Post subject: Reply with quote

All x11-proto/* are replaced by x11-base/xorg-proto, you can uninstall them, but before it you should update glibc separatly.
Others problems seems related to qt packages where you try to mix version 5.7 with 5.11 and that's not possible. You have unmasked all qt packages?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Sun Oct 14, 2018 12:14 pm    Post subject: Reply with quote

fedeliallalinea wrote:
All x11-proto/* are replaced by x11-base/xorg-proto, you can uninstall them, but before it you should update glibc separatly.
Others problems seems related to qt packages where you try to mix version 5.7 with 5.11 and that's not possible. You have unmasked all qt packages?


hmm i honestly don't really remember although i manually didn't do anything QT related as far as i remember.
How do i reset everything to default?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19943
Location: here

PostPosted: Sun Oct 14, 2018 12:38 pm    Post subject: Reply with quote

Troopo wrote:
hmm i honestly don't really remember although i manually didn't do anything QT related as far as i remember.
How do i reset everything to default?

Ok, but the first problem to resolve is update toolchain packages (gcc, binutils and glibc). What version of these package you installed?
Code:
!!! The following installed packages are masked:
- sys-libs/binutils-libs-2.29.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.25-r10::gentoo (masked by: package.mask)
- net-libs/libnsl-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (11 Sep 2018)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Sun Oct 14, 2018 3:48 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Troopo wrote:
hmm i honestly don't really remember although i manually didn't do anything QT related as far as i remember.
How do i reset everything to default?

Ok, but the first problem to resolve is update toolchain packages (gcc, binutils and glibc). What version of these package you installed?
Code:
!!! The following installed packages are masked:
- sys-libs/binutils-libs-2.29.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.25-r10::gentoo (masked by: package.mask)
- net-libs/libnsl-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (11 Sep 2018)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.


I've updated them and removed x11 as you suggested so now it's:
sys-devel/gcc-7.3.0-r3:7.3.0
sys-libs/glibc-2.25-r11:2.2
sys-devel/binutils-2.29.1-r1:2.29.1
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19943
Location: here

PostPosted: Sun Oct 14, 2018 3:53 pm    Post subject: Reply with quote

Troopo wrote:
sys-libs/glibc-2.25-r11:2.2
sys-devel/binutils-2.29.1-r1:2.29.1

These two are not updated because the latest stable are glibc-2.26-r7 and binutils-2.30-r4, furthermore your versions are also masked.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Sun Oct 14, 2018 5:17 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Troopo wrote:
sys-libs/glibc-2.25-r11:2.2
sys-devel/binutils-2.29.1-r1:2.29.1

These two are not updated because the latest stable are glibc-2.26-r7 and binutils-2.30-r4, furthermore your versions are also masked.


So whats a good idea to fix the masking problem? cuz i'm thinking delete the configs and start over manually unmasking and accepting packages
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19943
Location: here

PostPosted: Sun Oct 14, 2018 6:04 pm    Post subject: Reply with quote

Troopo wrote:
So whats a good idea to fix the masking problem? cuz i'm thinking delete the configs and start over manually unmasking and accepting packages

What return command
Code:
# emerge -uD sys-libs/glibc sys-devel/binutils

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Sun Oct 14, 2018 10:52 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Troopo wrote:
So whats a good idea to fix the masking problem? cuz i'm thinking delete the configs and start over manually unmasking and accepting packages

What return command
Code:
# emerge -uD sys-libs/glibc sys-devel/binutils


Code:

Calculating dependencies... done!
[ebuild     U  ] dev-qt/qtchooser-0_p20170803 [0_p20151008]
[ebuild     U  ] app-arch/bzip2-1.0.6-r10 [1.0.6-r8]
[ebuild     U  ] dev-lang/python-exec-2.4.6 [2.4.5] PYTHON_TARGETS="(-python3_7)"
[ebuild     U  ] sys-devel/llvm-common-6.0.1 [5.0.1]
[ebuild     U  ] dev-libs/lzo-2.10 [2.09]
[ebuild     U  ] dev-libs/libpthread-stubs-0.4-r1 [0.4]
[ebuild     U  ] dev-util/gperf-3.1 [3.0.4]
[ebuild     U  ] sys-devel/autoconf-wrapper-13-r1 [13]
[ebuild  N     ] dev-libs/ell-0.9  USE="-glib -pie" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] dev-util/re2c-1.0.3 [0.16]
[ebuild     U  ] sys-libs/timezone-data-2018e [2017c]
[ebuild     U  ] dev-libs/vala-common-0.36.13 [0.36.7]
[ebuild     U  ] sys-devel/patch-2.7.6-r2 [2.7.6-r1]
[ebuild     U  ] sys-libs/libseccomp-2.3.3 [2.3.2]
[ebuild     U  ] dev-libs/libbsd-0.9.1 [0.8.6]
[ebuild     U  ] sys-apps/coreutils-8.29-r1 [8.28-r1] USE="split-usr%*"
[ebuild     U  ] app-misc/pax-utils-1.2.3 [1.2.2-r2]
[ebuild     U  ] sys-apps/sandbox-2.13 [2.12]
[ebuild     U  ] sys-apps/sed-4.5 [4.2.2] USE="-forced-sandbox%"
[ebuild     U  ] sys-devel/make-4.2.1-r4 [4.2.1]
[ebuild     U  ] dev-libs/libgpg-error-1.29 [1.27-r1]
[ebuild     U  ] net-dns/libidn-1.35 [1.33-r2]
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.43.9 [1.43.6]
[ebuild     U  ] app-arch/tar-1.30 [1.29-r3]
[ebuild     U  ] sys-devel/bison-3.0.5-r1 [3.0.4-r1]
[ebuild     U  ] kde-frameworks/kf-env-5 [4]
[ebuild  N     ] dev-util/glib-utils-2.52.3
[ebuild     U  ] virtual/opengl-7.0-r2 [7.0-r1]
[ebuild     U  ] virtual/glu-9.0-r2 [9.0-r1]
[ebuild     U  ] app-admin/eselect-1.4.13 [1.4.11]
[ebuild     U  ] app-eselect/eselect-python-20171204 [20160516]
[ebuild  N     ] virtual/perl-Encode-2.800.100_rc-r4
[ebuild  N     ] virtual/perl-Carp-1.400.0-r1
[ebuild     U  ] sys-libs/ncurses-6.1-r2 [6.0-r1]
[ebuild     U  ] sys-apps/shadow-4.6 [4.5]
[ebuild  N     ] virtual/perl-XSLoader-0.220.0-r4
[ebuild  N     ] virtual/perl-Compress-Raw-Bzip2-2.69.0-r1
[ebuild  N     ] virtual/perl-IO-Compress-2.69.1_rc-r4
[ebuild  N     ] virtual/perl-IO-Socket-IP-0.370.0-r3
[ebuild     U  ] sys-libs/zlib-1.2.11-r2 [1.2.11-r1]
[ebuild     U  ] dev-libs/libgcrypt-1.8.3 [1.8.1] USE="-o-flag-munging%"
[ebuild     U  ] sys-libs/pam-1.3.0-r2 [1.2.1-r2] USE="-vim-syntax%"
[ebuild     U  ] dev-libs/fribidi-0.19.7 [0.19.6]
[ebuild     U  ] media-libs/libjpeg-turbo-1.5.3-r2 [1.5.1]
[ebuild     U  ] dev-libs/nettle-3.4 [3.3-r2]
[ebuild     U  ] dev-lang/perl-5.24.3-r1 [5.24.3]
[ebuild     U  ] media-libs/freetype-2.9.1-r3 [2.8]
[ebuild     U  ] dev-db/sqlite-3.24.0 [3.22.0]
[ebuild     U  ] media-libs/tiff-4.0.9-r4 [4.0.8]
[ebuild  NS    ] sys-devel/binutils-2.30-r4 [2.29.1-r1] USE="cxx nls -doc -multitarget -static-libs -test"
[ebuild     U  ] dev-lang/tcl-8.6.8 [8.6.6]
[ebuild     U  ] sys-apps/file-5.33-r4 [5.32] PYTHON_TARGETS="python3_6* -python3_5* (-python3_7)"
[ebuild  N     ] dev-perl/HTTP-Date-6.20.0-r1
[ebuild  N     ] dev-perl/LWP-MediaTypes-6.20.0-r1
[ebuild  N     ] dev-perl/Text-Iconv-1.700.0-r2
[ebuild  N     ] dev-perl/HTML-Tagset-3.200.0-r1
[ebuild  N     ] dev-perl/Socket6-0.280.0
[ebuild  N     ] dev-perl/TimeDate-2.300.0
[ebuild  N     ] virtual/perl-podlators-4.70.0-r1
[ebuild     U  ] dev-perl/URI-1.730.0 [1.710.0]
[ebuild     U  ] media-libs/harfbuzz-1.8.1 [1.7.2]
[ebuild  N     ] dev-perl/HTML-Parser-3.720.0  USE="-test"
[ebuild  N     ] dev-perl/Encode-Locale-1.50.0  USE="-test"
[ebuild  N     ] dev-perl/XML-XPath-1.420.0  USE="-examples -test"
[ebuild  N     ] dev-perl/File-Listing-6.40.0-r1
[ebuild  N     ] dev-perl/IO-HTML-1.1.0  USE="-test"
[ebuild  N     ] dev-perl/Sub-Name-0.210.0  USE="-suggested -test"
[ebuild     U  ] dev-perl/Text-Unidecode-1.300.0 [1.270.0]
[ebuild     U  ] dev-perl/libintl-perl-1.280.0 [1.240.0-r2]
[ebuild  N     ] dev-perl/MailTools-2.190.0  USE="-examples -test"
[ebuild     U  ] dev-perl/Net-SMTP-SSL-1.40.0 [1.30.0]
[ebuild  N     ] dev-perl/HTTP-Message-6.130.0  USE="-test"
[ebuild  N     ] dev-perl/Try-Tiny-0.300.0  USE="-minimal -test"
[ebuild  N     ] dev-perl/WWW-RobotRules-6.20.0-r1
[ebuild     U  ] dev-perl/Module-Build-0.422.400 [0.421.600]
[ebuild     U  ] sys-apps/help2man-1.47.6 [1.47.4]
[ebuild     U  ] dev-libs/libtasn1-4.13 [4.12-r1] USE="-test%"
[ebuild     U ~] net-dns/libidn2-2.0.5 [2.0.4]
[ebuild  N     ] dev-perl/Tie-IxHash-1.230.0  USE="-test"
[ebuild  N     ] dev-perl/HTTP-Cookies-6.40.0  USE="-test"
[ebuild  N     ] dev-perl/HTTP-Daemon-6.10.0-r2
[ebuild  N     ] dev-perl/HTTP-Negotiate-6.10.0-r1
[ebuild  N     ] dev-perl/IO-Socket-INET6-2.720.0-r1
[ebuild     U  ] net-libs/gnutls-3.5.19 [3.5.15]
[ebuild  N     ] dev-perl/Net-HTTP-6.170.0  USE="-minimal -test"
[ebuild     U  ] dev-libs/openssl-1.0.2p [1.0.2n]
[ebuild     U  ] dev-lang/python-3.6.5 [3.6.3-r1]
[ebuild     U  ] dev-lang/python-3.5.5 [3.5.4-r1]
[ebuild     U  ] net-misc/curl-7.61.1 [7.59.0]
[ebuild     U  ] dev-lang/python-3.4.8 [3.4.5-r1]
[ebuild     U  ] app-crypt/rhash-1.3.6-r1 [1.3.5] USE="ssl%* -libressl%"
[ebuild     U  ] app-misc/ca-certificates-20170717.3.36.1 [20161130.3.30.2]
[ebuild     U  ] dev-libs/libevdev-1.5.9-r1 [1.5.7] USE="-doc%"
[ebuild     U  ] app-crypt/p11-kit-0.23.12 [0.23.2]
[ebuild  N     ] dev-perl/libwww-perl-6.270.0  USE="ssl -test"
[ebuild  N     ] dev-perl/LWP-Protocol-https-6.70.0  USE="-test"
[ebuild  N     ] dev-perl/XML-Twig-3.520.0  USE="nls -test"
[ebuild  N     ] dev-perl/Net-DBus-1.1.0  USE="-test"
[ebuild     U  ] app-arch/lz4-1.8.2 [1.8.0]
[ebuild     U  ] app-text/build-docbook-catalog-1.21 [1.19.1]
[ebuild     U  ] media-fonts/liberation-fonts-2.00.1-r3 [2.00.1-r1]
[ebuild     U  ] x11-misc/shared-mime-info-1.10 [1.9]
[ebuild     U  ] dev-perl/File-MimeInfo-0.280.0 [0.270.0]
[ebuild     U  ] kde-frameworks/extra-cmake-modules-5.50.0 [5.43.0]
[ebuild     U  ] dev-libs/libxml2-2.9.8 [2.9.7] PYTHON_TARGETS="python3_6* -python3_5*"
[ebuild     U  ] dev-libs/libxslt-1.1.32 [1.1.30-r2]
[ebuild     U  ] app-crypt/libsecret-0.18.6-r1 [0.18.5] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] dev-libs/wayland-1.15.0 [1.13.0]
[ebuild     U  ] dev-libs/wayland-protocols-1.13 [1.11]
[ebuild     U  ] media-libs/fontconfig-2.13.0-r4 [2.12.6]
[ebuild     U  ] sys-apps/util-linux-2.32-r4 [2.30.2-r1]
[ebuild     U  ] sys-fs/e2fsprogs-1.43.9 [1.43.6]
[ebuild     U  ] net-print/cups-2.2.7 [2.1.4]
[ebuild     U  ] x11-libs/gdk-pixbuf-2.36.12 [2.36.11]
[ebuild  NS    ] sys-devel/llvm-6.0.1 [5.0.1] USE="libffi ncurses xml -debug -doc -gold -libedit -test -xar" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore"
[ebuild     U  ] app-text/mupdf-1.13.0 [1.11-r1] USE="lcms%*"
[ebuild     U  ] app-text/ghostscript-gpl-9.25 [9.21]
[ebuild     U  ] net-print/cups-filters-1.20.4 [1.17.9]
[ebuild  N     ] dev-perl/X11-Protocol-0.560.0-r1
[ebuild     U  ] x11-misc/xdg-utils-1.1.3-r1 [1.1.1-r1]
[ebuild     U  ] sys-process/procps-3.3.15-r1 [3.3.12-r1]
[ebuild     U  ] app-crypt/gnupg-2.2.8 [2.2.4-r2]
[ebuild     U  ] net-wireless/bluez-5.50 [5.48-r1] USE="btpclient%*"
[ebuild     U  ] x11-base/xcb-proto-1.13 [1.12-r2] PYTHON_TARGETS="python3_6%* -python3_4*"
[ebuild     U  ] x11-libs/libxcb-1.13.1 [1.12-r2]
[ebuild     U  ] x11-libs/xcb-util-renderutil-0.3.9-r2 [0.3.9-r1]
[ebuild     U  ] x11-libs/xcb-util-wm-0.4.1-r2 [0.4.1-r1]
[ebuild     U  ] x11-libs/xcb-util-0.4.0-r1 [0.4.0]
[ebuild     U ~] dev-qt/qtcore-5.11.1-r1 [5.7.1-r4]
[ebuild     U  ] kde-frameworks/breeze-icons-5.50.0 [5.43.0]
[ebuild     U ~] dev-qt/qtdbus-5.11.1 [5.7.1]
[ebuild     U ~] dev-qt/qtxml-5.11.1 [5.7.1]
[ebuild     U ~] dev-qt/qtnetwork-5.11.1 [5.7.1]
[ebuild     U  ] kde-frameworks/karchive-5.50.0 [5.43.0]
[ebuild     U ~] dev-qt/qttest-5.11.1 [5.7.1]
[ebuild     U ~] dev-qt/qtxmlpatterns-5.11.1 [5.7.1]
[ebuild     U  ] kde-frameworks/kdoctools-5.50.0 [5.43.0]
[ebuild     U ~] dev-qt/qtgui-5.11.1 [5.7.1-r1] USE="-vnc%"
[ebuild     U ~] dev-qt/qtx11extras-5.11.1 [5.7.1]
[ebuild     U ~] dev-qt/qtwidgets-5.11.1 [5.7.1] USE="gtk%*"
[ebuild     U ~] dev-qt/qtdeclarative-5.11.1 [5.7.1-r1]
[ebuild     U  ] kde-frameworks/ki18n-5.50.0 [5.43.0] PYTHON_SINGLE_TARGET="python3_6* -python3_5* (-python3_7)" PYTHON_TARGETS="python3_6* -python3_5* (-python3_7)"
[ebuild     U ~] dev-qt/qtsvg-5.11.1 [5.7.1]
[ebuild     U ~] dev-qt/linguist-tools-5.11.1 [5.7.1]
[ebuild     U  ] kde-frameworks/kcoreaddons-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kconfig-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kwidgetsaddons-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kdbusaddons-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kitemviews-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kcodecs-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kauth-5.50.0 [5.43.0]
[ebuild     U  ] kde-plasma/polkit-kde-agent-5.12.5 [5.11.5]
[ebuild     U  ] dev-lang/python-2.7.15 [2.7.14-r1] USE="bluetooth%*"
[ebuild   R   ~] dev-python/setuptools-38.5.1  PYTHON_TARGETS="python3_4* python3_6*"
[ebuild     U  ] dev-python/certifi-2018.4.16 [2017.4.17] PYTHON_TARGETS="python3_4* python3_6* (-python3_7)"
[ebuild     U  ] dev-util/meson-0.46.1 [0.44.1] PYTHON_TARGETS="python3_6* -python3_5*"
[ebuild     U  ] dev-libs/libinput-1.10.7 [1.9.4]
[ebuild  N     ] x11-base/xorg-proto-2018.4
[ebuild     U  ] dev-lang/tk-8.6.8 [8.6.6]
[ebuild     U  ] dev-python/lxml-4.1.1 [3.8.0] PYTHON_TARGETS="python3_6* (-pypy) -python3_5*"
[ebuild     U  ] sys-apps/systemd-238-r7 [236-r5] USE="pcre%* split-usr%*"
[ebuild     U  ] x11-libs/libX11-1.6.6 [1.6.5]
[ebuild     U  ] x11-libs/libICE-1.0.9-r2 [1.0.9-r1]
[ebuild     U  ] x11-libs/xcb-util-keysyms-0.4.0-r1 [0.4.0]
[ebuild     U  ] x11-libs/xcb-util-image-0.4.0-r1 [0.4.0]
[ebuild     U  ] x11-libs/libXau-1.0.8-r1 [1.0.8]
[ebuild     U  ] x11-libs/libxkbcommon-0.8.2 [0.7.1]
[ebuild     U  ] x11-libs/libXdmcp-1.1.2-r2 [1.1.2-r1]
[ebuild     U  ] x11-libs/libdrm-2.4.93 [2.4.88]
[ebuild     U  ] x11-libs/libxshmfence-1.3-r1 [1.2]
[ebuild     U  ] dev-python/pyxattr-0.6.0-r1 [0.5.5] PYTHON_TARGETS="python3_6%* -python3_5* (-python3_7)"
[ebuild     U  ] x11-libs/libfontenc-1.1.3-r1 [1.1.3]
[ebuild     U  ] dev-vcs/git-2.18.1 [2.16.1]
[ebuild     U  ] x11-libs/libXext-1.3.3-r1 [1.3.3]
[ebuild     U  ] x11-libs/libXrender-0.9.10-r1 [0.9.10]
[ebuild     U  ] x11-libs/libSM-1.2.2-r2 [1.2.2-r1]
[ebuild     U  ] x11-libs/libXfixes-5.0.3-r1 [5.0.3]
[ebuild     U  ] kde-frameworks/kguiaddons-5.50.0 [5.43.0]
[ebuild     U  ] x11-libs/xcb-util-cursor-0.1.3-r2 [0.1.3-r1]
[ebuild     U  ] kde-frameworks/kwindowsystem-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kconfigwidgets-5.50.0 [5.43.0]
[ebuild     U  ] x11-libs/libXi-1.7.9-r1 [1.7.9]
[ebuild     U  ] x11-libs/libXt-1.1.5-r1 [1.1.5]
[ebuild     U  ] x11-libs/libXrandr-1.5.1-r1 [1.5.1]
[ebuild     U  ] x11-libs/libXxf86vm-1.1.4-r1 [1.1.4]
[ebuild     U  ] x11-libs/libXcomposite-0.4.4-r2 [0.4.4-r1]
[ebuild     U  ] x11-libs/libXft-2.3.2-r1 [2.3.2]
[ebuild     U  ] x11-libs/libXdamage-1.1.4-r2 [1.1.4-r1]
[ebuild     U  ] kde-frameworks/kiconthemes-5.50.0 [5.43.0]
[ebuild     U  ] kde-frameworks/kcrash-5.50.0 [5.43.0]
[ebuild     U  ] x11-libs/pango-1.42.4 [1.40.14]
[ebuild     U  ] x11-libs/libXmu-1.1.2-r1 [1.1.2]
[ebuild     U  ] x11-libs/libXtst-1.2.3-r1 [1.2.3]
[ebuild     U  ] x11-libs/libXpm-3.5.12-r1 [3.5.12]
[ebuild     U  ] x11-libs/gtk+-2.24.32 [2.24.31-r1]
[ebuild     U  ] x11-libs/libXaw-1.0.13-r1 [1.0.13]
[ebuild     U  ] app-crypt/pinentry-1.1.0-r2 [1.0.0-r2] USE="-fltk%"
[ebuild     U  ] media-libs/mesa-18.1.9 [17.2.8]
[blocks b      ] <media-libs/mesa-18.1.1-r1 ("<media-libs/mesa-18.1.1-r1" is blocking dev-libs/wayland-1.15.0)
[uninstall     ] app-eselect/eselect-mesa-0.0.10-r1
[blocks b      ] app-eselect/eselect-mesa ("app-eselect/eselect-mesa" is blocking media-libs/mesa-18.1.9)
[ebuild     U  ] media-libs/libepoxy-1.5.1 [1.4.2]
[ebuild     U  ] x11-libs/gtk+-3.22.30 [3.22.19]
[blocks B      ] <sys-libs/slang-2.3.2_pre23 ("<sys-libs/slang-2.3.2_pre23" is blocking sys-libs/ncurses-6.1-r2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.11.1[dbus] required by (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^
    >=dev-qt/qtgui-5.9.4:5 required by (kde-frameworks/kitemviews-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^
    (and 13 more with the same problems)

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    >=dev-qt/qtgui-5.7.1:5/5.7=[dbus] required by (kde-plasma/plasma-integration-5.11.5:5/5::gentoo, installed)
                        ^^^^^^^
    >=dev-qt/qtgui-5.7.1:5/5.7= required by (kde-apps/akonadi-17.08.3:5/5::gentoo, installed)
                        ^^^^^^^
    ~dev-qt/qtgui-5.7.1[-gles2] required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^             ^^^^^
    dev-qt/qtgui:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                ^^^^^^^
    (and 14 more with the same problems)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.11.1 required by (dev-qt/qtgui-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^
    >=dev-qt/qtdbus-5.9.4:5 required by (kde-frameworks/kauth-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^
    (and 4 more with the same problems)

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^
    (and 1 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-5.9.4:5 required by (kde-frameworks/kdbusaddons-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtxmlpatterns-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^
    (and 27 more with the same problems)

  (dev-qt/qtcore-5.7.1-r4:5/5.7::gentoo, installed) pulled in by
    dev-qt/qtcore:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                 ^^^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    (and 26 more with the same problems)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdeclarative-5.9.4:5 required by (kde-frameworks/ki18n-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^
    ~dev-qt/qtdeclarative-5.11.1 required by (dev-qt/linguist-tools-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^

  (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^
    >=dev-qt/qtdeclarative-5.7.1:5/5.7= required by (kde-frameworks/kdeclarative-5.43.0:5/5.43::gentoo, installed)
                                ^^^^^^^
    >=dev-qt/qtdeclarative-5.7.1:5/5.7= required by (kde-frameworks/plasma-5.43.0:5/5.43::gentoo, installed)
                                ^^^^^^^
    >=dev-qt/qtdeclarative-5.7.1:5/5.7= required by (kde-frameworks/qqc2-desktop-style-5.43.0:5/5.43::gentoo, installed)
                                ^^^^^^^
    (and 8 more with the same problems)

dev-qt/qtsvg:5

  (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtsvg-5.9.4:5 required by (kde-frameworks/kiconthemes-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^

  (dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtsvg-5.7.1 required by (dev-qt/qtvirtualkeyboard-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^

dev-qt/qttest:5

  (dev-qt/qttest-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.11.1 required by (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^

  (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qttest-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.11.1 required by (dev-qt/qtdeclarative-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^^

  (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^                     ^^^^^

sys-process/procps:0

  (sys-process/procps-3.3.15-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-process/procps-3.3.12-r1:0/5::gentoo, installed) pulled in by
    sys-process/procps:0/5= required by (dev-db/mariadb-10.1.31-r1:0/18::gentoo, installed)
                      ^^^^^

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.11.1 required by (dev-qt/qtxmlpatterns-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^
    (and 1 more with the same problem)

  (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^
    (and 4 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.11.1 required by (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^
    >=dev-qt/qtwidgets-5.9.4:5 required by (kde-frameworks/kiconthemes-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^
    (and 7 more with the same problems)

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^
    dev-qt/qtwidgets:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                    ^^^^^^^
    (and 8 more with the same problems)

dev-qt/qtxml:5

  (dev-qt/qtxml-5.11.1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtxml-5.9.4:5 required by (kde-frameworks/kconfig-5.50.0:5/5.50::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^
    ~dev-qt/qtxml-5.11.1 required by (dev-qt/linguist-tools-5.11.1:5/5.11::gentoo, ebuild scheduled for merge)
    ^             ^^^^^^

  (dev-qt/qtxml-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtxml-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^
    (and 1 more with the same problem)

app-text/mupdf:0

  (app-text/mupdf-1.13.0:0/1.13.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/mupdf-1.11-r1:0/1.11::gentoo, installed) pulled in by
    <app-text/mupdf-1.12.0:0/1.11= required by (app-text/zathura-pdf-mupdf-0.3.1:0/0::gentoo, installed)
    ^               ^^^^^^^^^^^^^^
    >=app-text/mupdf-1.10a:0/1.11= required by (app-text/zathura-pdf-mupdf-0.3.1:0/0::gentoo, installed)
                          ^^^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (kde-frameworks/kdeclarative-5.43.0:5/5.43::gentoo, installed): ebuild is masked or unavailable
  (dev-db/mariadb-10.1.31-r1:0/18::gentoo, installed): ebuild is masked or unavailable
  (kde-frameworks/qqc2-desktop-style-5.43.0:5/5.43::gentoo, installed): ebuild is masked or unavailable
  (kde-plasma/plasma-integration-5.11.5:5/5::gentoo, installed): ebuild is masked or unavailable
  (kde-apps/akonadi-17.08.3:5/5::gentoo, installed): ebuild is masked or unavailable
  (kde-frameworks/plasma-5.43.0:5/5.43::gentoo, installed): ebuild is masked or unavailable
  (app-text/zathura-pdf-mupdf-0.3.1:0/0::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-libs/slang-2.3.0:0/0::gentoo, installed) pulled in by
    =sys-libs/slang-2* required by (dev-libs/newt-0.52.15:0/0::gentoo, installed)

  (sys-libs/ncurses-6.1-r2:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/ncurses-5.2-r2:0/6= required by (app-shells/bash-4.4_p12:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by (sys-apps/texinfo-6.3:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (x11-libs/vte-0.28.2-r208:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:0= required by (dev-lang/python-3.5.5:3.5/3.5m::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.9-r3:0/6=[abi_x86_64(-)] required by (sys-libs/gpm-1.20.7-r2:0/0::gentoo, installed)
    sys-libs/ncurses required by @selected
    >=sys-libs/ncurses-5.2:0/6= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed)
    sys-libs/ncurses:= required by (net-misc/telnet-bsd-1.2-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, installed)
    sys-libs/ncurses:0 required by (app-admin/eselect-1.4.13:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_64(-)]) required by (sys-devel/llvm-6.0.1:6/6::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.9-r3:0=[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_64(-)]) required by (sys-libs/readline-7.0_p3:0/7::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0/6= required by (sys-devel/gdb-7.12.1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/alsa-utils-1.1.2:0.9/0.9::gentoo, installed)
    >=sys-libs/ncurses-5.2:0/6= required by (net-ftp/ftp-0.17.23.0.2.1:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_64(-)]) required by (dev-db/unixODBC-2.3.5-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0/6=[abi_x86_64(-)] required by (sys-libs/readline-7.0_p3:0/7::gentoo, installed)
    sys-libs/ncurses:0/6=[unicode] required by (net-im/pidgin-2.12.0:0/2::gentoo, installed)
    sys-libs/ncurses:0/6= required by (dev-lang/ruby-2.3.6:2.3/2.3::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0/6=[abi_x86_64(-)] required by (sys-devel/llvm-5.0.1:5/5::gentoo, installed)
    sys-libs/ncurses:0/6= required by (net-misc/telnet-bsd-1.2-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (app-text/hunspell-1.6.1-r1:0/1.6::gentoo, installed)
    sys-libs/ncurses:0/6= required by (net-mail/mailutils-3.1.1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:0= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0=[unicode] required by (net-im/pidgin-2.12.0:0/2::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0/6= required by (sys-apps/texinfo-6.3:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (dev-lang/ruby-2.2.9:2.2/2.2::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0/6= required by (sys-block/parted-3.2-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (dev-db/mariadb-10.1.31-r1:0/18::gentoo, installed)
    sys-libs/ncurses:0/6= required by (dev-util/cmake-3.9.6:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r5:0/6= required by (sys-boot/grub-2.02:2/2.02::gentoo, installed)
    >=sys-libs/ncurses-5.2 required by (sys-kernel/gentoo-sources-4.9.76-r1:4.9.76-r1/4.9.76-r1::gentoo, installed)
    >=sys-libs/ncurses-5.2:0/6= required by (app-admin/testdisk-7.0-r3:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (sys-devel/gettext-0.19.8.1:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:= required by (sys-devel/bc-1.06.95-r2:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (app-crypt/pinentry-1.1.0-r2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0=[unicode] required by (sys-apps/gptfdisk-1.0.1:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (x11-libs/vte-0.28.2-r208:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by (app-shells/bash-4.4_p12:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:0/6= required by (sys-apps/less-529:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:0= required by (dev-lang/python-3.4.8:3.4/3.4m::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0/6= required by (sys-apps/gptfdisk-1.0.1:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (app-editors/nano-2.8.7:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3:0=[abi_x86_64(-)]) required by (sys-libs/gpm-1.20.7-r2:0/0::gentoo, installed)
    sys-libs/ncurses:0/6=[unicode] required by (media-video/vlc-2.2.8-r1:0/5-8::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0/6= required by (media-sound/lame-3.100-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r1:0/6=[unicode] required by (app-editors/nano-2.8.7:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by (app-editors/vim-8.0.1298:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:=[unicode?] (>=sys-libs/ncurses-5.7-r7:=[unicode]) required by (sys-process/procps-3.3.15-r1:0/6::gentoo, ebuild scheduled for merge)
    sys-libs/ncurses:0= required by (dev-util/cmake-3.9.6:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0= required by (sys-devel/gdb-7.12.1:0/0::gentoo, installed)
    sys-libs/ncurses:0= required by (app-text/hunspell-1.6.1-r1:0/1.6::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (media-sound/lame-3.100-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0/6= required by (sys-process/psmisc-22.21-r3:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.9-r3:0/6=[abi_x86_64(-)] required by (dev-db/unixODBC-2.3.5-r1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2:0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0/6=[unicode] required by (sys-process/procps-3.3.12-r1:0/5::gentoo, installed)
    >=sys-libs/ncurses-5.2:= required by (net-ftp/ftp-0.17.23.0.2.1:0/0::gentoo, installed)
    sys-libs/ncurses:= required by (net-mail/mailutils-3.1.1:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0=[unicode?] (>=sys-libs/ncurses-5.2-r2:0=[unicode]) required by (sys-apps/util-linux-2.32-r4:0/0::gentoo, ebuild scheduled for merge)
    >=sys-libs/ncurses-5.7-r7:0/6= required by (media-sound/alsa-utils-1.1.2:0.9/0.9::gentoo, installed)
    >=sys-libs/ncurses-5.2-r2:0/6= required by (app-editors/vim-8.0.1298:0/0::gentoo, installed)
    >=sys-libs/ncurses-5.7-r7:0= required by (sys-block/parted-3.2-r1:0/0::gentoo, installed)
    sys-libs/ncurses:0/6= required by (sys-libs/slang-2.3.0:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


!!! The following installed packages are masked:
- dev-perl/DBD-mysql-4.41.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Kent Fredric <kentnl@gentoo.org> (27 May 2018)
# Subject to Man-in-the-middle security bypass vulnerability.
# Retained in tree only for users who need older versions
# for compatibility reasons.
# Bug: #623942

- net-libs/libnsl-0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas K. Hüttel <dilfridge@gentoo.org> (11 Sep 2018)
# Mask transition ebuilds that were needed only for <glibc-2.26
# We will keep them in the tree as long as we have masked
# <glibc-2.26.

- sys-devel/binutils-2.29.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Michał Górny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017 and later updates)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3505
Location: Germany

PostPosted: Mon Oct 15, 2018 2:10 am    Post subject: Reply with quote

portage wrote:
You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
Please try it with this tip from portage,
try it with --backtrack=100
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Mon Oct 15, 2018 6:32 am    Post subject: Reply with quote

Josef.95 wrote:
portage wrote:
You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
Please try it with this tip from portage,
try it with --backtrack=100



Code:

Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwebchannel-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtserialport-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtimageformats-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    dev-qt/qtcore:5/5.7= required by (app-mobilephone/heimdall-1.4.2:0/0::gentoo, installed)
                 ^^^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
    ^              ^^^^^


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

dev-qt/qtquickcontrols2:5
dev-qt/qtvirtualkeyboard:5
dev-qt/qtscript:5
dev-qt/qtpaths:5
dev-qt/qtopengl:5
dev-qt/linguist-tools:5
dev-qt/qtgraphicaleffects:5
dev-qt/qtx11extras:5
dev-util/cmake:0
dev-qt/designer:5
dev-qt/qtsvg:5
dev-qt/qtxml:5
dev-qt/qtsql:5
dev-qt/qtwidgets:5
dev-qt/qtprintsupport:5
dev-qt/qtwayland:5
dev-qt/qtwebchannel:5
dev-qt/qtconcurrent:5
dev-qt/qtquickcontrols:5
dev-qt/qdbus:5
dev-qt/qtgui:5

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by net-print/cups-filters-1.20.4::gentoo
# required by net-print/cups-2.2.7::gentoo
# required by net-wireless/bluez-5.50::gentoo[cups]
# required by dev-lang/python-2.7.15::gentoo[bluetooth]
# required by dev-libs/libxml2-2.9.8::gentoo[python,python_targets_python2_7]
# required by app-text/build-docbook-catalog-1.21::gentoo
# required by app-text/docbook-xml-dtd-4.1.2-r6::gentoo
# required by dev-libs/glib-2.52.3::gentoo
# required by x11-misc/shared-mime-info-1.10::gentoo
# required by gnome-base/dconf-0.26.1::gentoo
=app-text/poppler-0.67.0 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "dev-qt/qtcore:5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtcore-5.11.1-r1::gentoo (masked by: backtracking: slot conflict)
- dev-qt/qtcore-5.9.6-r1::gentoo (masked by: backtracking: slot conflict)
- dev-qt/qtcore-5.9.6::gentoo (masked by: backtracking: slot conflict)

(dependency required by "app-text/poppler-0.67.0::gentoo[qt5]" [ebuild])
(dependency required by "net-print/cups-filters-1.20.4::gentoo" [ebuild])
(dependency required by "net-print/cups-2.2.7::gentoo" [ebuild])
(dependency required by "net-wireless/bluez-5.50::gentoo[cups]" [ebuild])
(dependency required by "dev-lang/python-2.7.15::gentoo[bluetooth]" [ebuild])
(dependency required by "dev-libs/libxml2-2.9.8::gentoo[python,python_targets_python2_7]" [ebuild])
(dependency required by "app-text/build-docbook-catalog-1.21::gentoo" [ebuild])
(dependency required by "app-text/docbook-xml-dtd-4.1.2-r6::gentoo" [installed])
(dependency required by "dev-libs/glib-2.52.3::gentoo" [installed])
(dependency required by "x11-misc/shared-mime-info-1.10::gentoo" [ebuild])
(dependency required by "gnome-base/dconf-0.26.1::gentoo" [installed])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19943
Location: here

PostPosted: Mon Oct 15, 2018 6:35 am    Post subject: Reply with quote

You are in a stable or unstable system? Post your emerge --info
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3500
Location: Dallas area

PostPosted: Mon Oct 15, 2018 10:20 am    Post subject: Reply with quote

You need the emerge --info, what's in make.conf, what's in the /etc/portage/package* stuff, and eselect python list.
He's got something screwy going on with his configuration and telling him random things won't help.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3505
Location: Germany

PostPosted: Mon Oct 15, 2018 1:43 pm    Post subject: Reply with quote

Yes, and for a better overview post please the output from
Code:
emerge --pretend -vuDN @world --autounmask=n --ignore-built-slot-operator-deps=y --backtrack=1 --verbose-conflicts $(qlist -IC dev-qt)
(qlist is from app-portage/portage-utils package)
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Tue Oct 16, 2018 8:22 pm    Post subject: Reply with quote

Ok here goes:

emerge --info
https://paste.pound-python.org/show/2TU7Z1xYKGt3BPLlhP4k/

make.conf
https://paste.pound-python.org/show/klGmQQhNZZBoXsdkZZPk/

package.accept_keywords
https://paste.pound-python.org/show/bry9KKwGdME0gjZX0HrC/

package.use
https://paste.pound-python.org/show/18159xu4OqRwpyp3yB4q/

package.mask
https://paste.pound-python.org/show/FzAfc1Hv4mMS4c13pqJl/

package.unmask
https://paste.pound-python.org/show/DqwLyQRXoeJaOCdoQ3vS/

eselect python list
https://paste.pound-python.org/show/UOgvwj6nlKImZoiXgPoJ/

emerge --pretend -vuDN @world --autounmask=n --ignore-built-slot-operator-deps=y --backtrack=1 --verbose-conflicts $(qlist -IC dev-qt)
https://paste.pound-python.org/show/wmMBYWbOQQrd430r2uKV/
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3500
Location: Dallas area

PostPosted: Tue Oct 16, 2018 8:41 pm    Post subject: Reply with quote

If you indeed have 4 pythons as eselect shows, then add
Code:
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"

to make.conf

and change python 3.6 to be primary with "eselect python set 3" to match the python single target set above (try and keep them in sync).

If you don't have all 4 pythons, then clean out the list with "eselect python cleanup", and set the PYTHON_TARGETS appropriately.

Comment out the =sys-libs/glibc-2.25-r11 and =sys-libs/binutils-libs-2.29.1-r1 lines in package.unmask.

Comment out =sys-libs/glibc-2.27-r6 and =sys-libs/binutils* lines in package.accept_keywords

Then run "emerge -pv glibc binutils binutils-libs" and let us know what it says.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3505
Location: Germany

PostPosted: Tue Oct 16, 2018 9:10 pm    Post subject: Reply with quote

Troopo,
the last emerge command and the output was not really complete in pastebin :-/

Now, Qt 5.11.1 and kde-plasma 5.13.5 is stable marked, you should now first run a fresh `emerge --sync`
And, please remove the "=sys-libs/glibc-2.28 **" Entry from package.accept_keywords
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Wed Oct 17, 2018 12:47 am    Post subject: Reply with quote

Anon-E-moose wrote:
If you indeed have 4 pythons as eselect shows, then add
Code:
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"

to make.conf

and change python 3.6 to be primary with "eselect python set 3" to match the python single target set above (try and keep them in sync).

If you don't have all 4 pythons, then clean out the list with "eselect python cleanup", and set the PYTHON_TARGETS appropriately.

Comment out the =sys-libs/glibc-2.25-r11 and =sys-libs/binutils-libs-2.29.1-r1 lines in package.unmask.

Comment out =sys-libs/glibc-2.27-r6 and =sys-libs/binutils* lines in package.accept_keywords

Then run "emerge -pv glibc binutils binutils-libs" and let us know what it says.


Thanks, this is the output
https://paste.pound-python.org/show/310mGjrxUhIhElvuwcxN/


Josef.95 wrote:
Troopo,
the last emerge command and the output was not really complete in pastebin :-/

Now, Qt 5.11.1 and kde-plasma 5.13.5 is stable marked, you should now first run a fresh `emerge --sync`
And, please remove the "=sys-libs/glibc-2.28 **" Entry from package.accept_keywords



I think now the python changes made a different result since this is what i get for it at the moment:
Code:

emerge --pretend -vuDN @world --autounmask=n --ignore-built-slot-operator-deps=y --backtrack=1 --verbose-conflicts $(qlist -IC dev-qt)

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "app-text/asciidoc" has unmet requirements.
- app-text/asciidoc-8.6.10::gentoo USE="-examples -graphviz -highlight -test" ABI_X86="(64)" PYTHON_SINGLE_TARGET="(-pypy) -python2_7" PYTHON_TARGETS="python2_7 (-pypy)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7 ) python_single_target_pypy? ( python_targets_pypy ) python_single_target_python2_7? ( python_targets_python2_7 )

(dependency required by "sys-kernel/genkernel-next-68::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19943
Location: here

PostPosted: Wed Oct 17, 2018 5:48 am    Post subject: Reply with quote

app-text/asciidoc not work with python_single_target set to python3_6 but only with python2.7, then you should active this with /etc/portage/package.use
Code:
# echo "app-text/asciidoc python_single_target_python2_7" >> /etc/portage/package.use

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3500
Location: Dallas area

PostPosted: Wed Oct 17, 2018 9:51 am    Post subject: Reply with quote

Code:
[ebuild  r  U ~] sys-libs/binutils-libs-2.31.1-r1:0/2.31.1-r1::gentoo


You have binutils-libs still set in package.accept_keywords, comment it out, and do what Josef.95 said comment out "=sys-libs/glibc-2.28 **"

And do what fedeliallalinea said re. package.use and asciidoc


But it looks like you're getting there.


Edit to add: If you haven't done it, I would add this
Code:
EMERGE_DEFAULT_OPTS="--autounmask=n"

to your make.conf file, that way you don't have to keep adding it to the command line.

ETA2: as a side note, I would remove ALL comment lines from the /etc/portage/package.* files (makes it easier to find things when looking)
I do comment things out when testing, but after the test is concluded, I remove the comment lines.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Troopo
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2015
Posts: 133

PostPosted: Wed Oct 17, 2018 10:14 pm    Post subject: Reply with quote

Thank you!

Looking better i think.

This is what i get for:
Code:

emerge --pretend -vuDN @world --autounmask=n --ignore-built-slot-operator-deps=y --backtrack=1 --verbose-conflicts $(qlist -IC dev-qt)



Result:

Code:

Total: 610 packages (479 upgrades, 1 downgrade, 64 new, 9 in new slots, 57 reinstalls, 3 uninstalls), Size of downloads: 3,949,698 KiB
Fetch Restriction: 1 package
Conflict: 7 blocks

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

virtual/libffi:0

  (virtual/libffi-3.0.13-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    =virtual/libffi-3.0.13-r1[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/glib-2.52.3:2/2::gentoo, installed)
                                                         
    >=virtual/libffi-3.0.13-r1:=[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/glib-2.52.3:2/2::gentoo, installed)
                                                             

dev-libs/libdbusmenu-qt:0

  (dev-libs/libdbusmenu-qt-0.9.3_pre20160218-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libdbusmenu-qt[qt4,abi_x86_64(-)] required by (dev-libs/sni-qt-0.2.6-r1:0/0::gentoo, installed)
                            ^^^               

virtual/libiconv:0

  (virtual/libiconv-0-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=virtual/libiconv-0-r1[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/glib-2.52.3:2/2::gentoo, installed)
                                                       
    =virtual/libiconv-0-r2[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/glib-2.52.3:2/2::gentoo, installed)
                                                       

sys-apps/tcp-wrappers:0

  (sys-apps/tcp-wrappers-7.6.22-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    sys-apps/tcp-wrappers[abi_x86_32(-),abi_x86_64(-)] required by (media-sound/pulseaudio-11.1-r1:0/0::gentoo, ebuild scheduled for merge)
                                                     

dev-libs/libffi:0

  (dev-libs/libffi-3.2.1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libffi-3.0.13-r1[abi_x86_32(-),abi_x86_64(-)] required by (virtual/libffi-3.0.13-r1:0/0::gentoo, installed)
                                                           

virtual/libintl:0

  (virtual/libintl-0-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=virtual/libintl-0-r1[abi_x86_32(-),abi_x86_64(-)] required by (sys-libs/pam-1.3.0-r2:0/0::gentoo, ebuild scheduled for merge)
                                                       
    =virtual/libintl-0-r2[abi_x86_32(-),abi_x86_64(-)] required by (sys-libs/pam-1.3.0-r2:0/0::gentoo, ebuild scheduled for merge)
                                                     
    >=virtual/libintl-0-r2[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/glib-2.52.3:2/2::gentoo, installed)
                                                       
    >=virtual/libintl-0-r1[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/libgpg-error-1.29:0/0::gentoo, ebuild scheduled for merge)
                                                       
    =virtual/libintl-0-r2[abi_x86_32(-),abi_x86_64(-)] required by (sys-apps/util-linux-2.32-r4:0/0::gentoo, ebuild scheduled for merge)
                                                     
    virtual/libintl[abi_x86_32(-),abi_x86_64(-)] required by (sys-apps/util-linux-2.32-r4:0/0::gentoo, ebuild scheduled for merge)
                                               
    =virtual/libintl-0-r2[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/glib-2.52.3:2/2::gentoo, installed)
                                                     
    =virtual/libintl-0-r2[abi_x86_32(-),abi_x86_64(-)] required by (dev-libs/libgpg-error-1.29:0/0::gentoo, ebuild scheduled for merge)
                                                     



How do i fix the remaining messages? also before i needed to upgrade portage now i don't have that msg anymore

I did all the changes suggested so just in case here are new versions of package.use and package.accept
https://paste.pound-python.org/show/RGxNOzFKUPZlySrYtbd7/

https://paste.pound-python.org/show/UGpTYq2oOvd1jwbhCN6N/
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3500
Location: Dallas area

PostPosted: Wed Oct 17, 2018 10:27 pm    Post subject: Reply with quote

remove

Code:
=sys-apps/portage-2.3.50-r4 ~amd64
=sys-apps/portage-2.3.51 ~amd64
=sys-libs/glibc-9999 **

from package.accept

all the dev-qt/qt*5.11* files are now "amd64" so don't need to be there, as of this morning when I synced up.

Actually rename package.accept_keywords to package.accept.old and see what really needs to be there.
You will get complaints if something is really needed.

Then do "emerge -pvuDU @world" and see what shows


Edit to add: do you have a package.keywords and if so, paste it so we can see what's in it.


ETA2: for the conflicts add
Code:
virtual/libffi abi_x86_32
virtual/libiconv abi_x86_32
sys-apps/tcp-wrappers abi_x86_32
dev-libs/libffi abi_x86_32
virtual/libintl abi_x86_32


to package.use

For this one,
Code:
dev-libs/libdbusmenu-qt:0

  (dev-libs/libdbusmenu-qt-0.9.3_pre20160218-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    dev-libs/libdbusmenu-qt[qt4,abi_x86_64(-)] required by (dev-libs/sni-qt-0.2.6-r1:0/0::gentoo, installed)


"emerge --depclean -a sni-qt" as it isn't even in portage any more and it's wanting a qt4 flag

ETA3: for the package.use file you have multiple lines and some conflict.

Code:
=sys-apps/util-linux-2.28.2 abi_x86_32
=sys-apps/util-linux-2.28.2 abi_x86_32
>=sys-apps/util-linux-2.30.2 abi_x86_32

>=dev-python/certifi-2018.4.16 python_targets_python3_4
>=dev-python/certifi-2018.4.16 python_targets_python3_5

>=dev-python/setuptools-38.5.1 python_targets_python3_4
>=dev-python/setuptools-38.5.1 python_targets_python3_5

>=sys-apps/dbus-1.10.18 -user-session
>=sys-apps/dbus-1.10.18 abi_x86_32
>=sys-apps/dbus-1.10.18 user-session
>=sys-apps/dbus-1.10.18 user-session


You don't need = or >= unless you want a specific target (something like sys-apps/util-linux works just fine) so change the above to
Code:
sys-apps/util-linux abi_x86_32
dev-python/certifi python_targets_python3_4 python_targets_python3_5
dev-python/setuptools python_targets_python3_4 python_targets_python3_5
sys-apps/dbus abi_x86_32


for dbus you have both user-session and -user-session (the default is -user-session) so no need to add it, if you want it then add it after the abi setting no need for a separate line.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 7.3.0, eudev, openrc, openbox, palemoon


Last edited by Anon-E-moose on Thu Oct 18, 2018 10:38 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum