Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udevd[1827]: specified group 'render' unknown
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
n05ph3r42
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jul 2016
Posts: 87

PostPosted: Sun Oct 14, 2018 6:17 pm    Post subject: udevd[1827]: specified group 'render' unknown Reply with quote

Also got next messages:
Code:
udevd:  ignoring invalid mode '@GROUP_RENDER_MODE@
udevd: ignoring invalid mode '@DEV_KVM_MODE@'

not sure is it critical, but dmesg beauty ruined
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5290

PostPosted: Sun Oct 14, 2018 7:27 pm    Post subject: Reply with quote

eudev installs a broken file. It's a bit more than cosmetic, it causes things like vaapi to not work.

Until the next update comes out you can fix it manually; open /lib/udev/rules.d/50-udev-default.rules and change line 39-40 to this:
Code:
SUBSYSTEM=="drm", KERNEL=="renderD*", GROUP="video", MODE="0666"
SUBSYSTEM=="kfd", GROUP="video", MODE="0666"

And line 82 to this:
Code:
KERNEL=="kvm", GROUP="kvm", MODE="0666", OPTIONS+="static_node=kvm"


(IMO these should be 0660, world-writable is questionably secure, but that's what upstream did...)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum