Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Plasma 5.13.5: No effect when pressing Volume keys
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
linuxfluesterer
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2016
Posts: 130
Location: Germany

PostPosted: Thu Oct 11, 2018 1:24 pm    Post subject: [Solved] Plasma 5.13.5: No effect when pressing Volume keys Reply with quote

Hallo friends.
I have a running Gentoo with Plasma 5.13.5. This is my third installation now. My pc-box is connected with a monitor via displayport.
And there is only one device in the pavucontrol devices list which is possible to select to hear sound (Digital-Stereo HDMI).
While on the two Plasma desktops before I was able to watch tv or watch movies (mpv, vlc) and control the volume with my keyboards vol-up, vol-down and vol-mute,
on my third system I can only see the symbol for my intended volume action on the display (monitor) but the stroking of the keys don't seem to be leading to that the system
(kmix or pulse, I'm not sure about what really counts) will increase, decrease or mute the sound.

As I said, I have Plasma 5.13.5 with Pulseaudio. Within kaffeine, vlc and mpv I can change the volume level or even mute it.
Like on my Gentoo systems before, I would like to control volume via my keyboard again.
For this I even tried to reconfigure the shortkey settings, but with the effect that now the keys were no more displayed on my monitor (and of course, sound was not effected like before).
So, I reset the keys then again, so that I got the keys (vol-up, vol-down, mute) displayed again.


Do you have a suggestion, a hint, how could I make control the volume with my keys again?

Thank you in advance.

-Linuxfluesterer


Last edited by linuxfluesterer on Thu Oct 11, 2018 5:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
linuxfluesterer
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2016
Posts: 130
Location: Germany

PostPosted: Thu Oct 11, 2018 5:57 pm    Post subject: Reply with quote

**** Update****

Due to this thread: https://forums.gentoo.org/viewtopic-t-1064826-start-0.html, I conclused that I had to reemerge kmix with USE flag pulseaudio, because sound in Plasma is redirected / delegated to Pulseaudio .
Now after reemerging, I can control sound via keys on my keyboard.

So, thank you for joining.

-Linuxfluesterer
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6620
Location: Austria

PostPosted: Thu Oct 11, 2018 6:03 pm    Post subject: Reply with quote

Clearly, if you use pulseaudio, then enable the flag globally. Otherwise you will get errors like that.

Plasma/kmix do not require pulseaudio for sound to work.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum