Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot emerge @world without unmasking OpenSSL-1.1.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
ZappingLinux
Tux's lil' helper
Tux's lil' helper


Joined: 13 Oct 2017
Posts: 117
Location: Delft, Netherlands

PostPosted: Sat Oct 06, 2018 10:27 am    Post subject: Cannot emerge @world without unmasking OpenSSL-1.1.0 Reply with quote

How do I work around this problem? Do I have to set a use variable? I am running a minimal install of gentoo and was able to emerge gnome because of downgrading to openssl 1.0.2 but now when I want to emerge @world to update the system it is asking again to unmask it.

Any help would be appreciated!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41734
Location: 56N 3W

PostPosted: Sat Oct 06, 2018 10:52 am    Post subject: Reply with quote

ZappingLinux,

It sounds like you have been using --autounmask and accpting portages advice without understanding the underlying problem.
--autounmask is useful to point you in the right direction but taken literally, its a badthing.

It sounds like you have a mix of testing and stable installed.

Add the -t option to your emerge command and post both your command and all the output.
The indents show the dependencies.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41734
Location: 56N 3W

PostPosted: Sat Oct 06, 2018 10:57 am    Post subject: Reply with quote

Moved from Other Things Gentoo to Duplicate Threads.

In favour of OpenSSL 1.1.0i Conflict
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum