Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nodejs install issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
CtrlAltElite
n00b
n00b


Joined: 19 Sep 2018
Posts: 4

PostPosted: Wed Sep 19, 2018 3:52 am    Post subject: nodejs install issues Reply with quote

Hello,

I am trying to install nodejs on my Raspberry Pi 3 B+

I am using this gentoo repo for the OS: https://github.com/sakaki-/gentoo-on-rpi3-64bit

I am getting openssl openssh and bindist issues. So I am here looking for help to see if anyone has successfully done this and can share the fix.

Here is what I have tried so far:


Code:
pi64 ~ # emaint sync --auto
pi64 ~ # echo -e '\n# disable bindist globally\nUSE="${USE} -bindist"' >> /etc/portage/make.conf
pi64 ~ # nice emerge -av --changed-use --with-bdeps=y dev-libs/openssl net-misc/openssh dev-qt/qtnetwork net-libs/nodejs



I have also went and edited a bunch of the portage files tryign to get it to work.

I am in the process of reinstalling my Pi to start from scratch again.
Back to top
View user's profile Send private message
Sakaki
Apprentice
Apprentice


Joined: 21 May 2014
Posts: 219

PostPosted: Wed Sep 19, 2018 5:16 pm    Post subject: Reply with quote

CtrlAltElite,

please post the output you get when trying the emerge step from the above, as well as the output of "emerge --info" on your RPi3, so that other members of the forum have the info they need to help you. Thanks!
_________________
Regards,

sakaki
Back to top
View user's profile Send private message
CtrlAltElite
n00b
n00b


Joined: 19 Sep 2018
Posts: 4

PostPosted: Thu Sep 20, 2018 10:40 pm    Post subject: Reply with quote

Code:
 emerge --info
Portage 2.3.40 (python 3.5.5-final-0, default/linux/arm64/17.0/desktop, gcc-7.3.0, glibc-2.27-r6, 4.14.44-v8-4fca48b7612d-bis+ aarch64)
=================================================================
System uname: Linux-4.14.44-v8-4fca48b7612d-bis+-aarch64-with-gentoo-2.6
KiB Mem:      992080 total,    286072 free
KiB Swap:     524284 total,    524284 free
Timestamp of repository gentoo: Thu, 06 Sep 2018 00:45:01 +0000
Head commit of repository gentoo: 39bd3768fcf94500593582cc02ec1b4e12f66a27
Head commit of repository sakaki-tools: 4d6529b5a3bdee9cf1652a1834fee3b3680ba834

Head commit of repository rpi3: 0e6efff5d86ec5156af45c638f3c8928e4054d26

sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p2) 2.30.0
distcc 3.2rc1 aarch64-unknown-linux-gnu [disabled]
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.14-r2::gentoo, 3.5.5-r1::gentoo
dev-util/cmake:           3.11.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.36::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r2::gentoo, 2.31.1::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo, 8.2.0-r2::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://isshoni.org/gentoo-portage-pi64
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: no

sakaki-tools
    location: /usr/local/portage/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

rpi3
    location: /usr/local/portage/rpi3
    sync-type: git
    sync-uri: https://github.com/sakaki-/rpi3-overlay.git
    masters: gentoo
    priority: 100

ACCEPT_KEYWORDS="arm64 ~arm64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="aarch64-unknown-linux-gnu"
CFLAGS="-march=armv8-a+crc -mtune=cortex-a53 -O2 -pipe"
CHOST="aarch64-unknown-linux-gnu"
CONFIG_PROTECT="/boot/cmdline.txt /boot/config.txt /etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=armv8-a+crc -mtune=cortex-a53 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles getbinpkg merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://trumpetti.atm.tut.fi/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_BINHOST="https://isshoni.org/pi64pie"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa arm64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus dri dts dvdr egl emboss encode exif fam ffmpeg flac fortran gdbm gif glamor gles1 gles2 gpm gtk iconv ipv6 jpeg lcms ldap libnotify libtirpc lock mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt4 qt5 readline seccomp spell ssl startup-notification svg tcpd thunar tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_ARM="edsp neon thumb thumb2 v4 v5 v6 v7 v8 vfp vfp-d32 vfpv3 vfpv4" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_5 python3_6" QEMU_SOFTMMU_TARGETS="aarch64 arm i386 x86_64" QEMU_USER_TARGETS="aarch64" RUBY_TARGETS="ruby21 ruby23" USERLAND="GNU" VIDEO_CARDS="fbdev vc4" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
CtrlAltElite
n00b
n00b


Joined: 19 Sep 2018
Posts: 4

PostPosted: Thu Sep 20, 2018 10:43 pm    Post subject: Reply with quote

Code:
demouser@pi64 ~ $ nice emerge -av --changed-use --with-bdeps=y dev-libs/openssl net-misc/openssh dev-qt/qtnetwork net-libs/nodejs
This action requires superuser access...
Would you like to add --pretend to options? [Yes/No] yes

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   #] dev-libs/openssl-1.1.1_pre9:0/1.1::gentoo  USE="asm zlib -bindist* -rfc3779 -sctp -sslv3 -static-libs {-test} -tls-heartbeat -vanilla" 0 KiB
[ebuild  N     ] net-libs/nghttp2-1.33.0:0/1.14::gentoo  USE="cxx threads xml -debug -hpack-tools -jemalloc -libressl -static-libs {-test} -utils" 1,519 KiB
[ebuild  N     ] net-libs/nodejs-8.11.4::gentoo  USE="npm snapshot ssl -debug -doc -icu -inspector -systemtap {-test}" PYTHON_TARGETS="python2_7" 17,894 KiB

Total: 3 packages (2 new, 1 reinstall), Size of downloads: 19,413 KiB

!!! The following binary packages have been ignored due to changed dependencies:

     sys-libs/zlib-1.2.11-r2::gentoo
     dev-util/pkgconfig-0.29.2::gentoo
     dev-lang/python-2.7.15::gentoo
     net-misc/openssh-7.7_p1-r9::gentoo
     dev-libs/libuv-1.23.0::gentoo
     dev-libs/libxml2-2.9.8::gentoo

NOTE: The --binpkg-changed-deps=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-changed-deps=y will silence this warning.

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-libs/nodejs-8.11.4::gentoo[ssl]
# required by net-libs/nodejs (argument)
>=dev-libs/openssl-1.1.1_pre9 -bindist

 * IMPORTANT: 1 news items need reading for repository 'rpi3'.
 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
Back to top
View user's profile Send private message
Sakaki
Apprentice
Apprentice


Joined: 21 May 2014
Posts: 219

PostPosted: Thu Sep 20, 2018 10:48 pm    Post subject: Reply with quote

Are you sure you have set -bindist globally (it does not appear so from the above, and from your emerge --info output)? Please post the contents of /etc/portage/make.conf. Thanks!
_________________
Regards,

sakaki
Back to top
View user's profile Send private message
CtrlAltElite
n00b
n00b


Joined: 19 Sep 2018
Posts: 4

PostPosted: Fri Sep 21, 2018 5:25 am    Post subject: Reply with quote

Sorry your right, i have reinstalled and messed with this so much im going crazy lol.

I follow the directions above again.

However when I get to the last command my Pi freezes everytime and cant complete the merge of the packages. Same thing happens when I try to run the updates in your enews thing it just freezes and I have to reboot it.

This is becoming to much work to just run a nodejs project.
Back to top
View user's profile Send private message
Sakaki
Apprentice
Apprentice


Joined: 21 May 2014
Posts: 219

PostPosted: Fri Sep 21, 2018 12:05 pm    Post subject: Reply with quote

CtrlAltElite,

sorry to hear you are having trouble with this ><

If your Pi is locking up, you have probably run out of memory / swap (see issue #59).

To address this, just open /etc/portage/make.conf and comment out the following lines so they read:
Code:
# for use when compiling locally
#MAKEOPTS="-j5 -l4"
#EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"
# for use with compiling with distcc only
#MAKEOPTS="-j8 -l4"
#EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"

Leave the rest of the file as-is, and save it.

Then pick up the new, more conservative defaults:
Code:
pi64 ~ # emaint sync --repo rpi3

(This will reduce the number of simultaneous compile threads attempted per emerge, and the number of simultaneous emerge processes, on your system.)

Then try:
Code:
pi64 ~ # nice emerge -av --changed-use --with-bdeps=y dev-libs/openssl net-misc/openssh dev-qt/qtnetwork =net-libs/nodejs-6.14.4
again.

If you get any compile errors with nodejs please just post them here.

Edit: update - I just tried this on an RPi3B+ here locally, and it went though fine. Note that I had to use v6.14.4 of nodejs - the most recent version didn't build correctly (syntax to specify this is on the command line above). Took about 3.5 hours to compile everything, but it definitely can be done.

I assume you are running on a microSD card larger than the minimum 8GB?

Apologies for the hassle with this - I have the project set up to distribute pre-built binaries for most package updates, but given the legal issue around redistribution here, there's no alternative (on Gentoo anyhow) but for you to rebuild the affected packages locally.
_________________
Regards,

sakaki
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum