Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with postfix mail queue -- RESOLVED
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1009
Location: Tujunga, CA

PostPosted: Thu Sep 20, 2018 4:37 am    Post subject: Problems with postfix mail queue -- RESOLVED Reply with quote

I have lots of deferred messages. When I run postqueue -f, I get errors like
Quote:
Sep 19 21:30:35 mon1 postfix/smtp[4643]: 9F0D59EAE22: to=<fkrogh@mathalacarte.com>, relay=none, delay=36812, delays=36812/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
in /var/log/messages. I've commented our references to amavis as follows
Quote:
# grep amavis /etc/postfix/main.cf /etc/postfix/master.cf
/etc/postfix/main.cf:#content_filter=smtp-amavis:[127.0.0.1]:10024
/etc/postfix/master.cf:smtp-amavis unix - - n - 2 smtp
/etc/postfix/master.cf:# -o content_filter=smtp-amavis # Bad result
as in my searching I found that these kinds of problems may be due to amavis. I'd love to have some suggestions on how to get the mail working again. Thanks,
Fred


Last edited by Fred Krogh on Thu Sep 20, 2018 6:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 383
Location: Somewhere in Denmark

PostPosted: Thu Sep 20, 2018 11:11 am    Post subject: Reply with quote

Quote:
I have lots of deferred messages. When I run postqueue -f, I get errors like
Quote:
Sep 19 21:30:35 mon1 postfix/smtp[4643]: 9F0D59EAE22: to=<fkrogh@mathalacarte.com>, relay=none, delay=36812, delays=36812/0.01/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
It's the handoff to amavis for scanning - Is amavis running?
Is amavis listining on that port (it's the default - but still)

Any error messages from amavis in logs?
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1009
Location: Tujunga, CA

PostPosted: Thu Sep 20, 2018 2:49 pm    Post subject: Reply with quote

It seems that at least I'm getting mail this morning. But postqueue -f is giving the same errors, and amavis is not running. Looking back in the logs I found
Quote:
Sep 19 21:29:08 mon1 amavis[2375]: Net::Server: Group Not Defined. Defaulting t
o EGID '102 102'
Sep 19 21:29:08 mon1 amavis[2375]: Net::Server: User Not Defined. Defaulting to
EUID '104'
Sep 19 21:29:08 mon1 amavis[2375]: No $altermime, not using it
Sep 19 21:29:08 mon1 amavis[2375]: Found secondary av scanner ClamAV-clamscan at
/usr/bin/clamscan
Sep 19 21:29:08 mon1 amavis[2375]: (!!)TROUBLE in pre_loop_hook: config: no rule
s were found! Do you need to run 'sa-update'?
Sep 19 21:29:08 mon1 amavis[2375]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook:
config: no rules were found! Do you need to run 'sa-update'?
I think these were the result of my playing around with different ways of removing amavis from the configuration files for postfix.
I just ran sa-update, but that makes no difference, but then amavis is not currently running. Many thanks for looking into this.
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 383
Location: Somewhere in Denmark

PostPosted: Thu Sep 20, 2018 3:35 pm    Post subject: Reply with quote

If you want to remove amavis from configuration that's simply a question of removing the content-filter line in main.cf and the smtp-amavis reference in master.cf.

Oth. if you want to get amavis running;

is $daemon_user and $daemon_group set in /etc/amavisd.conf ?

you can increase log level of amavis setting the $log_level variable in /etc/amavisd.conf

You tried to restart amavisd after sa-update? - still same error?
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1009
Location: Tujunga, CA

PostPosted: Thu Sep 20, 2018 4:21 pm    Post subject: Reply with quote

In amavisd.conf I have
Quote:
$daemon_user = 'amavis'; # (no default; customary: vscan or amavis), -u
$daemon_group = 'amavis'; # (no default; customary: vscan or amavis), -g
Iniitially amavis was not running.
I tried to run it and I can best show what happened by showing the commands. (psg is an alias that runs ps together wirh grep)
Quote:
mon1 ~ # /etc/init.d/amavisd start
* WARNING: amavisd has already been started
mon1 ~ # /etc/init.d/amavisd restart
* Stopping amavisd-new ...
The amavisd daemon is apparently not running, cannot stop it. [ !! ]
* ERROR: amavisd failed to stop
mon1 ~ # psg amavisd
mon1 ~ # /etc/init.d/amavisd stop
* Stopping amavisd-new ...
The amavisd daemon is apparently not running, cannot stop it. [ !! ]
* ERROR: amavisd failed to stop
mon1 ~ # psg amavis
mon1 ~ # /etc/init.d/amavisd zap
* Manually resetting amavisd to stopped state
mon1 ~ # psg amavis
mon1 ~ # /etc/init.d/amavisd start
* Starting amavisd-new ... [ ok ]
mon1 ~ # psg amavisd
28276 amavis /usr/sbin/amavisd (master) S
28284 amavis /usr/sbin/amavisd (virgin c S
28285 amavis /usr/sbin/amavisd (virgin c S
mon1 ~ # killall amavisd
amavisd: no process found
mon1 ~ # psg amavisd
28097 root /usr/bin/emacs /etc/amavisd S
28276 amavis /usr/sbin/amavisd (master) S
28284 amavis /usr/sbin/amavisd (virgin c S
28285 amavis /usr/sbin/amavisd (virgin c S
mon1 ~ # kill -9 28276
mon1 ~ # kill -9 28284
mon1 ~ # kill -9 28285
mon1 ~ # psg amavis
mon1 ~ # /etc/init.d/amavisd start
* WARNING: amavisd has already been started
mon1 ~ # psg amavis
mon1 ~ # /etc/init.d/amavisd restart
* Stopping amavisd-new ...
The amavisd daemon is apparently not running, cannot stop it. [ !! ]
* ERROR: amavisd failed to stop
mon1 ~ # psg amavis
mon1 ~ # /etc/init.d/amavisd start
* WARNING: amavisd has already been started
mon1 ~ # psg amavis
mon1 ~ # /etc/init.d/amavisd start
* WARNING: amavisd has already been started
mon1 ~ # psg amavis
mon1 ~ #
At least to me, this seems like strange behavior. In the log files the one time amavis started, I have
Quote:
Sep 20 09:01:09 mon1 amavis[28272]: starting. /usr/sbin/amavisd at mon1.mathalac
arte.com amavisd-new-2.11.0 (20160426), Unicode aware, LANG="en_US.utf8"
Sep 20 09:01:09 mon1 amavis[28276]: Net::Server: Group Not Defined. Defaulting
to EGID '102 102'
Sep 20 09:01:09 mon1 amavis[28276]: Net::Server: User Not Defined. Defaulting t
o EUID '104'
Sep 20 09:01:09 mon1 amavis[28276]: No $altermime, not using it
Sep 20 09:01:09 mon1 amavis[28276]: Found secondary av scanner ClamAV-clamscan a
t /usr/bin/clamscan
I'm hopeful that this means more to you than to me. Many thanks!
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 383
Location: Somewhere in Denmark

PostPosted: Thu Sep 20, 2018 4:47 pm    Post subject: Reply with quote

Is amavis installed via portage/emerge?

ie. is perl-dependecies installed?

is it using the correct/expected config-file?

You can try starting it with
Quote:
/etc/init.d/amavisd debug
instead of start - to see if that gives something additional info.

I get all this output with loglevel set to 2 in the amavisd.conf
Quote:
Sep 20 18:43:52 mail amavis[14418]: logging initialized, log level 2, syslog: amavis.mail
Sep 20 18:43:52 mail amavis[14418]: sd_notify (no socket): STATUS=Config files have been read, modules loaded.
Sep 20 18:43:52 mail amavis[14418]: starting. /usr/sbin/amavisd at mail.vlh.dk amavisd-new-2.11.0 (20160426), Unicode aware, LANG="en_US.utf8"
Sep 20 18:43:52 mail amavis[14418]: perl=5.024004, user=, EUID: 110 (110); group=, EGID: 992 992 (992 992)
Sep 20 18:43:52 mail amavis[14418]: INFO: no optional modules: unicore::lib::Nt::De.pl Unix::Getrusage
Sep 20 18:43:52 mail amavis[14418]: SpamControl: scanner SpamAssassin, module Amavis::SpamControl::SpamAssassin
Sep 20 18:43:53 mail amavis[14418]: INFO: SA version: 3.4.2, 3.004002, no optional modules: Razor2::Client::Agent
Sep 20 18:43:53 mail amavis[14418]: SpamControl: init_pre_chroot on SpamAssassin done
Sep 20 18:43:53 mail amavis[14418]: socket module IO::Socket::IP, protocol families available: INET, INET6
Sep 20 18:43:53 mail amavis[14418]: will bind to /var/amavis/amavisd.sock|unix, *:10024/tcp
Sep 20 18:43:53 mail amavis[14418]: sd_notify (no socket): STATUS=Transferring control to Net::Server.
Sep 20 18:43:53 mail amavis[14420]: Net::Server: Process Backgrounded
Sep 20 18:43:53 mail amavis[14420]: sd_notify (no socket): MAINPID=14420\nSTATUS=Daemonized, preparing to bind sockets.
Sep 20 18:43:53 mail amavis[14420]: Net::Server: 2018/09/20-18:43:53 Amavis (type Net::Server::PreForkSimple) starting! pid(14420)
Sep 20 18:43:53 mail amavis[14420]: Net::Server: Resolved [*]:10024 to [::]:10024, IPv6
Sep 20 18:43:53 mail amavis[14420]: Net::Server: Not including resolved host [0.0.0.0] IPv4 because it will be handled by [::] IPv6
Sep 20 18:43:53 mail amavis[14420]: Net::Server: Binding to UNIX socket file "/var/amavis/amavisd.sock"
Sep 20 18:43:53 mail amavis[14420]: Net::Server: Binding to TCP port 10024 on host :: with IPv6
Sep 20 18:43:53 mail amavis[14420]: sd_notify (no socket): STATUS=Sockets bound, checking user and group.
Sep 20 18:43:53 mail amavis[14420]: Net::Server: Group Not Defined. Defaulting to EGID '992 992'
Sep 20 18:43:53 mail amavis[14420]: Net::Server: User Not Defined. Defaulting to EUID '110'
Sep 20 18:43:53 mail amavis[14420]: sd_notify (no socket): STATUS=The rest of pre-fork init, finding helper programs.
Sep 20 18:43:53 mail amavis[14420]: config files read: /etc/amavisd.conf
Sep 20 18:43:54 mail amavis[14420]: Module Amavis::Conf 2.412
Sep 20 18:43:54 mail amavis[14420]: Module Archive::Zip 1.60
Sep 20 18:43:54 mail amavis[14420]: Module BerkeleyDB 0.55
Sep 20 18:43:54 mail amavis[14420]: Module Compress::Raw::Zlib 2.069
Sep 20 18:43:54 mail amavis[14420]: Module Compress::Zlib 2.069001
Sep 20 18:43:54 mail amavis[14420]: Module Crypt::OpenSSL::RSA 0.28
Sep 20 18:43:54 mail amavis[14420]: Module DBD::mysql 4.044
Sep 20 18:43:54 mail amavis[14420]: Module DBI 1.637
Sep 20 18:43:54 mail amavis[14420]: Module DB_File 1.835
Sep 20 18:43:54 mail amavis[14420]: Module Digest::MD5 2.54
Sep 20 18:43:54 mail amavis[14420]: Module Digest::SHA 5.95_01
Sep 20 18:43:54 mail amavis[14420]: Module Encode 2.80_01
Sep 20 18:43:54 mail amavis[14420]: Module File::Temp 0.2304
Sep 20 18:43:54 mail amavis[14420]: Module IO::Socket::INET6 2.72
Sep 20 18:43:54 mail amavis[14420]: Module IO::Socket::IP 0.37
Sep 20 18:43:54 mail amavis[14420]: Module MIME::Entity 5.509
Sep 20 18:43:54 mail amavis[14420]: Module MIME::Parser 5.509
Sep 20 18:43:54 mail amavis[14420]: Module MIME::Tools 5.509
Sep 20 18:43:54 mail amavis[14420]: Module Mail::DKIM::Signer 0.44
Sep 20 18:43:54 mail amavis[14420]: Module Mail::DKIM::Verifier 0.44
Sep 20 18:43:54 mail amavis[14420]: Module Mail::Header 2.19
Sep 20 18:43:54 mail amavis[14420]: Module Mail::Internet 2.19
Sep 20 18:43:54 mail amavis[14420]: Module Mail::SPF v2.009
Sep 20 18:43:54 mail amavis[14420]: Module Mail::SpamAssassin 3.004002
Sep 20 18:43:54 mail amavis[14420]: Module Net::DNS 1.1
Sep 20 18:43:54 mail amavis[14420]: Module Net::LibIDN 0.12
Sep 20 18:43:54 mail amavis[14420]: Module Net::Patricia 1.22
Sep 20 18:43:54 mail amavis[14420]: Module Net::Server 2.009
Sep 20 18:43:54 mail amavis[14420]: Module NetAddr::IP 4.079
Sep 20 18:43:54 mail amavis[14420]: Module Scalar::Util 1.4202
Sep 20 18:43:54 mail amavis[14420]: Module Socket 2.020_03
Sep 20 18:43:54 mail amavis[14420]: Module Socket6 0.28
Sep 20 18:43:54 mail amavis[14420]: Module Time::HiRes 1.9741
Sep 20 18:43:54 mail amavis[14420]: Module URI 1.73
Sep 20 18:43:54 mail amavis[14420]: Module Unix::Syslog 1.1
Sep 20 18:43:54 mail amavis[14420]: Amavis::ZMQ code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: Amavis::DB code loaded
Sep 20 18:43:54 mail amavis[14420]: SQL base code loaded
Sep 20 18:43:54 mail amavis[14420]: SQL::Log code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: SQL::Quarantine NOT loaded
Sep 20 18:43:54 mail amavis[14420]: Lookup::SQL code loaded
Sep 20 18:43:54 mail amavis[14420]: Lookup::LDAP code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: AM.PDP-in proto code loaded
Sep 20 18:43:54 mail amavis[14420]: SMTP-in proto code loaded
Sep 20 18:43:54 mail amavis[14420]: Courier proto code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: SMTP-out proto code loaded
Sep 20 18:43:54 mail amavis[14420]: Pipe-out proto code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: BSMTP-out proto code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: Local-out proto code loaded
Sep 20 18:43:54 mail amavis[14420]: OS_Fingerprint code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: ANTI-VIRUS code loaded
Sep 20 18:43:54 mail amavis[14420]: ANTI-SPAM code loaded
Sep 20 18:43:54 mail amavis[14420]: ANTI-SPAM-EXT code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: ANTI-SPAM-C code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: ANTI-SPAM-SA code loaded
Sep 20 18:43:54 mail amavis[14420]: Unpackers code loaded
Sep 20 18:43:54 mail amavis[14420]: DKIM code loaded
Sep 20 18:43:54 mail amavis[14420]: Tools code NOT loaded
Sep 20 18:43:54 mail amavis[14420]: Found $file at /usr/bin/file
Sep 20 18:43:54 mail amavis[14420]: No $altermime, not using it
Sep 20 18:43:54 mail amavis[14420]: Internal decoder for .mail
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .F at /usr/bin/unfreeze
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .Z at /usr/bin/uncompress
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .gz at /bin/gzip -d
Sep 20 18:43:54 mail amavis[14420]: Internal decoder for .gz (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .bz2 at /bin/bzip2 -d
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .xz at /usr/bin/xzdec
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .lzma at /usr/bin/lzmadec
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .lrz at /usr/bin/lrzip -q -k -d -o -
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .lzo at /usr/bin/lzop -d
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .lz4 at /usr/bin/lz4c -d
Sep 20 18:43:54 mail amavis[14420]: No ext program for .rpm, tried: rpm2cpio.pl, rpm2cpio
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .cpio at /usr/bin/pax
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .tar at /usr/bin/pax
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .deb at /usr/bin/ar
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .rar at /usr/bin/unrar
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .arj at /usr/bin/unarj
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .arc at /usr/bin/arc
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .zoo at /usr/bin/zoo
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .doc at /usr/bin/ripole
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .cab at /usr/bin/cabextract
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .tnef at /usr/bin/tnef
Sep 20 18:43:54 mail amavis[14420]: Internal decoder for .tnef (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .zip at /usr/bin/7za
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .kmz at /usr/bin/7za
Sep 20 18:43:54 mail amavis[14420]: Internal decoder for .zip (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Internal decoder for .kmz (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .7z at /usr/bin/7zr
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .gz at /usr/bin/7za (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .bz2 at /usr/bin/7za (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .Z at /usr/bin/7za (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .tar at /usr/bin/7za (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .xz at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .lzma at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .jar at /usr/bin/7z
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .cpio at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .arj at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .rar at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .swf at /usr/bin/7z
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .lha at /usr/bin/7z
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .iso at /usr/bin/7z
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .cab at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .deb at /usr/bin/7z (backup, not used)
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .rpm at /usr/bin/7z
Sep 20 18:43:54 mail amavis[14420]: Found decoder for .exe at /usr/bin/unrar; /usr/bin/lha; /usr/bin/unarj
Sep 20 18:43:54 mail amavis[14420]: Using primary internal av scanner code for ClamAV-clamd
Sep 20 18:43:54 mail amavis[14420]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
Sep 20 18:43:54 mail amavis[14420]: Deleting db files snmp.db,__db.002,__db.001,nanny.db,__db.003 in /var/amavis/db
Sep 20 18:43:54 mail amavis[14420]: Creating db in /var/amavis/db/; BerkeleyDB 0.55, libdb 5.3
Sep 20 18:43:54 mail amavis[14420]: initializing Mail::SpamAssassin (0)
Sep 20 18:43:54 mail amavis[14420]: SpamAssassin debug facilities: info
Sep 20 18:44:03 mail amavis[14420]: SpamAssassin loaded plugins: AWL, AskDNS, BodyEval, Check, DKIM, DNSEval, FreeMail, HTMLEval, HTTPSMismatch, Hashcash, HeaderEval, ImageInfo, MIMEEval, MIMEHeader, PDFInfo, Pyzor, Razor2, RelayEval, ReplaceTags, Rule2XSBody, SPF, SpamCop, TextCat, TxRep, URIDetail, URIEval, VBounce, WLBLEval, WhiteListSubject
Sep 20 18:44:03 mail amavis[14420]: SpamControl: init_pre_fork on SpamAssassin done
Sep 20 18:44:03 mail amavis[14420]: extra modules loaded after daemonizing/chrooting: /usr/lib64/perl5/vendor_perl/5.24.3/x86_64-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /usr/lib64/perl5/vendor_perl/5.24.3/x86_64-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, IO/Socket/SSL/PublicSuffix.pm, Mail/SpamAssassin/Plugin/FreeMail.pm, Mail/SpamAssassin/Plugin/PDFInfo.pm, Mail/SpamAssassin/Plugin/SpamCop.pm, Mail/SpamAssassin/Plugin/TxRep.pm, Net/Cmd.pm, Net/Config.pm, Net/SMTP.pm, Net/SSLeay.pm
Sep 20 18:44:03 mail amavis[14420]: sd_notify (no socket): READY=1\nSTATUS=Initialization done.
Sep 20 18:44:03 mail amavis[14420]: sd_notify (no socket): STATUS=Starting child process(es), ready for work.
So the few lines you get seems quite... sparse.

Last edited by freke on Thu Sep 20, 2018 4:59 pm; edited 2 times in total
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1009
Location: Tujunga, CA

PostPosted: Thu Sep 20, 2018 4:56 pm    Post subject: Reply with quote

Everything on my system has been installed using portage/emerge. equery g amavisd-new gives a long list (150 of them) of perl modules
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 383
Location: Somewhere in Denmark

PostPosted: Thu Sep 20, 2018 5:07 pm    Post subject: Reply with quote

Starting with /etc/init.d/amavisd debug probably creates quite some output so use wgetpaste or something similar ;)
Back to top
View user's profile Send private message
Fred Krogh
Veteran
Veteran


Joined: 07 Feb 2005
Posts: 1009
Location: Tujunga, CA

PostPosted: Thu Sep 20, 2018 5:50 pm    Post subject: Reply with quote

I'm mystified. I could post the debug print, but with that running, postqueue -f gave no errors. And a little mail arrived, unfortunately it was spam and got deleted before I bothered to look at the dates. So maybe things are wroking now. It seems that /etc/init.d/amavisd stop does not really stop things, but using zap instead of stop seems to do the job. I'm going to try running with amavis enabled in the configuration files and send some mail to myself. However that turns out, I'll postl the results here. Many thanks.

Just tried this and it worked!! Another thing that I did when having problems was to back out of the latest postfix. I will now try that and see what happens.

And now postfix-3.3.1-r1 seems to work for me as well. At least to me all of this will just remain a mystery! Thanks for the help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum