Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Downgrade of qtcore and qtsql with last update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pourpier
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 105

PostPosted: Sat Sep 15, 2018 10:52 am    Post subject: [SOLVED] Downgrade of qtcore and qtsql with last update Reply with quote

Hello!
I did a world update and I got slot conflicts for qt. I added the -t option to emerge -avuDN @world and it gave me this:
Code:
Calculating dependencies... done!
[nomerge       ] net-misc/youtube-dl-2018.08.22::gentoo  USE="offensive {-test}" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5"
[ebuild     U  ]  dev-lang/python-2.7.15:2.7::gentoo [2.7.14-r1:2.7::gentoo] USE="bluetooth%* gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -tk -wininst" 12.362 KiB
[ebuild     U  ] app-editors/nano-2.9.8::gentoo [2.8.7::gentoo] USE="magic ncurses nls spell unicode -debug -justify -minimal -slang -static" 2.838 KiB
[ebuild     U  ] sys-apps/man-pages-4.16::gentoo [4.15::gentoo] USE="nls" L10N="fr -da -de -it -ja -nl -pl -ru -zh-CN" 1.592 KiB
[nomerge       ] media-sound/clementine-1.3.1_p20180523::gentoo  USE="cdda dbus pulseaudio udisks -box -debug -dropbox -googledrive -ipod -lastfm -mms -moodbar -mtp -projectm -seafile -skydrive {-test} -wiimote"
[ebuild     UD ]  dev-qt/qtsql-5.9.6-r1:5/5.9.6::gentoo [5.11.1:5/5.11::gentoo] USE="sqlite -debug -freetds -mysql -oci8 -odbc -postgres {-test}" 0 KiB
[ebuild     UD~]   dev-qt/qtcore-5.9.6-r1:5/5.9::gentoo [5.11.1:5/5.11::gentoo] USE="icu -debug -systemd {-test}" 0 KiB
[nomerge       ] media-gfx/gimp-2.8.22-r1:2::gentoo  USE="alsa bzip2 dbus exif jpeg lcms mng pdf png python svg tiff udev -aalib (-altivec) (-aqua) -curl -debug -doc -gnome -jpeg2k -postscript -smp {-test} -wmf -xpm" CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7"
[nomerge       ]  gnome-base/librsvg-2.40.18:2::gentoo  USE="introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   dev-util/glib-utils-2.52.3::gentoo  0 KiB
[nomerge       ] dev-libs/libical-2.0.0-r3:0/2::gentoo  USE="-doc -examples -static-libs"
[nomerge       ]  dev-util/cmake-3.9.6::gentoo  USE="ncurses -doc -emacs -qt5 -server -system-jsoncpp {-test}"
[nomerge       ]   net-misc/curl-7.61.1::gentoo  USE="ipv6 ldap ssl -adns -brotli -http2 -idn -kerberos -metalink -rtmp -samba -ssh -static-libs {-test} -threads" ABI_X86="(64) -32 (-x32)" CURL_SSL="openssl -axtls -gnutls -libressl -mbedtls -nss (-winssl)"
[nomerge       ]    sys-devel/autoconf-2.69-r4:2.69::gentoo  USE="-emacs"
[nomerge       ]     dev-lang/perl-5.24.3-r1:0/5.24::gentoo  USE="berkdb gdbm -debug -doc -ithreads"
[nomerge       ]      sys-libs/db-5.3.28-r2:5.3::gentoo  USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64) -32 (-x32)"
[nomerge       ]       sys-devel/libtool-2.4.6-r3:2::gentoo  USE="-vanilla"
[nomerge       ]        sys-devel/automake-1.15.1-r2:1.15::gentoo  USE="{-test}"
[nomerge       ]         sys-apps/help2man-1.47.4::gentoo  USE="nls"
[nomerge       ]          dev-perl/Locale-gettext-1.70.0::gentoo
[nomerge       ]           sys-devel/gettext-0.19.8.1::gentoo  USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]            dev-libs/libxml2-2.9.8:2::gentoo  USE="ipv6 python readline -debug -examples -icu -lzma -static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5"
[nomerge       ]             dev-lang/python-2.7.15:2.7::gentoo [2.7.14-r1:2.7::gentoo] USE="bluetooth%* gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -build -doc -examples -hardened -libressl -tk -wininst"
[nomerge       ]              net-wireless/bluez-5.49-r1:0/3::gentoo  USE="alsa cups mesh obex readline udev -debug -deprecated -doc -experimental -extra-tools (-selinux) -systemd {-test} -test-programs -user-session" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[nomerge       ]               net-print/cups-2.2.7::gentoo  USE="X acl dbus pam python ssl threads usb -debug -java -kerberos -lprng-compat (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7"
[nomerge       ]                net-print/cups-filters-1.20.4::gentoo  USE="dbus foomatic jpeg ldap pdf png postscript tiff -ipp_autosetup -pclm -perl -static-libs {-test} -zeroconf"
[nomerge       ]                 app-text/poppler-0.62.0-r1:0/73::gentoo  USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss"
[ebuild     U ~]                  dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo [5.11.1:5/5.11::gentoo] USE="icu -debug -systemd {-test}" 0 KiB
[nomerge       ] media-gfx/gimp-2.8.22-r1:2::gentoo  USE="alsa bzip2 dbus exif jpeg lcms mng pdf png python svg tiff udev -aalib (-altivec) (-aqua) -curl -debug -doc -gnome -jpeg2k -postscript -smp {-test} -wmf -xpm" CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7"
[nomerge       ]  app-text/poppler-0.62.0-r1:0/73::gentoo  USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss"
[nomerge       ]   dev-qt/qtgui-5.11.1:5/5.11::gentoo  USE="dbus egl gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev (-gles2) -ibus {-test} -tslib -tuio -vnc"
[ebuild     U  ]    x11-libs/libxkbcommon-0.8.2::gentoo [0.8.0::gentoo] USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 629 KiB
[ebuild     U  ]  media-libs/libmng-2.0.3:0/2::gentoo [2.0.2-r1:0/2::gentoo] USE="lcms -static-libs" ABI_X86="(64) -32 (-x32)" 930 KiB
[ebuild  NS   ~] sys-kernel/gentoo-sources-4.18.7:4.18.7::gentoo [4.18.6:4.18.6::gentoo] USE="-build -experimental -symlink" 160 KiB
[nomerge       ] media-video/vlc-3.0.3-r1:0/5-9::gentoo  USE="X a52 alsa dbus dts dvbpsi dvd encode ffmpeg flac gcrypt jpeg libnotify libsamplerate mp3 mpeg ncurses ogg png pulseaudio qt5 ssl svg truetype udev vorbis x264 xml (-altivec) (-aom) -archive -bidi -bluray -cddb -chromaprint -chromecast -dc1394 -debug (-directx) -faad -fdk -fluidsynth -fontconfig -gme -gnome-keyring -gstreamer -ieee1394 -jack -kate -libass (-libav) -libcaca -libtar -libtiger -linsys -lirc -live -lua -macosx-notifications (-macosx-qtkit) -matroska -modplug -mtp -musepack (-neon) -nfs -omxil -opencv -optimisememory -opus -postproc -projectm -rdp -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -soxr -speex (-srt) -taglib {-test} -theora -tremor -twolame -upnp -v4l -vaapi -vdpau -vnc -vpx -wayland -wma-fixed -x265 -zeroconf -zvbi" CPU_FLAGS_X86="mmx sse"
[nomerge       ]  media-libs/libdvdread-6.0.0::gentoo  USE="css -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild     U  ]   media-libs/libdvdcss-1.4.2:1.2::gentoo [1.4.0:1.2::gentoo] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 359 KiB

Total: 11 packages (7 upgrades, 2 downgrades, 1 new, 1 in new slot), Size of downloads: 18.868 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.11.1-r1:5/5.11::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.11.1 required by (dev-qt/qtsvg-5.11.1:5/5.11::gentoo, installed)
    ^              ^^^^^^
    (and 10 more with the same problem)

  (dev-qt/qtcore-5.9.6-r1:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.6 required by (dev-qt/qtsql-5.9.6-r1:5/5.9.6::gentoo, ebuild scheduled for merge)
    ^              ^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qtsql-5.9.6-r1::gentoo
# required by media-sound/clementine-1.3.1_p20180523::gentoo
# required by @selected
# required by @world (argument)
=dev-qt/qtcore-5.9.6-r1 ~amd64

I tried equery d qtcore-5.9 and it gave me this:
Code:
* These packages depend on qtcore-5.9:
app-crypt/gpgme-1.11.1 (qt5 ? dev-qt/qtcore:5)
app-crypt/pinentry-1.0.0-r2 (qt5 ? dev-qt/qtcore:5)
app-crypt/qca-2.1.3-r2 (dev-qt/qtcore:5)
app-office/libreoffice-6.0.6.2 (kde ? dev-qt/qtcore:5)
app-text/poppler-0.62.0-r1 (qt5 ? dev-qt/qtcore:5)
dev-qt/linguist-tools-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtchooser-0_p20170803 (test ? dev-qt/qtcore:5)
dev-qt/qtconcurrent-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtdbus-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtgui-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtnetwork-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtopengl-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtsql-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtsvg-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qttest-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtwidgets-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtx11extras-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-qt/qtxml-5.11.1 (~dev-qt/qtcore-5.11.1)
dev-util/cmake-3.9.6 (qt5 ? dev-qt/qtcore:5)
media-libs/libmygpo-qt-1.1.0 (dev-qt/qtcore:5)
media-sound/clementine-1.3.1_p20180523 (dev-qt/qtcore:5)
media-video/vlc-3.0.3-r1 (qt5 ? dev-qt/qtcore:5)
x11-misc/lightdm-1.18.3-r1 (qt5 ? dev-qt/qtcore:5)

This is what I have in /etc/portage/package.accept_keywords for qt:
Code:
dev-qt/*:5/5.11 ~amd64


I read the ebuild for clementine and I haven't seen any specific requirement for qtcore-5.9.6 or qtsql-5.9.6

So I have no idea why emerge wants to downgrade qtcore and qtsql to 5.9.6 from 5.11
Does someone have a clue?

Best regards,
pourpier

PS: I just did equery g clementine and I saw that it needs qtsql-5.9.6-r1. My question now becomes if I put the line =dev-qt/qtcore-5.9.6-r1 ~amd64 (especially because that package is green on gentoo packages and thus not ~amd64) in /etc/portage/package.accept_keywords will there be some conflict as emerge also wants to upgrade qtcore-5.11.1 to 5.11.1-r1? I remember in the past that I had to avoid a mixture of qt packages in different slots.

[Moderator edit: added [code] tags to preserve output layout. -Hu]


Last edited by pourpier on Sat Sep 15, 2018 5:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1673

PostPosted: Sat Sep 15, 2018 3:11 pm    Post subject: Reply with quote

Looking at the clementine ebuild, it doesn't require a specific version of qtsql; so this issue may be a case of clementine needs to be rebuild along with qtsql. Try something like:
Code:
emerge -1av clementine qtsql


The issue with qt is that all parts of qt must be at the same version, so if you downgrade qtsql, all the rest of qt must also be downgraded at the same time.
Back to top
View user's profile Send private message
pourpier
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 105

PostPosted: Sat Sep 15, 2018 3:26 pm    Post subject: Reply with quote

ct85711 wrote:
Looking at the clementine ebuild, it doesn't require a specific version of qtsql; so this issue may be a case of clementine needs to be rebuild along with qtsql. Try something like:
Code:
emerge -1av clementine qtsql


The issue with qt is that all parts of qt must be at the same version, so if you downgrade qtsql, all the rest of qt must also be downgraded at the same time.


My actual version of qtsql is 5.11.1 as well as qtcore. In equery g clementine I saw qtsql-5.9.6-r1 even though the ebuild just mentions qt5.
I did re-emerge clementine. I had the green version before. So I put a ~amd64 in /etc/portage/package.accept_keywords and then I emerged clementine. But it absolutely wants the 5.9.6 version of qtsql. So I don't know how to proceed from here as I imagine I can't have both 5.11 and 5.9.6-r1 at the same time in /etc/portage/package.accept_keywords.
Cheers
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13043

PostPosted: Sat Sep 15, 2018 3:43 pm    Post subject: Reply with quote

You can have as many versions as you want in package.accept_keywords. That file only gives Portage permission to install the named versions in cases where it otherwise would not. It does not compel Portage to install any package named there. It looks like there is no qtsql with a subslot of 5.11 available, so the entry would not match anything. Why did you qualify the accept with a subslot?

Hint: check the output of emerge --pretend --verbose =dev-qt/qtsql-5.11.1\*.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6622
Location: Austria

PostPosted: Sat Sep 15, 2018 3:47 pm    Post subject: Re: Downgrade of qtcore and qtsql with last update Reply with quote

pourpier wrote:
This is what I have in /etc/portage/package.accept_keywords for qt:
Code:
dev-qt/*:5/5.11 ~amd64

You're using slot unmasking, but unfortunately that single line is not enough anymore. qtsql has gained more fine-grained subslots because sqlite ABI is broken with every micro release.

Code:
$ equery l -p qtsql
 * Searching for qtsql ...
[-P-] [  ] dev-qt/qtsql-5.9.6-r1:5/5.9.6
[IP-] [  ] dev-qt/qtsql-5.11.1-r1:5/5.11.1

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pourpier
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 105

PostPosted: Sat Sep 15, 2018 5:06 pm    Post subject: Reply with quote

Hu wrote:
You can have as many versions as you want in package.accept_keywords. That file only gives Portage permission to install the named versions in cases where it otherwise would not. It does not compel Portage to install any package named there. It looks like there is no qtsql with a subslot of 5.11 available, so the entry would not match anything. Why did you qualify the accept with a subslot?

Hint: check the output of emerge --pretend --verbose =dev-qt/qtsql-5.11.1\*.


Hello Hu!
The output of emerge -pv =dev-qt/qtsql-5.11.1\* asks to add =dev-qt/qtsql-5.11.1-r1 ~amd64 to /etc/portage/package.accept_keywords which was strange for me as I have dev-qt/*:5.11 ~amd64 in it which I copied from the recommendations of Asturm from another post. By reading Asturm's comment on this post I see why.
Cheers,
pourpier
Back to top
View user's profile Send private message
pourpier
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 105

PostPosted: Sat Sep 15, 2018 5:08 pm    Post subject: Re: Downgrade of qtcore and qtsql with last update Reply with quote

asturm wrote:
pourpier wrote:
This is what I have in /etc/portage/package.accept_keywords for qt:
Code:
dev-qt/*:5/5.11 ~amd64

You're using slot unmasking, but unfortunately that single line is not enough anymore. qtsql has gained more fine-grained subslots because sqlite ABI is broken with every micro release.

Code:
$ equery l -p qtsql
 * Searching for qtsql ...
[-P-] [  ] dev-qt/qtsql-5.9.6-r1:5/5.9.6
[IP-] [  ] dev-qt/qtsql-5.11.1-r1:5/5.11.1


Hello asturm!
Is it specific to qtsql or will it be the same mutatis mutandis for other qt packages with subslots?
Cheers,
pourpier
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6622
Location: Austria

PostPosted: Sat Sep 15, 2018 5:40 pm    Post subject: Reply with quote

You can always use the package.keywords files in kde overlay for reference. Right now, Documentation/package.keywords/kde-plasma-5.13.keywords contains:

Code:
dev-qt/*:5/5.11
dev-qt/qtwebkit:5/5.212
=dev-qt/qtsql-5.11*:5

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
pourpier
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 105

PostPosted: Sat Sep 15, 2018 5:47 pm    Post subject: Reply with quote

asturm wrote:
You can always use the package.keywords files in kde overlay for reference. Right now, Documentation/package.keywords/kde-plasma-5.13.keywords contains:

Code:
dev-qt/*:5/5.11
dev-qt/qtwebkit:5/5.212
=dev-qt/qtsql-5.11*:5


Thanks a lot for the tips, it worked fine with =dev-qt/qtsql-5.11.1-r1 in package.accept_keywords followed by emerge -1av =dev-qt/qtsql-5.11.1-r1. Then my world update had no blocks at all.
But I will edit my package.accept_keywords by copying the line related to qtsql you mentioned.
Cheers,
pourpier
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum