Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
3d graphics performance drops over time (GTX750)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 40

PostPosted: Wed Sep 12, 2018 5:54 pm    Post subject: 3d graphics performance drops over time (GTX750) Reply with quote

Okay, so there's something weird going on with my system and I don't understand what's wrong. I'm using the latest proprietary nvidia driver (396.54) with vulkan. I am currently playing some Resident Evil 4 (dolhin emulator) and Dark Souls 2 Scholar of the First Sin with DXVK (Lutris) on a fresh Gentoo install. At first everything was fine, but then I noticed a weird issue that makes games run like shit. From what I can tell this happens after I open and close games a lot of times or when games run for a long period of time. I'm guessing this has something to do with the drivers (a bug?), but I really don't know for sure. Never had this problem before and I thinking of reinstalling everything altogether, because I have no idea what is causing this. I checked if any proceses are running in the backgound that dind't close or something like that, but that's not the case. Btw, restarting my system fixes this issue until it starts to happen again. Also, this doesn't happen in Windows 10, so it's definately not a hardware isuue. :(
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2234
Location: near Augsburg, Germany

PostPosted: Wed Sep 12, 2018 6:27 pm    Post subject: Reply with quote

Can you check the graphics card temperature ?
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 40

PostPosted: Wed Sep 12, 2018 6:32 pm    Post subject: Reply with quote

No, it's not overheating. I checked that already, and even did a stress test to make sure. Also, I cleaned it up recently as well.

Maybe there's something wrong with my kernel config? Idk what to say at this point. :(
Everything else works fine. I'm only having problems with running games.
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2234
Location: near Augsburg, Germany

PostPosted: Wed Sep 12, 2018 6:57 pm    Post subject: Reply with quote

Can you check the graphics core clocks ?
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 40

PostPosted: Wed Sep 12, 2018 7:03 pm    Post subject: Reply with quote

I assume this is it?

https://i.imgur.com/WqaHy1O.png

How do I properly check it?
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2234
Location: near Augsburg, Germany

PostPosted: Thu Sep 13, 2018 4:11 am    Post subject: Reply with quote

Yes, correct.

And: can you check the logs (/var/log/.. and dmesg and top)?
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 405

PostPosted: Thu Sep 13, 2018 10:56 am    Post subject: Reply with quote

I think I saw similar bug fixed that year .. for Windows :D

You can try some older drivers, or just ignore that.

EDIT: I found that - it was fix for Linux
Quote:
Fixed a resource leak introduced in the 390 series of drivers that could lead to reduced performance after starting and stopping several OpenGL and/or Vulkan applications.


Version 390.87
Release Date Mon Aug 27, 2018

That fix was for legacy drivers, but it seems legacy drivers support even 10XX series.
Mb try that legacy version ? Its in portage.

On other hand Im using legacy drivers and they are crashing with kernel > 4.14 for me xD ( after random time of few hours, Im just 100% sure its nvidia legacy drivers fault, bc earlier I had Geforce 1050 on the same hardware and it was ok, now I returned to geforce 430Gt, I would use nouveau but on this temperature is 10 celsius higher when browsing ...)
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 40

PostPosted: Thu Sep 13, 2018 5:53 pm    Post subject: Reply with quote

@mir3x
yeah, that what I was thinking as well, and looks like it's not really fixed. I didn't want to downgrade until I confirmed it's really a bug with my current driver. Looks like I'll have to try an older version for now, but I am using kernel 4.14.xx as well, so idk really. I'll reply later about the results later.

@Keruskerfuerst

dmesg: https://pastebin.com/6iMM38aP

What am I supposed to be looking for in /var/log/ and top :?:
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2234
Location: near Augsburg, Germany

PostPosted: Thu Sep 13, 2018 6:14 pm    Post subject: Reply with quote

Quote:
What am I supposed to be looking for in /var/log/ and top :?:


top: a process eating 100 %CPU power.

/var/log/: maybe Xorg.0.log
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 40

PostPosted: Thu Sep 13, 2018 6:39 pm    Post subject: Reply with quote

@Keruskerfuerst
atm there's nothing eating up my CPU completely, but I should point out that the performance drop is only in 3d games. I'll check again if/when the problem occurs.

here's my xorg log: https://pastebin.com/716LN05s

Also, I've downgraded my nvidia-driver, so let's see what happens now.
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
an7h
n00b
n00b


Joined: 10 Jan 2018
Posts: 40

PostPosted: Sat Sep 15, 2018 10:07 pm    Post subject: Reply with quote

Okay, so I did some testing with an older driver, and yes, it is an issue with it. The downgrade fixed slowdown issues, but at the same time I can't get DXVK to work now with games, and overall the performance somewhat dropped. Ugh, looks like I'll have wait for a new driver to get this fixed properly. Thanks for the help, guys! :)
_________________
There's nothing more cheaper for politicians than human life.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum