Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
panic 0x228/0x274 with gentoo on RaspberryPi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Thu Aug 30, 2018 7:34 pm    Post subject: panic 0x228/0x274 with gentoo on RaspberryPi Reply with quote

I have built the kernel at https://github.com/raspberrypi/linux:rpi-4.18.y. for RPI 3B. I couldn't capture any more log except
Code:

panic 0x228/0x274


The only deviations I made from https://wiki.gentoo.org/wiki/Raspberry_Pi_3_64_bit_Install that I believe them as harmless are

1. I didn't make a swap partition.
2. I have used
Code:

crossdev -t aarch64-gentoo-linux-gnu

3. RPI kernel 4.18.y
4. boot partition is of 64MiB
5. as there is no brcmfmac43430-sdio.txt in the latest linux_firmware i copied both brcmfmac43430-sdio.AP6212.txt and brcmfmac43430-sdio.MUR1DX.txt


Last edited by necktwi on Fri Aug 31, 2018 9:41 am; edited 2 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41562
Location: 56N 3W

PostPosted: Thu Aug 30, 2018 7:38 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on ARM.

necktwi,

Explain the steps you used to configure, build and install the kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Fri Aug 31, 2018 3:09 am    Post subject: Reply with quote

I got your reply by mail while I haven't yet submitted the post! I am still previewing the post by then! If you notice I have put the deviations I made in the post. Please let me know if I can find any logs to post.

Thank You!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41562
Location: 56N 3W

PostPosted: Fri Aug 31, 2018 7:19 pm    Post subject: Reply with quote

necktwi,

Please try the RPI kernel 4.14.y kernel.
It gets all the fixes first.

The hardware for a Pi3B and P3B+ differ. I know the RPI kernel 4.14.y works on both with the bcmrpi3_defconfig.
The other changes are harmless.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Sat Sep 01, 2018 1:29 am    Post subject: Reply with quote

Before I tried 4.18.y, I tried 4.14.y which gave same error. Now I have strictly followed the guide, the 4.10.y is up and running, though the kernel spits
Code:
...
[    0.000000] Failed to get local register map. FIQ is disabled for cpus > 1
...
[    0.182547] dmi: Firmware registration failed.
...
[    0.327396] bcm2835-aux-uart 3f215040.serial: could not get clk: -517
...
[    2.224843] mmc1: error -110 whilst initialising SDIO card
[    2.270109] random: crng init done
[    3.483868] mmc1: error -110 whilst initialising SDIO card
[    4.751858] mmc1: error -110 whilst initialising SDIO card
[    6.120869] mmc1: error -110 whilst initialising SDIO card
[    8.168627] cgroup: cgroup2: unknown option "nsdelegate"
[    8.631640] udevd[657]: starting version 3.2.5
[    8.688998] udevd[657]: specified group 'i2c' unknown
[    8.689131] udevd[657]: specified group 'spi' unknown
[    8.689254] udevd[657]: specified group 'gpio' unknown

How can I fix them and update to the latest stable kernel?
Thank you!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41562
Location: 56N 3W

PostPosted: Sat Sep 01, 2018 10:40 am    Post subject: Reply with quote

necktwi,

I can host my working 4.14.y if you wish.
Substituting 4.14.y is the guide should just work.

4.10.y works on a Pi3B but everything moved to 4.14.y for the B+
As a result, 4.14.y works on both, but 4.10.y will not work on the B+.
It might boot but there will be no wifi, no USB and no LAN.

The Pi3 B+ also needs the latest bootcode.bin file as it does hardware detection.

It matters if your Pi is a 3B or 3B+
The 3B+ has a metal heat spreader over the CPU and a metal shield over the Wifi chip, that has the Raspberry logo on it.
Which Pi do you have ?

-- edit --

Code:
[    0.000000] Failed to get local register map. FIQ is disabled for cpus > 1

That reads as if you have the 32 bit *dtb file in use.
You must use the one from your kernel build.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Sat Sep 01, 2018 10:42 am    Post subject: Reply with quote

It's 3B. Please host. Thank you!
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Sat Sep 01, 2018 10:50 am    Post subject: Reply with quote

It seems my RPI isn't mounting boot and swap in the fstab
Code:
# mount
/dev/mmcblk0p3 on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=109493,mode=755)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run type tmpfs (rw,nodev,relatime,size=88664k,mode=755)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
shm on /dev/shm type tmpfs (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
none on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
blkio on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
memory on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
devices on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
freezer on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
net_cls on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)

Code:
# cat /etc/fstab
/dev/mmcblk0p1          /boot           vfat            noauto,noatime  1 2
/dev/mmcblk0p2          none            swap            sw              0 0
/dev/mmcblk0p3          /               ext4            noatime         0 1

It doen't mount even if I do mount -a
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41562
Location: 56N 3W

PostPosted: Sat Sep 01, 2018 11:29 am    Post subject: Reply with quote

necktwi,

You need Pi3_boot_010918.tbz2
That's every file you need on your Pi3 boot partition.

You also need the kernel modules tarball. That provides the content of /lib/modules/
I think that's enough.

/boot/config.txt should just work if you are using HDMI video. Read it over anyway.

You will probably need to edit my /boot/cmdline.txt
Code:
dwc_otg.lpm_enable=0 console=tty root=/dev/sda3 cma=256M@256M rootfstype=ext4 rootwait


I have root on a USB hdd, Put your root filesystem in place of /dev/sda3.
If your root filesystem is not ext4, fix that entry or remove rootfstype=ext4.

Warning: There is no framebuffer console in my 4.14.y, so the boot sequence goes
Rainbow
Blank screen for about 20 sec.
Console, after the VC4 kernel module loads, which requires root to mount.

The Green LED should do one long flash, then three or four short flashes when all is well.

Lastly. you might be interested in an arm64 BINHOST.
Feel free to poke abut on that server.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41562
Location: 56N 3W

PostPosted: Sat Sep 01, 2018 11:34 am    Post subject: Reply with quote

necktwi,

Ahhhh....

Code:
# cat /etc/fstab
/dev/mmcblk0p1          /boot           vfat            noauto,noatime  1 2
/dev/mmcblk0p2          none            swap            sw              0 0
/dev/mmcblk0p3          /               ext4            noatime         0 1


My mmc is usually mmcblk1 and my wifi is on mmc0
That's a fairly recent change.

Hmm ...

Code:
Pi3_~arm64 ~ # df -h
Filesystem                     Size  Used Avail Use% Mounted on
/dev/root                       24G   19G  4.6G  80% /
devtmpfs                        10M     0   10M   0% /dev
tmpfs                           97M  528K   97M   1% /run
cgroup_root                     10M     0   10M   0% /sys/fs/cgroup
tmpfs                          484M   15M  470M   3% /dev/shm
/dev/mapper/Pi3_64-buildspace   20G  691M   18G   4% /var/tmp/portage
/dev/mapper/Pi3_64-portage     3.0G  867M  2.0G  31% /usr/portage
/dev/mapper/Pi3_64-distfiles    40G  6.1G   32G  17% /var/cache/distfiles
/dev/mapper/Pi3_64-home         49G   33G   14G  71% /home
/dev/mapper/Pi3_64-packages     40G  5.6G   32G  15% /packages
/dev/mapper/Pi3_64-src          20G  3.5G   16G  19% /usr/src
/dev/mapper/Pi3_64-opt         2.0G  165M  1.7G   9% /opt
/dev/mapper/Pi3_64-tmp         4.0G   16M  3.8G   1% /tmp
none                           484M   16K  484M   1% /run/user/1000
/dev/mmcblk0p1                 8.0G  132M  7.9G   2% /boot
none                           484M     0  484M   0% /run/user/0
but its OK there.

Usually, boot is set noauto in fstab, so its not auto mounted.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Sat Sep 01, 2018 3:06 pm    Post subject: Reply with quote

The following error remains, though I previously did move 32-bit dtb aside and copied the specified dtb.
Code:
[    0.713064] Error: Driver 'sdhost-bcm2835' is already registered, aborting...
...
[    0.716426] zswap: default zpool zbud not available
[    0.716442] zswap: pool creation failed
...
[    1.981550] mmc1: error -110 whilst initialising SDIO card
[    2.066564] random: crng init done
[    3.245562] mmc1: error -110 whilst initialising SDIO card
[    4.503561] mmc1: error -110 whilst initialising SDIO card
...
[    5.587632] udevd[633]: specified group 'i2c' unknown
[    5.587769] udevd[633]: specified group 'spi' unknown
[    5.587903] udevd[633]: specified group 'gpio' unknown
[    5.590238] udevd[634]: starting eudev-3.2.5
[    5.872614] mmc1: error -110 whilst initialising SDIO card

I didn't understand "poke abut on that server". It sounds geeky, I like to do that if you elaborate!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41562
Location: 56N 3W

PostPosted: Sat Sep 01, 2018 3:33 pm    Post subject: Reply with quote

necktwi,

Sorry. "Poke about" is British English slang for look around my server and help yourself to anything interesting.
I run it mostly to help with Gentoo.

Code:
[    0.713064] Error: Driver 'sdhost-bcm2835' is already registered, aborting...

Is harmless. There are two drivers in the kernel for the Pi SD card. That message tells that the second driver is giving up because there is already a driver loaded.

Code:
[    0.716426] zswap: default zpool zbud not available
[    0.716442] zswap: pool creation failed

I tried to add compressed swap to the kernel and failed. Ordinary swap will work.
That's not a fatal error.

Code:
[    1.981550] mmc1: error -110 whilst initialising SDIO card

That's the WiFi.

Code:
[    5.587632] udevd[633]: specified group 'i2c' unknown
[    5.587769] udevd[633]: specified group 'spi' unknown
[    5.587903] udevd[633]: specified group 'gpio' unknown

I've not looked into.

It looks like your Pi booted.

Can you put your dmesg output onto a pastebin site please.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Sat Sep 01, 2018 3:48 pm    Post subject: Reply with quote

dmesg
https://pastebin.com/C2Z9qFfV
I shall explore bloodnooc.org. thanks!
Back to top
View user's profile Send private message
necktwi
Tux's lil' helper
Tux's lil' helper


Joined: 24 Aug 2018
Posts: 102

PostPosted: Tue Sep 04, 2018 11:39 am    Post subject: 4.18.y worked when cpu scaling set to ondemand Reply with quote

Previously when I tried 4.18.y, I didn't set cpu scaling to ondemand. Now i tried setting it and recompile the kernel. It worked.
https://pastebin.com/7d9TV2DD is the dmesg of the new kernel. though it still complains
Code:

[    5.587632] udevd[633]: specified group 'i2c' unknown
[    5.587769] udevd[633]: specified group 'spi' unknown
[    5.587903] udevd[633]: specified group 'gpio' unknown
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum