Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Nouveau driver not working with GTX 1050
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Tue Aug 28, 2018 3:58 pm    Post subject: [Solved] Nouveau driver not working with GTX 1050 Reply with quote

Code:

$ dmesg | grep nouveau
[    0.807535] fb: switching to nouveaufb from EFI VGA
[    0.807636] nouveau 0000:01:00.0: NVIDIA GP107 (137000a1)
[    0.917195] nouveau 0000:01:00.0: bios: version 86.07.39.80.1e
[    0.917407] nouveau 0000:01:00.0: Direct firmware load for nvidia/gp107/gr/sw_nonctx.bin failed with error -2
[    0.917411] nouveau 0000:01:00.0: gr: failed to load gr/sw_nonctx
[    0.917673] nouveau 0000:01:00.0: fb: 2048 MiB GDDR5
[    1.565069] nouveau 0000:01:00.0: DRM: VRAM: 2048 MiB
[    1.565071] nouveau 0000:01:00.0: DRM: GART: 536870912 MiB
[    1.565074] nouveau 0000:01:00.0: DRM: BIT table 'A' not found
[    1.565076] nouveau 0000:01:00.0: DRM: BIT table 'L' not found
[    1.565078] nouveau 0000:01:00.0: DRM: TMDS table version 2.0
[    1.565079] nouveau 0000:01:00.0: DRM: DCB version 4.1
[    1.565081] nouveau 0000:01:00.0: DRM: DCB outp 00: 01000f42 04620030
[    1.565084] nouveau 0000:01:00.0: DRM: DCB outp 01: 02011f62 04620010
[    1.565086] nouveau 0000:01:00.0: DRM: DCB outp 02: 02822f76 04600020
[    1.565088] nouveau 0000:01:00.0: DRM: DCB outp 03: 02022f72 04620020
[    1.565090] nouveau 0000:01:00.0: DRM: DCB conn 00: 00001031
[    1.565091] nouveau 0000:01:00.0: DRM: DCB conn 01: 00010161
[    1.565093] nouveau 0000:01:00.0: DRM: DCB conn 02: 00020246
[    1.587212] nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
[    1.690784] nouveau 0000:01:00.0: DRM: allocated 1920x1080 fb: 0x200000, bo (____ptrval____)
[    1.703144] fbcon: nouveaufb (fb0) is primary device
[    1.934596] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[    1.934722] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 0


Any help is appreciated.
Thanks.

----- Solution -----
It turned out that I didn't run "eselect opengl set nvidia".
_________________
Think twice,code once.


Last edited by PhoenixStarEclipse on Wed Aug 29, 2018 8:39 am; edited 2 times in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7645
Location: Saint Amant, Acadiana

PostPosted: Tue Aug 28, 2018 4:08 pm    Post subject: Reply with quote

So the firmware is not loaded because you are not providing it properly. Not sure what you expect us to do about it. Note, if you have the driver built into kernel then you need to build the firmware in, too.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4508
Location: Dallas area

PostPosted: Tue Aug 28, 2018 4:10 pm    Post subject: Reply with quote

emerge -av linux-firmware
_________________
PRIME x570-pro, 3700x, RX 550 & 560
Acer E5-575 (laptop), i3-7100u - i965
---both---
5.5.18 zen kernel, gcc 9.3.0, profile 17.1 (no-pie & modified) amd64-no-multilib, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Tue Aug 28, 2018 4:23 pm    Post subject: Reply with quote

Anon-E-moose wrote:
emerge -av linux-firmware

I've already had it installed.
Thanks anyway.
_________________
Think twice,code once.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24006
Location: here

PostPosted: Tue Aug 28, 2018 4:33 pm    Post subject: Reply with quote

What return command
Code:
$ grep FIRMWARE /usr/src/linux/.config

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Tue Aug 28, 2018 4:36 pm    Post subject: Reply with quote

Jaglover wrote:
So the firmware is not loaded because you are not providing it properly. Not sure what you expect us to do about it. Note, if you have the driver built into kernel then you need to build the firmware in, too.

Code:

#
# Firmware loader
#
CONFIG_FW_LOADER=y
CONFIG_EXTRA_FIRMWARE="nvidia/gp107/gr/sw_nonctx.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"

I've recompiled my kernel with the configure above, but the problem remains the same. BTW, I'm using ~amd64 packages.
Thanks for your advice.
_________________
Think twice,code once.
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Tue Aug 28, 2018 5:01 pm    Post subject: Reply with quote

fedeliallalinea wrote:
What return command
Code:
$ grep FIRMWARE /usr/src/linux/.config

Code:

CONFIG_PREVENT_FIRMWARE_BUILD=y
CONFIG_EXTRA_FIRMWARE="nvidia/gp107/gr/sw_nonctx.bin"
CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"
CONFIG_HOSTAP_FIRMWARE=y
CONFIG_HOSTAP_FIRMWARE_NVRAM=y
CONFIG_RT2X00_LIB_FIRMWARE=y
# CONFIG_CYPRESS_FIRMWARE is not set
CONFIG_DRM_LOAD_EDID_FIRMWARE=y
# CONFIG_FIRMWARE_EDID is not set
CONFIG_FIRMWARE_MEMMAP=y
# CONFIG_GOOGLE_FIRMWARE is not set
# CONFIG_TEST_FIRMWARE is not set

_________________
Think twice,code once.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7645
Location: Saint Amant, Acadiana

PostPosted: Tue Aug 28, 2018 5:39 pm    Post subject: Reply with quote

Check with uname -a if you are running the kernel you think you are.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Wed Aug 29, 2018 1:32 am    Post subject: Reply with quote

Jaglover wrote:
Check with uname -a if you are running the kernel you think you are.

Yes, the latest kernel is being run.
_________________
Think twice,code once.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7645
Location: Saint Amant, Acadiana

PostPosted: Wed Aug 29, 2018 1:43 am    Post subject: Reply with quote

Latest like the latest kernel version or latest like the last one you compiled and installed?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Wed Aug 29, 2018 2:07 am    Post subject: Reply with quote

Jaglover wrote:
Latest like the latest kernel version or latest like the last one you compiled and installed?

Yes, I made this mistake before so I remember to run "grub-mkconfig" clearly.
_________________
Think twice,code once.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7645
Location: Saint Amant, Acadiana

PostPosted: Wed Aug 29, 2018 2:59 am    Post subject: Reply with quote

Not what I was asking, can you confirm the date and time of running kernel is correct?
Code:
uname -v

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Wed Aug 29, 2018 5:04 am    Post subject: Reply with quote

Jaglover wrote:
Not what I was asking, can you confirm the date and time of running kernel is correct?
Code:
uname -v

I booted from 4.18.4 Kernel and everything worked fine. I think the problem was caused by some incorrect config about my intel GPU. I'm going to recompile the kernel and see if the problem still appears.
_________________
Think twice,code once.
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Wed Aug 29, 2018 6:15 am    Post subject: Reply with quote

Jaglover wrote:
Not what I was asking, can you confirm the date and time of running kernel is correct?
Code:
uname -v


I've reinstalled the kernel from the default config, then invoked genkernel for a functioning kernel. Now it seems a little better, but the problem still exists. I'm completely sure that the kernel is the version desired.

Code:

[    0.807539] fb: switching to nouveaufb from EFI VGA
[    0.807705] nouveau 0000:01:00.0: NVIDIA GP107 (137000a1)
[    0.917269] nouveau 0000:01:00.0: bios: version 86.07.39.80.1e
[    0.917483] nouveau 0000:01:00.0: Direct firmware load for nvidia/gp107/gr/sw_ctx.bin failed with error -2
[    0.917487] nouveau 0000:01:00.0: gr: failed to load gr/sw_ctx
[    0.917880] nouveau 0000:01:00.0: fb: 2048 MiB GDDR5
[    1.565100] nouveau 0000:01:00.0: DRM: VRAM: 2048 MiB
[    1.565102] nouveau 0000:01:00.0: DRM: GART: 536870912 MiB
[    1.565104] nouveau 0000:01:00.0: DRM: BIT table 'A' not found
[    1.565106] nouveau 0000:01:00.0: DRM: BIT table 'L' not found
[    1.565108] nouveau 0000:01:00.0: DRM: TMDS table version 2.0
[    1.565110] nouveau 0000:01:00.0: DRM: DCB version 4.1
[    1.565112] nouveau 0000:01:00.0: DRM: DCB outp 00: 01000f42 04620030
[    1.565114] nouveau 0000:01:00.0: DRM: DCB outp 01: 02011f62 04620010
[    1.565116] nouveau 0000:01:00.0: DRM: DCB outp 02: 02822f76 04600020
[    1.565118] nouveau 0000:01:00.0: DRM: DCB outp 03: 02022f72 04620020
[    1.565120] nouveau 0000:01:00.0: DRM: DCB conn 00: 00001031
[    1.565122] nouveau 0000:01:00.0: DRM: DCB conn 01: 00010161
[    1.565124] nouveau 0000:01:00.0: DRM: DCB conn 02: 00020246
[    1.587205] nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
[    1.690783] nouveau 0000:01:00.0: DRM: allocated 1920x1080 fb: 0x200000, bo (____ptrval____)
[    1.691145] fbcon: nouveaufb (fb0) is primary device
[    1.943556] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[    1.943673] [drm] Initialized nouveau 1.3.1 20120801 for 0000:01:00.0 on minor 0

_________________
Think twice,code once.
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 71
Location: Jiangsu/China

PostPosted: Wed Aug 29, 2018 6:22 am    Post subject: Reply with quote

Jaglover wrote:
Not what I was asking, can you confirm the date and time of running kernel is correct?
Code:
uname -v


I compared the performance between the two kernels, and found that the line complaining about "Direct firmware load for nvidia/gp107/gr/sw_ctx.bin failed with error -2" does no harm. It's just that nouveau drivers lack efficiency. I'm swithing to close-source drivers.

Thank you.
_________________
Think twice,code once.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum