Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] extlinux doesn't find /boot/vmlinuz
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 09 Apr 2016
Posts: 54

PostPosted: Sat Aug 18, 2018 5:44 pm    Post subject: [solved] extlinux doesn't find /boot/vmlinuz Reply with quote

New install of Gentoo x86_64. Using extlinux boot loader

Installed extlinux :
emerge --ask sys-boot/syslinux
dd bs=440 conv=notrunc count=1 if=/usr/share/syslinux/mbr.bin of=/dev/sda

mkdir /boot/extlinux
extlinux --install /boot/extlinux
cd /boot
ln -snf . /boot/boot

cd /usr/src/linux
make install

cd /usr/share/syslinux
cp menu.c32 memdisk libcom32.c32 libutil.c32 vesamenu.c32 /boot/extlinux

UI vesamenu.c32
LABEL gentoo
    MENU LABEL Gentoo Linux
    LINUX /boot/vmlinuz-4.14.63-gentoo-r1
    APPEND root=/dev/sda2

When i try to boot extlinux does not find the kernel (/boot/vmlinuz-4.14.63-gentoo-r1). It fails with
Loading /boot/vmlinuz-4.14.63-gentoo-r1... failed: No such file or directory

This appears as extlinux menu being displayed continuously and counting the menu timeout in a loop : 3..2..1..3..2..1..... Clicking Esc to hide the menu allows to see the error


Found out that if i edit the config line from the extlinux menu (Tab in the menu) and change "/boot/vmlinuz..." to "/vmlinuz...." then it boots correctly

So, it seems that the "ln -snf . /boot/boot" symlink was not working correctly. (What i think might be happening is - when extlinux accesses it from the boot partition, then instead of pointing to "this folder", the symlink points to itself)

I deleted the symlink and created it again without the path from / :

cd /boot
rm boot
ln -ns . boot

So there is no explicit reference to any "boot/" folder or so in it

This solved the problem

Alternatively, it would probably work to just edit extlinux.conf and remove "boot/" from there, as mentioned above
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum