Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Sorry. Aber ich weiss nicht mehr weiter.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
sewulba
Guru
Guru


Joined: 09 Feb 2005
Posts: 495
Location: Heidelberg

PostPosted: Fri Aug 17, 2018 9:48 am    Post subject: [solved]Sorry. Aber ich weiss nicht mehr weiter. Reply with quote

Hallo Gentoo Community.

Es geht in meinem Fall jetzt mal ausnahmsweise nicht um Gentoo, sondern ein Raspbian. Aber sowohl diverse Debianforen, wie auch das vice-dev in Freenode IRC chat sagt gar nichts dazu.
Ich gehe also davon aus, dass meine Frage vielleicht völlig dumm ist. Wenn das so ist tut es mir leid, aber ich komme schon seit Tagen nicht weiter. So nun zu meinem Problem:

Ich habe ein minimales Raspbian installiert auf einen RPi 3 b+. Ich möchte Den Emulator Vice mit SDL von der Konsole aus nutzen. Fertig gibt es das wohl nicht also habe ich mir die Quellen runtergeladen (probiert mir Version 3.1 und 3.2 von Vice).
Ich bin folgendermaßen vorgegangen:

Code:
apt-get install libsdl1.2-dev
apt-get install byacc flex texinfo xa65
./confgure --enable-sdlui --without-pulse --without-resid
make -j5
make install

So weit keine Probleme. Läßt sich ohne Probs compilieren. :lol:
Nun gebe ich den Befehl x64 ein und es scheint zu starten. Aber es gibt nur einen schwarzen Bildschirm. Wenn ich nun blind F12 drücke und Pfeil nach oben, komme ich wieder raus und sehe die Konsole wieder. Er läuft wohl, aber sehen tue ich nichts.
Die logs sehen gut aus, außer vielleicht eine Meldung:

Code:
SDLVideo: Warning - bitdepth not set for OpenGL, trying 32...


Sonst sieht alles gut aus. Ich komme definitiv nicht mehr weiter und hoffe einer von Euch kann mir einen entscheidenden Tipp geben auch wenn es kein Gentoo ist. Ich bin echt verzweifelt. :cry:

Gruss Sewulba
_________________
System1:Apple PowerMac Dual G4 @ 1,83GHz with 2GB Ram. 400GB + 80GB HDD, Gentoo 13.0-ppc32
System2:Apple MacIntosh PowerMac Dual G5 @ 2.7 GHz/1,35GHz FSB... 8GB Ram. 250GB SATA. Gentoo 10.0-PPC64-64ul


Last edited by sewulba on Sun Aug 19, 2018 2:41 am; edited 1 time in total
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 197
Location: Switzerland

PostPosted: Fri Aug 17, 2018 1:00 pm    Post subject: Reply with quote

hi sewulba,
hast du schon versucht, die Farbtiefe in Vice auf 24 Bit zu stellen? Die Meldung, welche dir angezeigt wird, versucht in einen 32 Bit Mode zu wechseln. Falls dies nicht funktioniert, kann es sein, dass du nur ein schwarzes Bild hast. Leider kenne ich mich mit Vice nicht aus. Ich habe jedoch noch einen Guide[1] für Raspian gefunden. So wie ich das verstanden habe, unterstützt die Distro Retro Pi [2] ebenfalls den Vice Emulator oder mindestens einen Comodore 64 Emulator.


Gruss

[1]https://lb.raspberrypi.org/forums/viewtopic.php?t=69353
[2]https://retropie.org.uk/download/
_________________
For calming down your eyes or clearing your mind: www.patrickwehli.ch
Back to top
View user's profile Send private message
sewulba
Guru
Guru


Joined: 09 Feb 2005
Posts: 495
Location: Heidelberg

PostPosted: Sat Aug 18, 2018 8:49 am    Post subject: Reply with quote

mvaterlaus wrote:
hi sewulba,
hast du schon versucht, die Farbtiefe in Vice auf 24 Bit zu stellen? Die Meldung, welche dir angezeigt wird, versucht in einen 32 Bit Mode zu wechseln. Falls dies nicht funktioniert, kann es sein, dass du nur ein schwarzes Bild hast. Leider kenne ich mich mit Vice nicht aus. Ich habe jedoch noch einen Guide[1] für Raspian gefunden. So wie ich das verstanden habe, unterstützt die Distro Retro Pi [2] ebenfalls den Vice Emulator oder mindestens einen Comodore 64 Emulator.


Gruss

[1]https://lb.raspberrypi.org/forums/viewtopic.php?t=69353
[2]https://retropie.org.uk/download/


Hi und vielen Dank für Deine Antwort.

Ich habe schon alle Farbtiefen ausprobiert. Keine Veränderung. Retropie ist leider keine Alternative für mich, da man einen Controller dafür braucht. Ich möchte direkt in die C64er-Emulation springen können.
Ich befürchte mein Problem ist wohl grundsätzlicher Natur. Ich habe gestern noch Gentoo auf dem RPI 3 b+ gemacht und Vice installiert. Gleiches Phenomen. Schwarzer Bildschirm. Vielleicht ist die libSDL1.2 broken. Ich weiss nicht. Irgendwie strange die Sache.

Gruss Sewulba
_________________
System1:Apple PowerMac Dual G4 @ 1,83GHz with 2GB Ram. 400GB + 80GB HDD, Gentoo 13.0-ppc32
System2:Apple MacIntosh PowerMac Dual G5 @ 2.7 GHz/1,35GHz FSB... 8GB Ram. 250GB SATA. Gentoo 10.0-PPC64-64ul
Back to top
View user's profile Send private message
sewulba
Guru
Guru


Joined: 09 Feb 2005
Posts: 495
Location: Heidelberg

PostPosted: Sun Aug 19, 2018 2:40 am    Post subject: Reply with quote

Das Probnlem ist nun gelöst.
Ich hatte mich entschieden von der libsdl1.2 weg zu libsdl2 zu gehen.
Aus dem Repository installiert und es ging noch viel weniger. Nach etwa 2 Stunden wusste ich nun, dass der support für OpenGL wohl nicht wirklich funktioniert, weil als VIDEODRIVER von SDL2 nur dummy ging.
Also habe ich in den sauren Apfel gebissen und auch libsdl2 aus Quellen compiliert. Und siehe da: Compiliert man es mit den Funktionen, die man braucht, dann geht alles super.
Ich werde von dem System nun ein Backup machen und alles mit Gentoo auf dem RPi 3 B+. Da man sowieso alles selbst compilieren muss, dann will ich lieber Gentoo haben. :P

Gruss Sewulba

Ps.: Mit libsdl1.2 unter Raspbian null Chance es (VICE) zum laufen zu bekommen, zumindest für mich.
_________________
System1:Apple PowerMac Dual G4 @ 1,83GHz with 2GB Ram. 400GB + 80GB HDD, Gentoo 13.0-ppc32
System2:Apple MacIntosh PowerMac Dual G5 @ 2.7 GHz/1,35GHz FSB... 8GB Ram. 250GB SATA. Gentoo 10.0-PPC64-64ul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum