Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Kernel generated by genkernel fails to start xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 23
Location: Jiangsu/China

PostPosted: Fri Aug 10, 2018 5:20 am    Post subject: [Solved] Kernel generated by genkernel fails to start xorg Reply with quote

I tried to follow Gentoo wiki to install the modesetting driver for my intel integrated video card and changed some of the kernel options. After rebooting, xorg fails to start. I used
Code:
genkernel --lvm all
to fix this, but failed. It seems that genkernel inherits configs from the current running kernel. How can I disable this feature and let genkernel generate a brand-new kernel based on only it's detections?

Here's the output of dmesg

If any of you guys know something please let me know :lol:
Thank you in advance! :D
_________________
Think twice,code once.


Last edited by PhoenixStarEclipse on Fri Aug 10, 2018 10:49 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19224
Location: here

PostPosted: Fri Aug 10, 2018 5:23 am    Post subject: Reply with quote

You can add --menuconfig option to genkernel and disable via menu the undesired config
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1771
Location: Oranienburg/Germany

PostPosted: Fri Aug 10, 2018 8:27 am    Post subject: Reply with quote

Hi,

as fedeliallalinea said, add "--menuconfig" and check for the following:

Code:

[    7.860218] [drm] The driver support for your hardware in this kernel version is alpha quality
               See CONFIG_DRM_I915_ALPHA_SUPPORT or i915.alpha_support module parameter
               to enable support in this kernel version, or check for kernel updates.


In addition check, if you have the correct firmware packages installed. Maybe the coffee lake cpu needs a special firmware to run kms properly.

greets, Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 8GB, 620GB
3rd: i5-4570, 16GB, 10TB
4th: Asus N61VN, 8GB, 120GB
5th: Cubietruck, 2GB, 160GB + NFS
6th: C2D T7200, 2GB, 16GB USB + NFS
7th: RPi3 1GB, 64GB USB
Back to top
View user's profile Send private message
PhoenixStarEclipse
n00b
n00b


Joined: 11 May 2017
Posts: 23
Location: Jiangsu/China

PostPosted: Fri Aug 10, 2018 10:49 am    Post subject: Thanks, that was helpful Reply with quote

bbgermany wrote:
Hi,

as fedeliallalinea said, add "--menuconfig" and check for the following:

Code:

[    7.860218] [drm] The driver support for your hardware in this kernel version is alpha quality
               See CONFIG_DRM_I915_ALPHA_SUPPORT or i915.alpha_support module parameter
               to enable support in this kernel version, or check for kernel updates.


In addition check, if you have the correct firmware packages installed. Maybe the coffee lake cpu needs a special firmware to run kms properly.

greets, Stefan

_________________
Think twice,code once.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum