Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba - Windows NT4 Zugriff auf Share
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
doedel
Guru
Guru


Joined: 05 Feb 2006
Posts: 571
Location: Denmark

PostPosted: Tue Aug 07, 2018 10:11 am    Post subject: Samba - Windows NT4 Zugriff auf Share Reply with quote

Hallo,

ich habe eine Windows NT 4.0 (SP6a)-VM, in welcher ich mit Windows CE (Platform Builder) herumspielen will. Da Virtualbox keine Shared-Folders mit NT unterstützt, dachte ich, ich mache das mit Windows-Freigaben.

Netzwerk in Virtualbox ist auf Bridged. Ich kann auch problemlos hin und her pingen oder die VM mit nmap scannen. Netzwerk läuft.

Host = 192.168.0.15
VM = 192.168.0.24

Ich habe zuerst eine Freigabe erstellt (gesamtes Laufwerk C des NT-Systems).
Dann versucht zu mounten:
Code:

i5g ~ # smbclient -L \\\\192.168.0.24\\
Enter root's password:
Server does not support EXTENDED_SECURITY  but 'client use spnego = yes and 'client ntlmv2 auth = yes'
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows NT 4.0] Server=[NT LAN Manager 4.0]

   Sharename       Type      Comment
   ---------       ----      -------
   ADMIN$          Disk      Remote Admin
   IPC$            IPC       Remote IPC
   C$              Disk      Default share
Server does not support EXTENDED_SECURITY  but 'client use spnego = yes and 'client ntlmv2 auth = yes'
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows NT 4.0] Server=[NT LAN Manager 4.0]

   Server               Comment
   ---------            -------

   Workgroup            Master
   ---------            -------
i5g ~ # mount.cifs \\\\192.168.0.24\\C$ /mnt/smb
Password for root@\\192.168.0.24\C$:
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)



Danach habe ich eine Samba-Konfiguration erstellt, die eine Anonyme RW Freigabe erstellt. Mit einer Windows 7 VM kann ich auf diese auch zugreifen.
Windows NT4 frägt nach einem Passwort/Usernamen, ich lasse beides leer, tut sich nix, frägt gleich wieder danach.

Aber eigentlich will ich keinen Samba-Server für die VM, sondern das umgekehrt lösen, also die Freigabe der VM mounten.

Gibt's da eine Lösung für?


PS: Ich habe auch noch Interix (Vorgänger von Windows Services for Unix) da. Ich meine mal was von NFS gelesen zu haben, wäre das vielleicht eine alternative Lösung?
_________________
http://krumeltee.wordpress.com/ -> Linux, Microcontroller, ...
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1776
Location: Oranienburg/Germany

PostPosted: Tue Aug 07, 2018 11:04 am    Post subject: Reply with quote

Hallo,

eventuell musst du bei der SAMBA Kompatibilität für SMB rumschrauben. Könnest du mal deine smb.conf posten? Vielleicht finden wir da den "Schuldigen" ;)

Eventuell ist es sowas wie das hier:

Code:

server min protocol = SMB2_10
client min protocol = SMB2
client max protocol = SMB3


NT4 ist da doch echt "alt".

MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 8GB, 620GB
3rd: i5-4570, 16GB, 10TB
4th: Asus N61VN, 8GB, 120GB
5th: Cubietruck, 2GB, 160GB + NFS
6th: C2D T7200, 2GB, 16GB USB + NFS
7th: RPi3 1GB, 64GB USB
Back to top
View user's profile Send private message
doedel
Guru
Guru


Joined: 05 Feb 2006
Posts: 571
Location: Denmark

PostPosted: Tue Aug 07, 2018 12:03 pm    Post subject: Reply with quote

Eine smb.conf möchte ich ja nicht benutzen (bzw. keinen Samba Dienst), aber das brachte mich auf die Lösung:

Code:

# mount.cifs \\\\192.168.0.24\\C /mnt/smb -o vers=1.0,username=Administrator

So benutze ich Samba 1.0. Das username=Administrator musste ich noch anhängen, bei der Passwortabfrage dann einfach enter (leer lassen).

Vielen Dank!


Ja, NT ist schon etwäs älter. Genauso wie WinCE 2.11. Mit Win2000 gab's diverse Probleme schon beim Installieren des Platform Builders und NT4 wird eben als Betriebssystem für PB empfohlen.

Soweit läuft das jetzt alles wie es soll, nur der seamless-Mode will nicht. Dafür funktionieren die Grafiktreiber der VBOX-Guest-Additions ansonsten problemlos (32bit Color, Fenstergrösse=Auflösung, Mauszeigerintegration).
_________________
http://krumeltee.wordpress.com/ -> Linux, Microcontroller, ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum