Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage] InsecureRequestWarning
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Jul 08, 2018 1:22 pm    Post subject: [portage] InsecureRequestWarning Reply with quote

Hallo Zusammen,

Ich bekommen beim Syncen immer folgende Meldung:

Code:
 * Fetching remote list...
/usr/lib64/python3.4/site-packages/urllib3/connectionpool.py:858: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecureRequestWarning)
/usr/lib64/python3.4/site-packages/urllib3/connectionpool.py:858: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecureRequestWarning)
 * Fetch Ok


Grundsätzlich scheint alles zu funktionieren, aber mich würde trotzdem interessieren, wie man das abstellen kann?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2184
Location: Germany

PostPosted: Sun Jul 08, 2018 10:21 pm    Post subject: Reply with quote

Hi 3PO,

also ich weiß nicht wem die Seite readthedocs.io gehört. Aber wenn man dem Link folgt der bei der Warnung angegeben wurde..

Quote:
This happens when a request is made to an HTTPS URL without certificate verification enabled. Follow the certificate verification guide to resolve this warning.


Steht das da.. folgt man dem certificate verification Link.. bekommt man den Hinweis:

Quote:
It is highly recommended to always use SSL certificate verification. By default, urllib3 does not verify HTTPS requests.

In order to enable verification you will need a set of root certificates. The easiest and most reliable method is to use the certifi package which provides Mozilla’s root certificate bundle: ...


Das was folgt ist der Hinweis via pip certifi zu installieren.

Das ist vielleicht möglich, aber ich würde portage vorziehen statt einer pip Installation. Weil pip eher ein eigener Python-Paket-Manager ist und es ist in der Regel besser das mit Portage zu machen.

Schau dir mal an ob du
Code:
[I] dev-python/certifi
     Verfügbare Versionen:   2018.4.16 {PYTHON_TARGETS="pypy pypy3 python2_7 python3_4 python3_5 python3_6"}
     Installierte Versionen: 2018.4.16(16:00:00 18.06.2018)(PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6 -pypy -pypy3")
     Startseite:             http://certifi.io/ https://pypi.org/project/certifi
     Beschreibung:           Python package for providing Mozilla's CA Bundle


Installiert hast und schon neu gebaut nach dem Python-Update auf deinem System. Es gab ja vor Wochen den Wechsel auf ein neues stabiles "PYTHON_SINGLE_TARGET". Vielleicht wurde da bei dir das Paket dev-python/certifi noch nicht in der neuen PYTHON_SINGLE_TARGET Variante neu gebaut so das dein von Portage verwendete Python halt keine zur Version passende Version findet.

Wäre, wenn du das Paket nicht schon installiert hast, der einzige Grund den ich mir jetzt vorstellen könnte warum das nicht klappt. Oh wobei wenn du eine Version als Single_Target setzt aber nicht als Python_Target könnte das auch passieren. Denn das Certifi verwendet ja nur Python_Targets...
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Jul 15, 2018 2:59 pm    Post subject: Reply with quote

certifi ist bei mir installiert:

Code:
[I] dev-python/certifi
     Verfügbare Versionen:   2018.4.16 {PYTHON_TARGETS="pypy pypy3 python2_7 python3_4 python3_5 python3_6"}
     Installierte Versionen: 2018.4.16(21:46:11 29.06.2018)(PYTHON_TARGETS="python2_7 python3_5 -pypy -pypy3 -python3_4 -python3_6")
     Startseite:             http://certifi.io/ https://pypi.org/project/certifi
     Beschreibung:           Python package for providing Mozilla's CA Bundle


"PYTHON_TARGETS" und "PYTHON_SINGLE_TARGET" habe in der make.conf nicht gesetzt.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3514
Location: Germany

PostPosted: Sun Jul 15, 2018 3:53 pm    Post subject: [portage] InsecureRequestWarning Reply with quote

Hallo 3PO,
laut der Fehlermeldung wird die (relativ alte) python3.4 Version verwendet - aber dein installiertes dev-python/certifi Paket ist nicht mit python3.4 Unterstützung gebaut - vermutlich passt das nicht zusammen.

Vorschlag: Schau mal bitte wie dein python Interpreter gesetzt ist -->
Code:
eselect python list
Vermutlich ist der (noch) auf python3.4 gesetzt?!
Falls ja, dann setze den doch (sofern möglich) auf die aktuelle python3.5 Version.
Schau doch bitte auch mal warum python3.4 überhaupt noch installiert ist - zb via
Code:
emerge -av --depclean python:3.4
damit werden dann auch die reverse dependencies mit aufgelistet (sofern es den welche gibt).
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sat Jul 21, 2018 3:32 pm    Post subject: Reply with quote

Sorry für die späte Rückmeldung, aber daran scheint es nicht gelegen zu haben, denn die Fehlermeldung kommt auch mit Python 3.5:

Code:
 * Fetching remote list...
/usr/lib64/python3.5/site-packages/urllib3/connectionpool.py:858: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecureRequestWarning)
/usr/lib64/python3.5/site-packages/urllib3/connectionpool.py:858: InsecureRequestWarning: Unverified HTTPS request is being made. Adding certificate verification is strongly advised. See: https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecureRequestWarning)
 * Fetch Ok
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum