Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome desktop & vnc issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ranran
n00b
n00b


Joined: 11 Jul 2018
Posts: 53

PostPosted: Tue Jul 17, 2018 7:18 pm    Post subject: gnome desktop & vnc issue Reply with quote

Hello,

I have just installed gentoo.

1. I also selected profile desktop:
selected profile 7.0/desktop/gnome.
2. The updated world, which tool a lot of time.
emerge --ask --update --deep --newuse @world

Yet, checking make.conf, I see that there is no USE flag in file, shouldn't there be ?

I then tried to do "startx" , but there is no such command.

Next thing , I installed:
libvncserver
tightvnc

on starting vncserver, and connecting from remote I succeeded in connection, yet I only get a blank screen.
On doing "startx", I only get 3 terminals. (yet with vnc connection I always see a blank screen)

I then tried to install lightd, but trying to execyte lightd, I get:
"Failed to get system bus: could not connect: no such file or directory.
Failed to get D-bus connection"


Is there any idea how I should fix it to get a vnc connection.

Thank you,
ranran
ranran
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19235
Location: here

PostPosted: Tue Jul 17, 2018 7:39 pm    Post subject: Re: gnome desktop & vnc issue Reply with quote

ranran wrote:
1. I also selected profile desktop:
selected profile 7.0/desktop/gnome.
2. The updated world, which tool a lot of time.
emerge --ask --update --deep --newuse @world

You should install gnome or gnome-light, your emerge command perform an packages upadate but only if are installed

ranran wrote:
Yet, checking make.conf, I see that there is no USE flag in file, shouldn't there be ?

Check with emerge --info, some use flags are provided by profile but not directly added in make.conf.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ranran
n00b
n00b


Joined: 11 Jul 2018
Posts: 53

PostPosted: Tue Jul 17, 2018 8:15 pm    Post subject: Reply with quote

I'll try that.
Does the fail in startx explains why I also fail in vnc remote connection ?

Thanks,
ranran
Back to top
View user's profile Send private message
ranran
n00b
n00b


Joined: 11 Jul 2018
Posts: 53

PostPosted: Wed Jul 18, 2018 4:13 pm    Post subject: Reply with quote

I have difficulties with it.
I hope someone can help.

I tried to install gnome with
emerge --ask gnome-base/gnome
I got this error

Code:
These are the packages that would be merged, in order:

Calculating dependencies  ....... done!

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8:=[introspection]" has unmet requirements.
- net-misc/networkmanager-1.10.10::gentoo USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -connection-sharing -dhcpcd -elogind -gnutls -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( consolekit elogind systemd )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) vala? ( introspection ) wext? ( wifi ) exactly-one-of ( nss gnutls ) at-most-one-of ( consolekit elogind systemd )

(dependency required by "gnome-base/gnome-shell-3.24.3::gentoo[networkmanager]" [ebuild])
(dependency required by "gnome-base/gnome-3.24.2::gentoo" [ebuild])
(dependency required by "gnome-base/gnome" [argument])


So, I tried:
USE="systemd" emerge net-misc/networkmanager
Code:
Calculating dependencies 

!!! Problem resolving dependencies for net-misc/networkmanager
... done!

!!! The ebuild selected to satisfy "net-misc/networkmanager" has unmet requirements.
- net-misc/networkmanager-1.10.10::gentoo USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -connection-sharing -dhcpcd -elogind -gnutls -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( consolekit elogind systemd )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) vala? ( introspection ) wext? ( wifi ) exactly-one-of ( nss gnutls ) at-most-one-of ( consolekit elogind systemd )



I also tried adding to /etc/portage/make.confExample global USE flags :
USE="-qt4 -qt5 -kde X gtk gnome systemd"
and did:
emerge -avuND world

Yet, on repeating emerge --ask gnome-base/gnome, I get same results :(


emerge --info
https://hastebin.com/umuxagocaw.makefile

Thank you for help,
ranran
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19235
Location: here

PostPosted: Wed Jul 18, 2018 4:28 pm    Post subject: Reply with quote

You use OperRC or SystemD?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ranran
n00b
n00b


Joined: 11 Jul 2018
Posts: 53

PostPosted: Wed Jul 18, 2018 4:32 pm    Post subject: Reply with quote

I'm not sure .......

I installed new gentoo a day ago, then changed profile from 7.0/* to to 7.0/desktop/gnome.
and updated world.
I then added to make.conf several USE flags including systemd, as described in gnome wiki here:
https://wiki.gentoo.org/wiki/GNOME/Guide

Thanks for any idea,
ranran
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41127
Location: 56N 3W

PostPosted: Wed Jul 18, 2018 4:48 pm    Post subject: Reply with quote

ranran,

The three xterms is Xorgs default response to startx.
If you want something else, you must install and configure it.

By default, Gnome requires systemd. There is a systemd stage3 that make that easy.
You can switch from OpenRC to systemd or even run Gnome without systemd.
Gnome without systemd is not supported by the Gentoo devs.

Your error
Code:
!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8:=[introspection]" has unmet requirements.
- net-misc/networkmanager-1.10.10::gentoo USE="bluetooth consolekit dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -connection-sharing -dhcpcd -elogind -gnutls -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( consolekit elogind systemd )

Is due to both USE="consolekit systemd" being on. The error is "at-most-one-of"
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ranran
n00b
n00b


Joined: 11 Jul 2018
Posts: 53

PostPosted: Wed Jul 18, 2018 4:50 pm    Post subject: Reply with quote

Hi NeddySeagon,

What do you think is best to do ?
I don't mind, just need a desktop and vnc.
I don't understand... should I reinstall gentoo and use another stage3 ... that will be really bad if I must reinstall it from beginning :(

Another question, should I have seen the 3 terminals on vnc ?
Why I only get a blank screen ?

Another strage thing is that after update world the vncserver utility was removed.
Is because it is installed with
USE="server" emerge tigervnc

Thanks,
ranran


Last edited by ranran on Wed Jul 18, 2018 5:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum