Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
more portage flakiness [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1493

PostPosted: Sun Jul 15, 2018 7:33 pm    Post subject: more portage flakiness [solved] Reply with quote

portage-2.3.40-r1

I have this on two machines. The third machine does not show any change. The configurations are supposed to be as identical as possible (there are some slight hardware differences).

Code:

# emerge -Op cairo

These are the packages that would be merged, in order:

[ebuild   R    ] x11-libs/cairo-1.14.12::local  USE="X glib opengl svg xcb (-aqua) -debug (-gles2) -static-libs -valgrind" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


# emerge -p cairo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-libs/cairo-1.14.12::gentoo [1.14.12::local] USE="X glib opengl svg xcb (-aqua) -debug (-gles2) -static-libs -valgrind" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


Last edited by curmudgeon on Mon Jul 16, 2018 5:38 am; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5133

PostPosted: Sun Jul 15, 2018 8:04 pm    Post subject: Reply with quote

Show us a diff between the normal ebuild and your version? It's probably unsatisfiable dependencies.
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1493

PostPosted: Mon Jul 16, 2018 5:38 am    Post subject: more portage flakiness [solved] Reply with quote

Oops. Yes, indeed, the gentoo ebuild had changed (as part of - not sure how to describe it - the "proto" consolidation). Of course, there was no version bump (I think there should be in cases such as this), so I never updated the local ebuild. Thanks for pointing me in the right direction (probably should have found it myself, though).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum