Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xtables-addons 2.13 and kernel 4.14.52...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1299
Location: Fayetteville, NC, USA

PostPosted: Mon Jul 09, 2018 3:49 pm    Post subject: [SOLVED] Xtables-addons 2.13 and kernel 4.14.52... Reply with quote

I just built the new kernel and tried to rebuild my modules and got an error.
Code:

/var/tmp/portage/net-firewall/xtables-addons-2.13/work/xtables-addons-2.13/extensions/xt_DNETMAP.c: In function ‘dnetmap_tg’:
/var/tmp/portage/net-firewall/xtables-addons-2.13/work/xtables-addons-2.13/extensions/xt_DNETMAP.c:380:2: error: implicit declaration of function ‘NF_CT_ASSERT’; did you mean ‘NF_ACCEPT’? [-Werror=implicit-function-declaration]
  NF_CT_ASSERT(hooknum == NF_INET_POST_ROUTING ||
  ^~~~~~~~~~~~
  NF_ACCEPT

Looks like something may have changed? Do I need a newer xtables?
_________________
Ever picture systemd as what runs "The Borg"?


Last edited by The_Great_Sephiroth on Sat Jul 14, 2018 8:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19213
Location: here

PostPosted: Mon Jul 09, 2018 4:07 pm    Post subject: Reply with quote

Try to unmask 3.0 version
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1299
Location: Fayetteville, NC, USA

PostPosted: Mon Jul 09, 2018 4:19 pm    Post subject: Reply with quote

The system is updating right now. When it finishes I will try this. Thank you!
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1299
Location: Fayetteville, NC, USA

PostPosted: Sat Jul 14, 2018 8:57 pm    Post subject: Reply with quote

OK, version 3.0 requires kernel 4.15 or newer, so that didn't work. I did see 2.14 in the repo so I used it and it worked. No idea why 2.13 didn't, but likely something in the kernel changed is all.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19213
Location: here

PostPosted: Sun Jul 15, 2018 5:44 am    Post subject: Reply with quote

The_Great_Sephiroth wrote:
OK, version 3.0 requires kernel 4.15 or newer, so that didn't work. I did see 2.14 in the repo so I used it and it worked. No idea why 2.13 didn't, but likely something in the kernel changed is all.

Simply because version 2.13 require a kernel version <4.14. For me this is a bug and and should be opened a bug report for stabilize version 2.14 since that the kernel 4.14 is stable now
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum