Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma - nvidia problem[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gentoorockerfr
Apprentice
Apprentice


Joined: 25 May 2012
Posts: 201

PostPosted: Mon Jul 09, 2018 2:08 pm    Post subject: Plasma - nvidia problem[SOLVED] Reply with quote

when i try startx with xorg.conf file and opengl set to nvidia X not working -> says no screen found
when i try startx without xorg.conf file and opengl set to nvidia -> black screen saying plasma is unable to start as it could not correctly use Opengl2...
when i try startx with xorg.conf file and opengl set to xorg-x11 X not working
when i try startx without xorg.conf file and opengl set to xorg-x11 X -> working but in this situation i haven't a working graphic card

Quote:


ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


Any suggestions?
thank you


Last edited by gentoorockerfr on Sat Jul 14, 2018 7:20 am; edited 1 time in total
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 793

PostPosted: Tue Jul 10, 2018 4:20 pm    Post subject: Reply with quote

Quote:
ERROR: NVIDIA driver is not loaded

well, is it?
what's
Code:
modprobe nvidia
say?
check your /usr/src/linux-symlink and maybe your hardware. later nvidia-binary-drivers do not work with old(er) hardware, but compile (after a warning in the ebuild) and load.
reinstall nvidia-drivers, if necessary.
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
gentoorockerfr
Apprentice
Apprentice


Joined: 25 May 2012
Posts: 201

PostPosted: Thu Jul 12, 2018 5:32 pm    Post subject: Reply with quote

i cannot modprobe nvidia...i have already installed nvidia...

i have a series of problems with profile 17 of plasma....(see other posts)....
Back to top
View user's profile Send private message
DawgG
l33t
l33t


Joined: 17 Sep 2003
Posts: 793

PostPosted: Fri Jul 13, 2018 9:53 am    Post subject: Reply with quote

Quote:
i cannot modprobe nvidia...i have already installed nvidia...

if it (the nvidia-binary driver; a kernel module) is correctly installed, you must be able to modprobe it. if this fails, you cannot use it.
Code:
lsmod
must list nvidia as a loaded module.
if you (want to) use nouveau, you do not need it.

(sorry, with kde/plasma i cannot help you.)
GOOD LUCK!
_________________
DUMM KLICKT GUT.
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 438
Location: Berlin

PostPosted: Fri Jul 13, 2018 11:19 am    Post subject: Reply with quote

try to blacklist nouveau Driver in :

Code:
/etc/modprobe.d/blacklist.conf


Quote:
blacklist nouveau


good luck :-)
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
gentoorockerfr
Apprentice
Apprentice


Joined: 25 May 2012
Posts: 201

PostPosted: Sat Jul 14, 2018 7:20 am    Post subject: Reply with quote

Ok thank you! the problem was that i had not choosen the right profile...Also i blacklisted nouveau!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum