Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox Marks All Words as Misspelled
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 470

PostPosted: Wed Jul 04, 2018 3:58 pm    Post subject: Firefox Marks All Words as Misspelled Reply with quote

Sometime in the last few days Firefox started marking (ie. red squiggly line under a word) all words in text entry boxes as mis-spelled. Any idea why? (I am a bad speller but by misspelled word rate is not 100%)

I currently have www-client/firefox-61.0 emerged.

from firefoxe's about:config:

extensions.spellcheck.inline.max-misspellings;500
layout.spellcheckDefault;1
services.sync.prefs.sync.layout.spellcheckDefault;true
services.sync.prefs.sync.spellchecker.dictionary;true
spellchecker.dictionary_path;/usr/share/myspell

I have app-dicts/myspell-en emerged.

from 'eix -I firefox':

Code:
     Installed versions:  61.0^d(18:57:38 06/28/18)(dbus gmp-autoupdate hwaccel screenshot -bindist -custom-cflags -custom-optimization -debug -eme-free -hardened -jack -neon -pulseaudio -selinux -startup-notification -system-harfbuzz -system-icu -system-jpeg -system-libevent -system-libvpx -system-sqlite -test -wifi L10N="-ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cak -cs -cy -da -de -dsb -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -ff -fi -fr -fy -ga -gd -gl -gn -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -ka -kab -kk -km -kn -ko -lij -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW")


my /etc/locale.gen contains:
Code:
en_US ISO-8859-1
en_US.UTF-8 UTF-8


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1639

PostPosted: Wed Jul 04, 2018 6:00 pm    Post subject: Reply with quote

One thing I would suggest you check within firefox, is make sure it is using the correct language(s) for spell checking.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

Here's a thread I found, that described the same issue you have.
https://support.mozilla.org/en-US/questions/975459
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 247

PostPosted: Wed Jul 04, 2018 10:33 pm    Post subject: Reply with quote

It is a know bug with the last version of firefox. It seems like there is not going to be a solution for this in this release so the options are: to install the beta version or downgrade to stable.

https://bugs.gentoo.org/659730
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5227

PostPosted: Thu Jul 05, 2018 4:16 am    Post subject: Reply with quote

It's not actually fixed in 62.0_beta upstream, the ebuild just applies a workaround (which could've just as easily been backported to 61).
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6267
Location: /usr/lib64/lv2

PostPosted: Thu Jul 05, 2018 3:00 pm    Post subject: Reply with quote

Having this issue as well so I decided to mask 61.0.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum