Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia opengl not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
justin_brody
Apprentice
Apprentice


Joined: 26 Jan 2005
Posts: 209

PostPosted: Tue Jul 03, 2018 10:32 pm    Post subject: nvidia opengl not working Reply with quote

Hello,
I can't get opengl to work with nvidia, but it's o.k. with xorg-x11.
Code:

 ~ # eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11
~ #   glxinfo
name of display: localhost:25.0
Error: couldn't find RGB GLX visual or fbconfig

~ # eselect opengl set 2
Switching to xorg-x11 OpenGL interface... done
alaya ~ # glxinfo | head -5
name of display: localhost:25.0
display: localhost:25  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4

Any ideas? I'm running nvidia-drivers-396.24-r1 with the following use flags:
Code:

 U I
 + + X           : Install the X.org driver, OpenGL libraries, XvMC libraries, and VDPAU libraries
 + + abi_x86_32  : 32-bit (x86) libraries
 - - acpi        : Add support for Advanced Configuration and Power Interface
 - - compat      : Install non-GLVND libGL for backwards compatibility
 + + driver      : Install the kernel driver module
 - - gtk3        : Install nvidia-settings with support for GTK+ 3
 + + kms         : Enable support for kernel mode setting (KMS)
 + + multilib    : On 64bit systems, if you want to be able to compile 32bit and 64bit binaries
 - - pax_kernel  : PaX patches from the PaX project
 - - static-libs : Build static versions of dynamic libraries as well
 + + tools       : Install additional tools such as nvidia-settings
 + + uvm         : Install the Unified Memory kernel module (nvidia-uvm) for sharing memory between CPU and GPU in CUDA programs
 - - wayland     : Enable dev-libs/wayland backend

I am a member of the video group and have run a number of cuda applications on the card.

Any ideas??

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6840

PostPosted: Wed Jul 04, 2018 12:03 pm    Post subject: Reply with quote

You need to provide xorg.log, maybe check your dmesg also, nvidia do report error there too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum