Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sabayon boots to black screen after update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
AmphetamineSalts
n00b
n00b


Joined: 16 Jul 2017
Posts: 2

PostPosted: Fri Jun 29, 2018 5:54 am    Post subject: Sabayon boots to black screen after update Reply with quote

Hi, after following directions on the wiki's The Aftermath: Post-installation upgrades and configuration
section, Sabayon now boots a black screen; I can't even access another TTY prompt. Can someone please help me fix this?

Here is some info:

My computer has an Asrock Z370 Pro4 motherboard, and uses UEFI. The graphics card is Intel UHD 630, and it has an i7-8700K processor. The /var/log/Xorg.0.log file contains the following:

Code:


[   290.256]
X.Org X Server 1.19.5
Release Date: 2017-10-12
[   290.256] X Protocol Version 11, Revision 0
[   290.256] Build Operating System: Linux 4.9.0-sabayon x86_64 Gentoo
[   290.256] Current Operating System: Linux Jupiter 4.14.0-sabayon #1 SMP Tue Jun 19 09:36:43 UTC 2018 x86_64
[   290.256] Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.14.0-sabayon root=/dev/mapper/sabayon_jupiter-root ro single locale=en_US dolvm rd.lvm.lv=sabayon_jupiter/root resume=/dev/mapper/sabayon_jupiter-swap resume=/dev/sdc2 rd.lvm.lv=sabayon_jupiter/swap splash vconsole.keymap=us rd.vconsole.keymap=us quiet
[   290.256] Build Date: 14 June 2018  12:41:25PM
[   290.256] 
[   290.256] Current version of pixman: 0.34.0
[   290.256]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   290.256] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   290.256] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 29 01:40:49 2018
[   290.257] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   290.257] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   290.257] (==) No Layout section.  Using the first Screen section.
[   290.257] (==) No screen section available. Using defaults.
[   290.257] (**) |-->Screen "Default Screen Section" (0)
[   290.257] (**) |   |-->Monitor "<default monitor>"
[   290.258] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   290.258] (==) Automatically adding devices
[   290.258] (==) Automatically enabling devices
[   290.258] (==) Automatically adding GPU devices
[   290.258] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   290.258] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   290.258]    Entry deleted from font path.
[   290.258] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   290.258]    Entry deleted from font path.
[   290.258] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   290.258]    Entry deleted from font path.
[   290.258] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   290.258]    Entry deleted from font path.
[   290.258]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   290.258] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   290.258]    Entry deleted from font path.
[   290.258]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   290.258] (==) FontPath set to:
   /usr/share/fonts/misc/
[   290.258] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   290.258] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   290.258] (II) Loader magic: 0x55ce92ff1ce0
[   290.258] (II) Module ABI versions:
[   290.258]    X.Org ANSI C Emulation: 0.4
[   290.258]    X.Org Video Driver: 23.0
[   290.258]    X.Org XInput driver : 24.1
[   290.258]    X.Org Server Extension : 10.0
[   290.259] (++) using VT number 7

[   290.259] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[   290.262] (--) PCI:*(0:0:2:0) 8086:3e92:1849:3e92 rev 0, Mem @ 0xde000000/16777216, 0xc0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[   290.262] (II) LoadModule: "glx"
[   290.263] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   290.267] (II) Module glx: vendor="X.Org Foundation"
[   290.267]    compiled for 1.19.5, module version = 1.0.0
[   290.267]    ABI class: X.Org Server Extension, version 10.0
[   290.267] (==) Matched intel as autoconfigured driver 0
[   290.268] (==) Matched modesetting as autoconfigured driver 1
[   290.268] (==) Matched fbdev as autoconfigured driver 2
[   290.268] (==) Matched vesa as autoconfigured driver 3
[   290.268] (==) Assigned the driver to the xf86ConfigLayout
[   290.268] (II) LoadModule: "intel"
[   290.268] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   290.268] (II) Module intel: vendor="X.Org Foundation"
[   290.268]    compiled for 1.19.5, module version = 2.99.917
[   290.268]    Module class: X.Org Video Driver
[   290.268]    ABI class: X.Org Video Driver, version 23.0
[   290.268] (II) LoadModule: "modesetting"
[   290.269] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[   290.269] (II) Module modesetting: vendor="X.Org Foundation"
[   290.269]    compiled for 1.19.5, module version = 1.19.5
[   290.269]    Module class: X.Org Video Driver
[   290.269]    ABI class: X.Org Video Driver, version 23.0
[   290.269] (II) LoadModule: "fbdev"
[   290.269] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
[   290.269] (II) Module fbdev: vendor="X.Org Foundation"
[   290.269]    compiled for 1.19.5, module version = 0.5.0
[   290.269]    Module class: X.Org Video Driver
[   290.269]    ABI class: X.Org Video Driver, version 23.0
[   290.269] (II) LoadModule: "vesa"
[   290.269] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
[   290.269] (II) Module vesa: vendor="X.Org Foundation"
[   290.269]    compiled for 1.19.5, module version = 2.4.0
[   290.269]    Module class: X.Org Video Driver
[   290.269]    ABI class: X.Org Video Driver, version 23.0
[   290.269] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   290.270] (II) intel: Driver for Intel(R) HD Graphics
[   290.270] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   290.270] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   290.270] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[   290.270] (II) FBDEV: driver for framebuffer: fbdev
[   290.270] (II) VESA: driver for VESA chipsets: vesa



It also said that it can't run in "framebuffer mode".

Please help! Thank you in advance, and have a wonderful day.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1592
Location: Here and Away Again

PostPosted: Fri Jun 29, 2018 1:20 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Unsupported Software.

Since this is about Sabayon, not Gentoo, it fits better here.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum