Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Erledigt] Verständnisfrage zu einem "slot conflict"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Jun 24, 2018 2:06 pm    Post subject: [Erledigt] Verständnisfrage zu einem "slot conflict&quo Reply with quote

Hallo Zusammen,

Ich wollte heute mal wieder ein world Update machen, doch leider nörgelt Portage wegen:

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-drivers/nvidia-drivers:0

  (x11-drivers/nvidia-drivers-340.107:0/340::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-drivers/nvidia-drivers-396.24-r1:0/396::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-drivers/nvidia-drivers-347.09 required by (media-video/nvidia_video_sdk-6.0.1:0/0::gentoo, installed)
    ^^                           ^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (x11-base/xorg-server-1.20.0:0/1.20.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (x11-drivers/nvidia-drivers-396.24-r1:0/396::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-joystick-1.6.3:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-intel-2.99.917_p20180214-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-keyboard-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-vesa-2.4.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-nv-2.1.21:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-void-1.4.1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/nvidia-drivers-340.107:0/340::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-video-fbdev-0.5.0:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-synaptics-1.9.1:0/0::gentoo, ebuild scheduled for merge)
    (x11-drivers/xf86-input-mouse-1.9.3:0/0::gentoo, ebuild scheduled for merge)

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by @__auto_slot_operator_replace_installed__ (argument)
# /etc/portage/package.mask/nvidia:
=x11-drivers/nvidia-drivers-396.24-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


Ich habe den nvidia Treiber maskiert:

Code:
vdr01_64 ~ # grep -r "x11-drivers/nvidia-drivers" /etc/portage/*
/etc/portage/package.keywords/nvidia:<=x11-drivers/nvidia-drivers-387.34
/etc/portage/package.mask/nvidia:>=x11-drivers/nvidia-drivers-390.42
/etc/portage/package.use/nvidia:x11-drivers/nvidia-drivers gtk3 uvm
vdr01_64 ~ #


Installiert ist Version 387.34 und wenn ich die Fehlermeldung,
Code:
  (x11-drivers/nvidia-drivers-396.24-r1:0/396::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-drivers/nvidia-drivers-347.09 required by (media-video/nvidia_video_sdk-6.0.1:0/0::gentoo, installed)
    ^^                           ^^^^^^
richtig verstehe, soll mindestens Version 347.09 installiert sein, was ja der Fall ist.

Ich verstehe nun nicht, weshalb Portage nörgelt?

Wo habe ich denn nun meinen Denkfehler? :roll:


Last edited by 3PO on Sun Jun 24, 2018 3:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3490
Location: Germany

PostPosted: Sun Jun 24, 2018 3:19 pm    Post subject: Reply with quote

Hallo 3PO,

hehe ja, ist ein wenig kniffelig zu durchschauen.
Der slot conflict kommt etwa wie folgt zustande: Scheinbar hast du dir xorg-server-1.20.0 freigeschaltet,
und damit ist deine erwünschte nvidia-drivers-387.34 Version noch nicht kompatibel.
Die für nvidia-drivers-387.34 geforderten Abhängigkeiten schauen im ebuild so aus
nvidia-drivers-387.34.ebuild:
X? (
                <x11-base/xorg-server-1.19.99:=
[...]

Daher versucht portage scheinbar eine andere xorg-server-1.20 kompatible nvidia-drivers Version aufzulösen - 387.34 und höher kommt nicht in Frage, da maskiert, also wird eine nächst niedrigere kompatible Version versucht, und das ist laut der Ausgabe:
Code:
(x11-drivers/nvidia-drivers-340.107:0/340::gentoo, ebuild scheduled for merge)
und mit dieser nvidia-drivers-340.107 Version kommt es dann zu dem Konflikt mit
Code:
 >=x11-drivers/nvidia-drivers-347.09 required by (media-video/nvidia_video_sdk-6.0.1:0/0::gentoo, installed)
    ^^                           ^^^^^^

Lange Rede kurzer Sinn - für nvidia-drivers-387.34 brauchst du <x11-base/xorg-server-1.19.99
aktuell wäre das stable xorg-server-1.19.5-r2
Back to top
View user's profile Send private message
3PO
Veteran
Veteran


Joined: 26 Nov 2006
Posts: 1080
Location: Schwabenländle

PostPosted: Sun Jun 24, 2018 3:45 pm    Post subject: Reply with quote

Danke @Josef.95,

genau daran hat es gelegen. :wink:

Ich hatte vor langer zeit mal den xorg-server freigeschaltet, weil irgend eine Version von nvidia das wollte.

Leider aber funktionieren ja nvidia Treiber >=390.xx nit mehr mit dem VDR, bzw. mit skindesiger. :(

Man sollte halt ab und zu mal die keywords ausmisten. :lol:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum