Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201806-08 ] file
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2114

PostPosted: Sat Jun 23, 2018 10:26 pm    Post subject: [ GLSA 201806-08 ] file Reply with quote

Gentoo Linux Security Advisory

Title: file: Denial of service (GLSA 201806-08)
Severity: normal
Exploitable: remote
Date: 2018-06-23
Bug(s): #657930
ID: 201806-08

Synopsis

A vulnerability in file could lead to a Denial of Service
condition.


Background

file is a utility that guesses a file format by scanning binary data for
patterns.


Affected Packages

Package: sys-apps/file
Vulnerable: < 5.33-r2
Unaffected: >= 5.33-r2
Architectures: All supported architectures


Description

File does not properly utilize the do_core_note function in readelf.c in
libmagic.a.


Impact

A remote attacker could send a specially crafted ELF file possibly
resulting in a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All file users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-apps/file-5.33-r2"
   


References

CVE-2018-10360
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum