Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
chromium from pg_overlay
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 738

PostPosted: Wed Jun 13, 2018 7:13 pm    Post subject: chromium from pg_overlay Reply with quote

[Moderator note: this post, and the first 7 responses, were originally attached to Chromium USE flag change?, which dealt with Chromium from ::gentoo. This subthread deals with Chromium from ::pg_overlay. -Hu]

Chromium from pg_overlay hasn't built for me in a while. 67-0.3396.87 fails with
Code:

[25/104] python ../../v8/tools/js2c.py gen/v8/libraries.cc CORE ../../v8/src/js/macros.py ../../v8/src/messages.h ../../v8/src/js/prologue.js ../../v8/src/js/array.js ../../v8/src/js/typedarray.js ../../v8/src/debug/mirrors.js ../../v8/src/debug/debug.js ../../v8/src/debug/liveedit.js ../../v8/src/js/intl.js --startup_blob gen/v8/libraries.bin
ninja: build stopped: subcommand failed.
 * ERROR: www-client/chromium-67.0.3396.87::local_overlay failed (compile phase):
 *   ninja -v -j4 -l0 -C out/Release mksnapshot failed
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_compile
 *   environment, line 5054:  Called eninja '-C' 'out/Release' 'mksnapshot'
 *   environment, line 1707:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"
 *
 * If you need support, post the output of `emerge --info '=www-client/chromium-67.0.3396.87::local_overlay'`,
 * the complete build log and the output of `emerge -pqv '=www-client/chromium-67.0.3396.87::local_overlay'`.
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 442
Location: Earth

PostPosted: Wed Jun 13, 2018 7:20 pm    Post subject: Reply with quote

Quote:
try chromium from pg_overlay
Code:
[ebuild R ] www-client/chromium-67.0.3396.79::pg_overlay USE="cups custom-cflags debian inox jumbo-build (pic) proprietary-codecs pulseaudio suid system-ffmpeg system-icu system-libvpx tcmalloc thin-lto vaapi -component-build -gnome-keyring -hangouts -kerberos (-neon) (-selinux) -widevine" L10N="ru -am -ar -bg -bn -ca -cs -da -de -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 0 KiB


i also use chromium from this overlay and yesterdays version without this use flag worked anyway with NF.

P.S. just emerged ' www-client/chromium-67.0.3396.87 ' from pg_overlay right now with ccache and i only use chromium for NF and it works.

Code:
www-client/chromium-67.0.3396.87::layees [67.0.3396.81::layees] USE="-component-build -cups -custom-cflags -debian -gnome-keyring -hangouts inox jumbo-build -kerberos (-neon) (pic) proprietary-codecs pulseaudio (-selinux) -suid (-system-ffmpeg) (-system-icu) (-system-libvpx) (-tcmalloc) thin-lto -vaapi widevine" L10N="-am -ar -bg -bn -ca -cs -da -de -el en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 577,629 KiB


Code:
real  55m40.410s
user  332m32.091s
sys   13m32.811s

_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Thu Jun 14, 2018 2:20 am    Post subject: Reply with quote

Princess Nell wrote:
Chromium from pg_overlay hasn't built for me in a while. 67-0.3396.87 fails with

USE flags?
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 738

PostPosted: Thu Jun 14, 2018 6:36 am    Post subject: Reply with quote

After seeing your post in this thread, I changed them to
Code:

[ebuild     U ~] www-client/chromium-67.0.3396.87::local_overlay [64.0.3282.144::local_overlay] USE="custom-cflags* debian inox jumbo-build* (pic) proprietary-codecs suid system-icu thin-lto%* -component-build -cups -gnome-keyring -hangouts -kerberos (-neon) -pulseaudio (-selinux) (-system-ffmpeg*) (-system-libvpx) (-tcmalloc) -vaapi -widevine (-iridium%) (-ungoogled%)" L10N="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW" 0 KiB

withe the same result (ninja mksnapshot failed).
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Thu Jun 14, 2018 8:05 am    Post subject: Reply with quote

disable USE=thin-lto
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 442
Location: Earth

PostPosted: Thu Jun 14, 2018 3:51 pm    Post subject: Reply with quote

Perfect Gentleman wrote:
disable USE=thin-lto


this is confusing, somehow, because for me it works with
Code:
thin-lto


And newer Versions of chromium compiles only with newer Clang >=clang-6.0.0 - imo!

thx @ Perfect Gentleman for the overlay 8)
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 738

PostPosted: Thu Jun 14, 2018 8:31 pm    Post subject: Reply with quote

Still fails in the same place. This is clang-5.0.2 here.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Fri Jun 15, 2018 12:36 am    Post subject: Reply with quote

Code:
sudo USE="custom-cflags debian inox jumbo-build proprietary-codecs suid system-icu thin-lto -component-build -cups -gnome-keyring -hangouts -kerberos -pulseaudio -system-ffmpeg -system-libvpx -tcmalloc vaapi -widevine" ebuild /usr/portage/overlay/pg_overlay/www-client/chromium/chromium-67.0.3396.87.ebuild clean configure
...
Done. Made 8452 targets from 1531 files in 2085ms
>>> Source configured.

Code:
 ~ $ qlist -Iv nodejs
net-libs/nodejs-10.4.0

~ $ qlist -Iv clang
sys-devel/clang-6.0.0-r1
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2319
Location: Germania

PostPosted: Fri Jun 15, 2018 12:42 pm    Post subject: Reply with quote

Princess Nell you may try with FEATURES="-usersandbox"

See bugreport (comment #14 ff) here: https://bugs.gentoo.org/640174#c14
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Fri Jun 15, 2018 12:51 pm    Post subject: Reply with quote

imo, it's better not to use chromium from my overlay on stable branch.
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 738

PostPosted: Sun Jun 17, 2018 8:40 pm    Post subject: Reply with quote

clang-6 did the trick. Thanks.
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 442
Location: Earth

PostPosted: Wed Aug 01, 2018 8:28 pm    Post subject: Reply with quote

New Version works great here with NF (widevine)

thx to pg :D

Code:
chromium-68.0.3440.76


Code:
real   44m36.799s
user   288m40.604s
sys   6m27.276s


emerged with ccache :!:
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2319
Location: Germania

PostPosted: Fri Sep 07, 2018 10:56 am    Post subject: Reply with quote

What is the best useflag combination of debian, inox and ungoogled to build chromium-69 from pg_overlay?

Any patch clashes between them?

___
I need widevine, which applies widevine patch. AFAIK it is wise to apply debian and inox or ungoogled patchsets. Though, these apply widevine patches again. JFYI, Inox is missing the series file, therefore patches skipped anyway. I wonder if that is intended since ungoogled applies inox patches.

Not too difficult to tweak series files not to apply widevine patches again, though.
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Fri Sep 07, 2018 11:31 am    Post subject: Reply with quote

Quote:
What is the best useflag combination of debian, inox and ungoogled to build chromium-69 from pg_overlay?

ungoogled or inox. now inox includes debian patchset.
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 442
Location: Earth

PostPosted: Sat Sep 15, 2018 3:07 pm    Post subject: Reply with quote

@ Perfect Gentleman

did something changed with current Chromium Version in your Overlay?

It seems that most (inox - debian - ungoogled) patches are not available anymore and widevine patch failed with ' ungoogled ' Use Flag.

last Version which works for me is ' chromium-68.0.3440.118 ' with ' debian and inox ' patches and widevine.

thx
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Sun Sep 16, 2018 1:55 pm    Post subject: Reply with quote

@CooSee, there is smth wrong with Inox patches from Ungoogled. I can't make Chromium-69 work. It can be compiled but always "Aborted".
If it does't work till 'morrow, I'll drop Chromium-69.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2319
Location: Germania

PostPosted: Sun Sep 16, 2018 2:33 pm    Post subject: Reply with quote

chromium
Quote:
Version 69.0.3497.87 (Entwickler-Build) (64-Bit)
(from pg_overlay) works fine with inox and debian patchsets here. Though, I need one more patch from ungoogled to make it compile.
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Sun Sep 16, 2018 2:37 pm    Post subject: Reply with quote

geki wrote:
Though, I need one more patch from ungoogled to make it compile.

Why not to pull-request it?
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 442
Location: Earth

PostPosted: Sun Sep 16, 2018 2:40 pm    Post subject: Reply with quote

@ Perfect Gentleman

thx for reply :-)

i'll wait until it's fixed.
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2319
Location: Germania

PostPosted: Sun Sep 16, 2018 7:13 pm    Post subject: Reply with quote

Perfect Gentleman
no pull-request for trivial matters. AFAIS I recommend ungoogled over debian and inox patchsets; as ungoogled has debian and inox patchsets included, has it not?
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 233

PostPosted: Thu Sep 20, 2018 1:16 am    Post subject: Reply with quote

Tried to compile chromium-69.0.3497.95 and got this

Code:
[14830/14830] python "../../build/toolchain/gcc_link_wrapper.py" --output="./v8_context_snapshot_generator" -- x86_64-pc-linux-gnu-clang++ -fPIC -Wl,-z,noexecstack -Wl,-z,now -Wl,-z,relro -Wl,-z,defs -Wl,--no-as-needed -fuse-ld=lld -Wl,--icf=all -Wl,--color-diagnostics -rdynamic -Wl,-rpath-link=. -Wl,--disable-new-dtags -Wl,--icf=none -Wl,-O1 -Wl,--as-needed -o "./v8_context_snapshot_generator" -Wl,--start-group @"./v8_context_snapshot_generator.rsp"  -Wl,--end-group   -latomic -ldl -lpthread -lrt -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4 -levent -ljpeg -lpng16 -lz -lxml2 -lxslt -lm -lresolv -lX11 -lX11-xcb -lxcb -lXcomposite -lXcursor -lXdamage -lXext -lXfixes -lXi -lXrender -lXtst -lfreetype -lharfbuzz -lfontconfig -lwebpdemux -lwebpmux -lwebp -lexpat -ldrm -lXrandr -lpangocairo-1.0 -lpango-1.0 -lcairo -lXss -lasound -lpulse -lre2 -lsnappy -lpci -ldbus-1
FAILED: v8_context_snapshot_generator
python "../../build/toolchain/gcc_link_wrapper.py" --output="./v8_context_snapshot_generator" -- x86_64-pc-linux-gnu-clang++ -fPIC -Wl,-z,noexecstack -Wl,-z,now -Wl,-z,relro -Wl,-z,defs -Wl,--no-as-needed -fuse-ld=lld -Wl,--icf=all -Wl,--color-diagnostics -rdynamic -Wl,-rpath-link=. -Wl,--disable-new-dtags -Wl,--icf=none -Wl,-O1 -Wl,--as-needed -o "./v8_context_snapshot_generator" -Wl,--start-group @"./v8_context_snapshot_generator.rsp"  -Wl,--end-group   -latomic -ldl -lpthread -lrt -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lsmime3 -lnss3 -lnssutil3 -lplds4 -lplc4 -lnspr4 -levent -ljpeg -lpng16 -lz -lxml2 -lxslt -lm -lresolv -lX11 -lX11-xcb -lxcb -lXcomposite -lXcursor -lXdamage -lXext -lXfixes -lXi -lXrender -lXtst -lfreetype -lharfbuzz -lfontconfig -lwebpdemux -lwebpmux -lwebp -lexpat -ldrm -lXrandr -lpangocairo-1.0 -lpango-1.0 -lcairo -lXss -lasound -lpulse -lre2 -lsnappy -lpci -ldbus-1
/usr/bin/ld.lld: error: undefined symbol: vaGetDisplay
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_create) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaGetDisplayDRM
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_create) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaGetDisplayDRM
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_derive) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaMaxNumImageFormats
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_init) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaQueryImageFormats
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_init) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaQueryVendorString
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_init) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaQuerySurfaceAttributes
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_get_constraints) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaErrorStr
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_get_constraints) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaQuerySurfaceAttributes
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_get_constraints) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaErrorStr
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_get_constraints) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaDeriveImage
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_init) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaErrorStr
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_init) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaDestroyImage
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_frames_init) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaTerminate
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_free) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaSetErrorCallback
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_connect) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaSetInfoCallback
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_connect) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaInitialize
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_connect) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaErrorStr
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_device_connect) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaCreateSurfaces
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_pool_alloc) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: undefined symbol: vaErrorStr
>>> referenced by hwcontext_vaapi.c
>>>               ffmpeg_internal/hwcontext_vaapi.o:(vaapi_pool_alloc) in archive obj/third_party/ffmpeg/libffmpeg_internal.a

/usr/bin/ld.lld: error: too many errors emitted, stopping now (use -error-limit=0 to see all errors)
clang-6.0: error: linker command failed with exit code 1 (use -v to see invocation)
ninja: build stopped: subcommand failed.


use flags
Code:
[ebuild  N    #] www-client/chromium-69.0.3497.95::pg_overlay  USE="custom-cflags (pic) pulseaudio vaapi -component-build -cups -gnome-keyring -hangouts -jumbo-build -kerberos (-neon) -proprietary-codecs (-selinux) -suid (-system-ffmpeg) (-system-icu) (-system-libvpx) (-tcmalloc) -thin-lto -widevine" L10N="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW"


on a side note ccache didn't work at all. this is from building it twice in a row.
Code:
cache directory                     /x/chromium_build/.ccache
primary config                      /x/chromium_build/.ccache/ccache.conf
secondary config      (readonly)    /etc/ccache.conf
stats zero time                     Wed Sep 19 14:13:57 2018
cache hit (direct)                     2
cache hit (preprocessed)               0
cache miss                         27169
cache hit rate                      0.01 %
called for link                      206
called for preprocessing             144
compile failed                        10
preprocessor error                    92
no input file                       1620
cleanups performed                     0
files in cache                    107634
cache size                           2.1 GB
max cache size                       3.0 GB
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2319
Location: Germania

PostPosted: Thu Sep 20, 2018 6:16 am    Post subject: Reply with quote

Saundersx
that can be solved by: (the path referenced is within WORKDIR.)
https://github.com/perfect7gentleman/pg_overlay/issues/42

then simply do
Code:
ebuild /path/to/chromium.ebuild merge
to finish build.
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 233

PostPosted: Thu Sep 20, 2018 6:02 pm    Post subject: Reply with quote

Thanks for the suggestion. That worked for me after I added a bunch more "-lvdpau -lva -lva-drm -lva-x11" as -lva itself wasn't enough. So it got further until this issue popped up https://bugs.gentoo.org/666266 . Guess I'll update gcc and clang and try again.

Also after some reading I got ccache working, way way faster compile time considering it was the same version. This is my /etc/portage/env/chromium.conf now.
Code:
CCACHE_SIZE="3G"
CCACHE_DIR="/x/chromium_build/.ccache"
CCACHE_COMPRESS="true"
CCACHE_SLOPPINESS="file_macro,time_macros,include_file_mtime,include_file_ctime,file_stat_matches,pch_defines"
IND_CACHE=yes
PORTAGE_TMPDIR="/x/chromium_build/build"
MAKEOPTS="-j8"
FEATURES="ccache nodoc noinfo"
DISTCC_HOSTS=""
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 747

PostPosted: Sat Sep 22, 2018 3:39 am    Post subject: Reply with quote

anyone here builds Chromium-69 with LLVM/Clang-7.0 ?
Back to top
View user's profile Send private message
Saundersx
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 233

PostPosted: Sun Sep 23, 2018 5:30 am    Post subject: Reply with quote

Perfect Gentleman wrote:
anyone here builds Chromium-69 with LLVM/Clang-7.0 ?


Yep, aside from the -lva issue it compiled and appears to work fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum