Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ncurses-6.1-r2 shows wrong characters
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
saski4711
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2004
Posts: 76

PostPosted: Fri Jun 08, 2018 6:59 am    Post subject: ncurses-6.1-r2 shows wrong characters Reply with quote

Hi,

after updating to latest ncurses:

Code:

sys-libs/ncurses-6.1-r2:0/6::gentoo  USE="cxx threads unicode -ada -debug -doc -gpm -minimal -profile -static-libs {-test} -tinfo -trace" ABI_X86="32 (64) (-x32)" 3,287 KiB


I get issues displaying curses frontends like midnight commander: https://ibb.co/jFZJL8

Any ideas what's wrong?

Regards
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19053
Location: here

PostPosted: Fri Jun 08, 2018 7:13 am    Post subject: Reply with quote

What locale you set in your system?
If you run mc with command line
Code:
$ LANG=C mc

characters are correct?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
saski4711
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2004
Posts: 76

PostPosted: Fri Jun 08, 2018 7:22 am    Post subject: Reply with quote

fedeliallalinea wrote:
What locale you set in your system?
If you run mc with command line
Code:
$ LANG=C mc

characters are correct?


Hi,
yeah that did it! LANG is set to
Code:
declare -x LANG="en_US.utf8"

what's wrong with that?
Back to top
View user's profile Send private message
saski4711
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jun 2004
Posts: 76

PostPosted: Fri Jun 08, 2018 8:30 am    Post subject: Reply with quote

Ok I've changed LANG in /etc/env.d/02locale from
Code:
LANG="en_US.utf8"

to
Code:
LANG="en_US.utf8 C"


that made it permanent.

Thx for the support! :D
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19053
Location: here

PostPosted: Fri Jun 08, 2018 8:31 am    Post subject: Reply with quote

saski4711 wrote:
what's wrong with that?

Nothing, I also have this and mc work correctly
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 5887
Location: Room 101

PostPosted: Fri Jun 08, 2018 9:45 am    Post subject: Reply with quote

saski4711 wrote:
Code:
LANG="en_US.utf8 C"

saski4711 ... that is incorrect, LANG is a single value, it's not an array.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum